summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2004-12-15 09:47:36 +0000
committerAndrej Kacian <ticho@gentoo.org>2004-12-15 09:47:36 +0000
commit9dbf3efceb34d0152daed6fa7636ed1ab890b5de (patch)
treea8c79c8ddc89b80dd9087b97db9349be290eb97e /net-mail
parenttouch (diff)
downloadhistorical-9dbf3efceb34d0152daed6fa7636ed1ab890b5de.tar.gz
historical-9dbf3efceb34d0152daed6fa7636ed1ab890b5de.tar.bz2
historical-9dbf3efceb34d0152daed6fa7636ed1ab890b5de.zip
Initial import. Closes #73364.
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/popick/ChangeLog11
-rw-r--r--net-mail/popick/Manifest14
-rw-r--r--net-mail/popick/files/digest-popick-0.11
-rw-r--r--net-mail/popick/metadata.xml6
-rw-r--r--net-mail/popick/popick-0.1.ebuild36
5 files changed, 68 insertions, 0 deletions
diff --git a/net-mail/popick/ChangeLog b/net-mail/popick/ChangeLog
new file mode 100644
index 000000000000..52bb3fe0a552
--- /dev/null
+++ b/net-mail/popick/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-mail/popick
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/popick/ChangeLog,v 1.1 2004/12/15 09:47:36 ticho Exp $
+
+*popick-0.1 (15 Dec 2004)
+
+ 15 Dec 2004; Andrej Kacian <ticho@gentoo.org> +metadata.xml,
+ +popick-0.1.ebuild:
+ Initial import. Closes #73364, ebuild submitted by Mina Naguib
+ <webmaster@topfx.com>.
+
diff --git a/net-mail/popick/Manifest b/net-mail/popick/Manifest
new file mode 100644
index 000000000000..ec1a8b7b9975
--- /dev/null
+++ b/net-mail/popick/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 e12aeabfea98033a1919dfc2677c42bc ChangeLog 405
+MD5 87eba79fbf4b0474e5a4e051b246e23e metadata.xml 293
+MD5 057e0cce6d677fdb875c59e860a68883 popick-0.1.ebuild 940
+MD5 3e21fe6a5a10b9c37ca7eeab20dbe427 files/digest-popick-0.1 60
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.6 (GNU/Linux)
+
+iD8DBQFBwAhDQlM6RnzZP+IRAnzFAJwI1Sq4xwv232CzV9BePTDaJBSb9gCeNEhq
+uyyWwNopsPE31OUAsrJr9So=
+=EDUQ
+-----END PGP SIGNATURE-----
diff --git a/net-mail/popick/files/digest-popick-0.1 b/net-mail/popick/files/digest-popick-0.1
new file mode 100644
index 000000000000..5a11eac5cb66
--- /dev/null
+++ b/net-mail/popick/files/digest-popick-0.1
@@ -0,0 +1 @@
+MD5 6e475c0b6f3c4d37a7fefc9eb7fcec05 popick-0.1.tar.gz 4000
diff --git a/net-mail/popick/metadata.xml b/net-mail/popick/metadata.xml
new file mode 100644
index 000000000000..991a7b55bdc4
--- /dev/null
+++ b/net-mail/popick/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <longdescription>An interactive, curses-based POP3 mail deleter that allows you to match messages with regexes.</longdescription>
+</pkgmetadata>
diff --git a/net-mail/popick/popick-0.1.ebuild b/net-mail/popick/popick-0.1.ebuild
new file mode 100644
index 000000000000..0390368ef8e2
--- /dev/null
+++ b/net-mail/popick/popick-0.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/popick/popick-0.1.ebuild,v 1.1 2004/12/15 09:47:36 ticho Exp $
+
+inherit eutils
+
+DESCRIPTION="A POP3 mailbox deleter that allows you to interactively specify regular expressions to match the message headers, and delete matching messages."
+HOMEPAGE="http://www.topfx.com"
+SRC_URI="http://www.topfx.com/dist/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+ dev-perl/Curses-UI
+ dev-perl/Getopt-Long"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ mv popick.pl popick || die "Renaming popick.pl to popick"
+ sed -i -e 's:/usr/local:/usr:g' $(grep -rl /usr/local *) || die "sed /usr/local failed"
+}
+
+src_compile() {
+ # No compiling needed :)
+ pod2man popick > popick.1 || die "Generating manpage failed"
+}
+
+src_install() {
+ dobin popick
+ doman popick.1
+}