summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Fitzgerald <gregf@gentoo.org>2003-11-20 01:01:05 +0000
committerGreg Fitzgerald <gregf@gentoo.org>2003-11-20 01:01:05 +0000
commit704031f5f81cdab8ec920abdd6eaa5b6eb3e671f (patch)
treee7cceac74bcae8d505e43b45d60a841982b1563c /net-mail/tpop3d
parentVersion bump. (diff)
downloadhistorical-704031f5f81cdab8ec920abdd6eaa5b6eb3e671f.tar.gz
historical-704031f5f81cdab8ec920abdd6eaa5b6eb3e671f.tar.bz2
historical-704031f5f81cdab8ec920abdd6eaa5b6eb3e671f.zip
Version bump.
Diffstat (limited to 'net-mail/tpop3d')
-rw-r--r--net-mail/tpop3d/Manifest4
-rw-r--r--net-mail/tpop3d/files/digest-tpop3d-1.5.22
-rw-r--r--net-mail/tpop3d/files/tpop3d-1.5.2-fix-AV-problem.patch36
-rw-r--r--net-mail/tpop3d/tpop3d-1.5.2.ebuild84
4 files changed, 124 insertions, 2 deletions
diff --git a/net-mail/tpop3d/Manifest b/net-mail/tpop3d/Manifest
index 2da1ee9371fc..01b5df2430dc 100644
--- a/net-mail/tpop3d/Manifest
+++ b/net-mail/tpop3d/Manifest
@@ -1,7 +1,7 @@
-MD5 0882970251dcc3eba07b1631b49bd6f8 ChangeLog 1196
+MD5 317eee2f7fd0b487b9c94037ab84e932 ChangeLog 1197
MD5 5721b86fd871bdfab77231abc6e02f68 metadata.xml 161
MD5 ae128b31e721c7c03164bb01c891739e tpop3d-1.4.2.ebuild 2455
-MD5 296f43281e6fe2479ff270109e3ee1c8 tpop3d-1.5.2.ebuild 2558
+MD5 152ce52e71401e8ceb0dbc05ef5eecd3 tpop3d-1.5.2.ebuild 2555
MD5 70073dfbe2bd93a7922b97c4f4cd3af2 files/digest-tpop3d-1.4.2 145
MD5 9190b714d11bf56eaa8488012a167b70 files/tpop3d-init 702
MD5 b40cd6aa6ab9186588d4c6ab10167a8f files/tpop3d-1.5.2-fix-AV-problem.patch 1710
diff --git a/net-mail/tpop3d/files/digest-tpop3d-1.5.2 b/net-mail/tpop3d/files/digest-tpop3d-1.5.2
new file mode 100644
index 000000000000..fa86fdfc7eb4
--- /dev/null
+++ b/net-mail/tpop3d/files/digest-tpop3d-1.5.2
@@ -0,0 +1,2 @@
+MD5 1bd2fa0a8a0da9d7ee0f4c5723006631 tpop3d-1.5.2.tar.gz 235769
+MD5 b40cd6aa6ab9186588d4c6ab10167a8f tpop3d-1.5.2-fix-AV-problem.patch 1710
diff --git a/net-mail/tpop3d/files/tpop3d-1.5.2-fix-AV-problem.patch b/net-mail/tpop3d/files/tpop3d-1.5.2-fix-AV-problem.patch
new file mode 100644
index 000000000000..b634b61e2d63
--- /dev/null
+++ b/net-mail/tpop3d/files/tpop3d-1.5.2-fix-AV-problem.patch
@@ -0,0 +1,36 @@
+--- connection.c 14 Jul 2003 23:31:20 -0000 1.49
++++ connection.c 30 Sep 2003 18:52:19 -0000
+@@ -381,9 +381,30 @@
+ * Send a +OK... / -ERR... response to a message. Returns 1 on success or 0 on
+ * failure. */
+ int connection_sendresponse(connection c, const int success, const char *s) {
+- if (connection_send(c, success ? "+OK " : "-ERR ", success ? 4 : 5)
+- && connection_send(c, s, strlen(s))
+- && connection_send(c, "\r\n", 2)) {
++ /*
++ * For efficiency's sake, we should send this bit-by-bit, avoiding another
++ * buffer copy. But unfortunately, there are POP3 clients in the world
++ * so stupid that they assume a whole response will arrive in a single TCP
++ * segment. Particular examples include POP3 virus-scanning proxies, such
++ * as Norman ASA's, which was evidently written by somebody very lazy.
++ *
++ * Obviously there's no way to guarantee how the packets in a TCP stream
++ * are disposed, in general, but we can increase the probability of success
++ * by trying to ensure here that our response is contained in a single
++ * write call. It still might get split up by the ioabs layer, but we have
++ * to take our chances....
++ */
++ static char *buf;
++ static size_t buflen;
++ size_t l;
++
++ l = (success ? 6 : 7) + strlen(s);
++
++ if (!buf || buflen < l + 1)
++ buf = xrealloc(buf, buflen = l + 1);
++
++ sprintf(buf, "%s %s\r\n", success ? "+OK" : "-ERR", s);
++ if (connection_send(c, buf, l)) {
+ if (verbose)
+ log_print(LOG_DEBUG, _("connection_sendresponse: client %s: sent %s %s'"), c->idstr, success ? "+OK" : "-ERR", s);
+ return 1;
diff --git a/net-mail/tpop3d/tpop3d-1.5.2.ebuild b/net-mail/tpop3d/tpop3d-1.5.2.ebuild
new file mode 100644
index 000000000000..edbf3eb1da6b
--- /dev/null
+++ b/net-mail/tpop3d/tpop3d-1.5.2.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/tpop3d/tpop3d-1.5.2.ebuild,v 1.1 2003/11/20 01:01:02 gregf Exp $
+
+DESCRIPTION="An extensible POP3 server with vmail-sql/MySQL support."
+HOMEPAGE="http://www.ex-parrot.com/~chris/tpop3d/"
+SRC_URI="http://www.ex-parrot.com/~chris/tpop3d/${P}.tar.gz
+ ftp://callagur.burningturtle.com/pub/ebuilds/tpop3d/tpop3d-1.5.2-fix-AV-problem.patch"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="ssl ldap mysql perl pam tcpd maildir debug"
+
+DEPEND="virtual/glibc
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ ldap? ( >=net-nds/openldap-2.0.7 )
+ mysql? ( >=dev-db/mysql-3.23.28 )
+ perl? ( >=dev-lang/perl-5.6.1 )
+ pam? ( >=sys-libs/pam-0.75 )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+ epatch ${DISTDIR}/${P}-fix-AV-problem.patch
+}
+
+src_compile() {
+ local myconf
+ use mysql && myconf="--enable-auth-mysql"
+ use ldap && myconf="${myconf} --enable-auth-ldap"
+ use perl && myconf="${myconf} --enable-auth-perl"
+ use tcpd && myconf="${myconf} --enable-tcp-wrappers"
+ use pam || myconf="${myconf} --disable-auth-pam"
+ use maildir && myconf="${myconf} --enable-mbox-maildir"
+ # If you want plaintext /etc/passwd authentication
+ if [ ! -z $ENABLE_PASSWD ]; then
+ myconf="${myconf} --enable-auth-passwd"
+ fi
+ # If you want to use /etc/shadow instead.
+ # Make sure you also set $ENABLE_PASSWD
+ if [ ! -z $ENABLE_SHADOW ]; then
+ myconf="${myconf} --enable-shadow-passwords"
+ fi
+ # authenticate against any passwd-like file
+ if [ ! -z $ENABLE_FLATFILE ]; then
+ myconf="${myconf} --enable-auth-flatfile"
+ fi
+ # authenticate via an external program
+ if [ ! -z $ENABLE_OTHER ]; then
+ myconf="${myconf} --enable-auth-other"
+ fi
+ # Make it Rated G and safe for the kids
+ if [ ! -z $BE_NICE ]; then
+ myconf="${myconf} --disable-snide-comments"
+ fi
+ # Install net-mail/drac for integration with tpop3d
+ if [ ! -a $ENABLE_DRAC ]; then
+ myconf="${myconf} --enable-drac"
+ fi
+ if [ `use debug` ]; then
+ myconf="${myconf} --enable-electric-fence --enable-backtrace"
+ fi
+ econf ${myconf} || die "./configure failed"
+
+ # Add in custom CFLAGS to the makefile...
+ sed -i "s/CFLAGS =/CFLAGS = ${CFLAGS} /" Makefile
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodir /etc/tpop3d
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/tpop3d-init
+}
+
+pkg_postinst() {
+ einfo "Read the tpop3d.conf manpage"
+ einfo "Please create /etc/tpop3d/tpop3d.conf to fit your Configuration"
+}