summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2003-01-10 18:43:08 +0000
committerArcady Genkin <agenkin@gentoo.org>2003-01-10 18:43:08 +0000
commit9e7840fd21c418bf8df63e1b9d9c5fd6f79b3cf0 (patch)
tree6e88a427478e3baa1187cfc00ac7dbad27b70e5c /net-mail/tmda
parentadded helper scripts... Fixes #13525 (diff)
downloadhistorical-9e7840fd21c418bf8df63e1b9d9c5fd6f79b3cf0.tar.gz
historical-9e7840fd21c418bf8df63e1b9d9c5fd6f79b3cf0.tar.bz2
historical-9e7840fd21c418bf8df63e1b9d9c5fd6f79b3cf0.zip
New version. Masked till Gentoo freezes over. ;^)
Diffstat (limited to 'net-mail/tmda')
-rw-r--r--net-mail/tmda/ChangeLog7
-rw-r--r--net-mail/tmda/files/digest-tmda-0.681
-rw-r--r--net-mail/tmda/tmda-0.68.ebuild66
3 files changed, 73 insertions, 1 deletions
diff --git a/net-mail/tmda/ChangeLog b/net-mail/tmda/ChangeLog
index 24e113b60222..ca2cb26d2e04 100644
--- a/net-mail/tmda/ChangeLog
+++ b/net-mail/tmda/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/tmda
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/tmda/ChangeLog,v 1.24 2003/01/02 21:56:16 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/tmda/ChangeLog,v 1.25 2003/01/10 18:43:08 agenkin Exp $
+
+*tmda-0.68 ( 10 Jan 2003 )
+
+ 10 Jan 2003; Arcady Genkin <agenkin@gentoo.org> :
+ Updated to 0.68.
*tmda-0.67 ( 02 Jan 2003 )
diff --git a/net-mail/tmda/files/digest-tmda-0.68 b/net-mail/tmda/files/digest-tmda-0.68
new file mode 100644
index 000000000000..a03ac844c79d
--- /dev/null
+++ b/net-mail/tmda/files/digest-tmda-0.68
@@ -0,0 +1 @@
+MD5 7f0403bc845ab20335323cb8f22fdbfd tmda-0.68.tgz 295679
diff --git a/net-mail/tmda/tmda-0.68.ebuild b/net-mail/tmda/tmda-0.68.ebuild
new file mode 100644
index 000000000000..2c0e5d5fa188
--- /dev/null
+++ b/net-mail/tmda/tmda-0.68.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2002 Arcady Genkin <agenkin@thpoon.com>
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/tmda/tmda-0.68.ebuild,v 1.1 2003/01/10 18:43:08 agenkin Exp $
+
+DESCRIPTION="Python-based SPAM reduction system"
+HOMEPAGE="http://www.tmda.net/"
+LICENSE="GPL-2"
+
+DEPEND=">=dev-lang/python-2.1
+ virtual/mta"
+
+SRC_URI="http://tmda.net/releases/${P}.tgz
+ http://tmda.net/releases/old/${P}.tgz"
+
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+
+S="${WORKDIR}/${P}"
+
+src_compile () {
+ ./compileall || die
+}
+
+src_install () {
+ # Figure out python version
+ # below hack should be replaced w/ pkg-config, when we get it working
+ local pv=`python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:'`
+
+ # Executables
+ dobin bin/tmda-*
+
+ # The Python TMDA module
+ insinto "/usr/lib/python${pv}/site-packages/TMDA"
+ doins TMDA/*.py*
+ insinto "/usr/lib/python${pv}/site-packages/TMDA/pythonlib/email"
+ doins TMDA/pythonlib/email/*.py*
+
+ # The templates
+ insinto /etc/tmda
+ doins templates/*.txt
+
+ # Documentation
+ dodoc COPYING ChangeLog README THANKS UPGRADE CRYPTO CODENAMES INSTALL
+ dodoc contrib/tmda.spec contrib/sample.config
+ dohtml -r htdocs/*.html
+
+ # Contributed binaries and stuff
+ cd ${S}/contrib
+
+ exeinto /usr/lib/tmda/bin
+ doexe printcdb printdbm collectaddys def2html
+ insinto /usr/lib/tmda/lisp
+ doins tmda.el
+
+ # Not sure what's the best thing to do with tmda-cgi.
+ # For now, installing it in a tarball under /usr/lib/tmda.
+ cd ${S}/contrib
+ tar cjf ${D}/usr/lib/tmda/tmda-cgi.tar.bz2 cgi
+}
+
+pkg_postinst () {
+ einfo
+ einfo "The tmda-cgi stuff has been installed in /usr/lib/tmda-cgi.tar.bz2."
+ einfo "Refer to the README file, included in the tarball."
+ einfo
+}