summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-11-01 22:52:20 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-11-01 22:52:20 +0000
commit890f588eb255b25c61d5b678ff4ded70489d5bfd (patch)
tree2e9edb72e91f13b4825111c3eaac0e923f2d6d6f /net-mail/fetchmail
parentunstable new version (diff)
downloadhistorical-890f588eb255b25c61d5b678ff4ded70489d5bfd.tar.gz
historical-890f588eb255b25c61d5b678ff4ded70489d5bfd.tar.bz2
historical-890f588eb255b25c61d5b678ff4ded70489d5bfd.zip
version bump, ebuild fixes, unstable
Diffstat (limited to 'net-mail/fetchmail')
-rw-r--r--net-mail/fetchmail/ChangeLog8
-rw-r--r--net-mail/fetchmail/fetchmail-6.1.2.ebuild82
-rw-r--r--net-mail/fetchmail/files/digest-fetchmail-6.1.21
3 files changed, 90 insertions, 1 deletions
diff --git a/net-mail/fetchmail/ChangeLog b/net-mail/fetchmail/ChangeLog
index a1b84d68b200..4df9153f10d2 100644
--- a/net-mail/fetchmail/ChangeLog
+++ b/net-mail/fetchmail/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mailfetchmailChangeLog/
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.12 2002/10/23 21:36:20 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.13 2002/11/01 22:52:20 lostlogic Exp $
+
+*fetchmail-6.1.2 (01 Nov 2002)
+
+ 01 Nov 2002; Brandon Low <lostlogic@gentoo.org> fetchmail-6.1.2.ebuild :
+ Refix the manpages so that we don't install un-necessary stuff,
+ version bump, unstable briefly.
*fetchmail-6.1.1 (21 Oct 2002)
diff --git a/net-mail/fetchmail/fetchmail-6.1.2.ebuild b/net-mail/fetchmail/fetchmail-6.1.2.ebuild
new file mode 100644
index 000000000000..44d8af1ccf18
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-6.1.2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.1.2.ebuild,v 1.1 2002/11/01 22:52:20 lostlogic Exp $
+
+IUSE="ssl nls"
+
+S="${WORKDIR}/${P}"
+
+DESCRIPTION="Fetchmail is a full-featured remote-mail retrieval and forwarding utility"
+HOMEPAGE="http://www.tuxedo.org/~esr/fetchmail/"
+SRC_URI="http://www.tuxedo.org/~esr/fetchmail/${P}.tar.gz"
+
+DEPEND="virtual/glibc
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ nls? ( sys-devel/gettext )"
+
+SLOT="0"
+LICENSE="GPL-2 public-domain"
+KEYWORDS="~x86"
+
+src_compile() {
+
+ local myconf
+
+ use ssl && myconf="${myconf} --with-ssl=/usr" \
+ || myconf="${myconf} --without-ssl"
+
+ use nls && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+
+ # This needs inet6-apps, which we don't have
+ #use ipv6 && myconf="${myconf} --enable-inet6 --enable-netsec"
+ # || myconf="${myconf} --disable-inet6 --disable-netsec"
+
+ econf \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ ${myconf} || die "Configuration failed."
+
+ emake || die "Compilation failed."
+
+}
+
+src_install() {
+
+ einstall || die
+
+ dohtml *.html
+
+ dodoc FAQ FEATURES ABOUT-NLS NEWS NOTES README \
+ README.NTLM README.SSL TODO COPYING MANIFEST
+
+ doman /usr/share/man/*.1
+ rm -f ${D}/usr/share/man/*.1
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/fetchmail
+
+ docinto contrib
+ local f
+ for f in contrib/*
+ do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+
+ if ! python -c "import Tkinter" >/dev/null 2>&1
+ then
+ einfo
+ einfo "You will not be able to use fetchmailconf(1), because you"
+ einfo "don't seem to have Python with tkinter support."
+ einfo
+ einfo "If you want to be able to use fetchmailconf(1), do the following:"
+ einfo " 1. Include 'tcltk' in USE variable in your /etc/make.conf."
+ einfo " 2. (Re-)merge Python."
+ einfo
+ fi
+
+}
diff --git a/net-mail/fetchmail/files/digest-fetchmail-6.1.2 b/net-mail/fetchmail/files/digest-fetchmail-6.1.2
new file mode 100644
index 000000000000..eb42c29be7ef
--- /dev/null
+++ b/net-mail/fetchmail/files/digest-fetchmail-6.1.2
@@ -0,0 +1 @@
+MD5 6c617efe83262f0e9d5c0992caab8f72 fetchmail-6.1.2.tar.gz 1122660