summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2003-03-31 19:56:18 +0000
committerJon Portnoy <avenj@gentoo.org>2003-03-31 19:56:18 +0000
commit5e3ce5da3d452e8346cf5f0310127e1df695ac16 (patch)
tree27adc651f1f6fee758f52ecd6aee769588cc3cd0 /net-mail/fetchmail
parentBumped rxvt to a newer version in order to fix compile errors in previous ver... (diff)
downloadhistorical-5e3ce5da3d452e8346cf5f0310127e1df695ac16.tar.gz
historical-5e3ce5da3d452e8346cf5f0310127e1df695ac16.tar.bz2
historical-5e3ce5da3d452e8346cf5f0310127e1df695ac16.zip
init script changes, fixes bug 18546
Diffstat (limited to 'net-mail/fetchmail')
-rw-r--r--net-mail/fetchmail/ChangeLog12
-rw-r--r--net-mail/fetchmail/fetchmail-6.2.2-r1.ebuild8
-rw-r--r--net-mail/fetchmail/files/conf.d-fetchmail8
-rw-r--r--net-mail/fetchmail/files/fetchmail2
4 files changed, 26 insertions, 4 deletions
diff --git a/net-mail/fetchmail/ChangeLog b/net-mail/fetchmail/ChangeLog
index dbb8994fbaa4..3c20b4b155b8 100644
--- a/net-mail/fetchmail/ChangeLog
+++ b/net-mail/fetchmail/ChangeLog
@@ -1,12 +1,20 @@
# ChangeLog for net-mail/fetchmail
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.29 2003/03/31 02:33:15 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.30 2003/03/31 19:56:18 avenj Exp $
+
+*fetchmail-6.2.2-r1 (24 Mar 2003)
+
+ 31 Mar 2003; Jon Portnoy <avenj@gentoo.org> files/fetchmail
+ files/conf.d-fetchmail :
+ Adjusted init scripts to get polling_period from conf.d/fetchmail,
+ fixes bug #18546.
-*fetchmail-6.2.2 (24 Mar 2003)
30 Mar 2003; Jon Portnoy <avenj@gentoo.org> files/fetchmail :
Added -d 60 to close bug #18491
+*fetchmail-6.2.2 (24 Mar 2003)
+
25 Mar 2003; Daniel Robbins <drobbins@gentoo.org> files/fetchmail:
initscript now has "use mta" so that we can begin to close bug #11455.
diff --git a/net-mail/fetchmail/fetchmail-6.2.2-r1.ebuild b/net-mail/fetchmail/fetchmail-6.2.2-r1.ebuild
index f8e8aef2e777..9d15eabec6a1 100644
--- a/net-mail/fetchmail/fetchmail-6.2.2-r1.ebuild
+++ b/net-mail/fetchmail/fetchmail-6.2.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.2.2-r1.ebuild,v 1.1 2003/03/31 02:43:10 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.2.2-r1.ebuild,v 1.2 2003/03/31 19:56:18 avenj Exp $
inherit eutils
@@ -49,6 +49,9 @@ src_install() {
exeinto /etc/init.d
doexe ${FILESDIR}/fetchmail
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/conf.d-fetchmail fetchmail
docinto contrib
local f
@@ -70,4 +73,7 @@ pkg_postinst() {
einfo " 2. (Re-)merge Python."
einfo
fi
+
+ einfo "Please see /etc/conf.d/fetchmail if you want to adjust"
+ einfo "the polling delay used by the fetchmail init script."
}
diff --git a/net-mail/fetchmail/files/conf.d-fetchmail b/net-mail/fetchmail/files/conf.d-fetchmail
new file mode 100644
index 000000000000..354512d4158d
--- /dev/null
+++ b/net-mail/fetchmail/files/conf.d-fetchmail
@@ -0,0 +1,8 @@
+# Copyright 2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/files/conf.d-fetchmail,v 1.1 2003/03/31 19:56:18 avenj Exp $
+
+# Polling frequency in seconds
+# (fetchmail will daemonize and check for new mail at this interval)
+polling_period="60"
+
diff --git a/net-mail/fetchmail/files/fetchmail b/net-mail/fetchmail/files/fetchmail
index d32587a4a1eb..be5067dc57b3 100644
--- a/net-mail/fetchmail/files/fetchmail
+++ b/net-mail/fetchmail/files/fetchmail
@@ -16,7 +16,7 @@ start() {
ebegin "Starting fetchmail"
start-stop-daemon --start --quiet --exec /usr/bin/fetchmail \
- -- -d 60 -f /etc/fetchmailrc
+ -- -d ${polling_period} -f /etc/fetchmailrc
eend ${?}
}