summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-11-13 05:10:33 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-11-13 05:10:33 +0000
commit817d815fc8b08c88f34ed541bc0cdf7996964071 (patch)
treeb118025923c36cc04631ee633c9adf7d5fef001a /net-libs
parentfix for #10471 (diff)
downloadhistorical-817d815fc8b08c88f34ed541bc0cdf7996964071.tar.gz
historical-817d815fc8b08c88f34ed541bc0cdf7996964071.tar.bz2
historical-817d815fc8b08c88f34ed541bc0cdf7996964071.zip
Added the new stable line, marked as testing and reintroduced the USE=ssl variable as current ORBit2 doesn't break then
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/linc/ChangeLog10
-rw-r--r--net-libs/linc/files/digest-linc-0.5.51
-rw-r--r--net-libs/linc/linc-0.5.5.ebuild46
3 files changed, 56 insertions, 1 deletions
diff --git a/net-libs/linc/ChangeLog b/net-libs/linc/ChangeLog
index d0eb9995cbca..4e3bf029dd1d 100644
--- a/net-libs/linc/ChangeLog
+++ b/net-libs/linc/ChangeLog
@@ -1,7 +1,15 @@
# ChangeLog for net-libs/linc
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/linc/ChangeLog,v 1.9 2002/10/27 15:10:34 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/linc/ChangeLog,v 1.10 2002/11/13 05:10:33 spider Exp $
+
+*linc-0.5.5 (13 Nov 2002)
+
+ 13 Nov 2002; Spider <spider@gentoo.org> linc-0.5.5.ebuild :
+ new version in the stable tree. now, is this confusing or what?
+ reinstated the USE="ssl" variable as the compile of recent ORBit2 works with
+ linc built without ssl. Tested the combinations for both builds to make sure.
+
*linc-0.7.0 (27 Oct 2002)
27 Oct 2002; foser <foser@gentoo.org> linc-0.7.0.ebuild :
diff --git a/net-libs/linc/files/digest-linc-0.5.5 b/net-libs/linc/files/digest-linc-0.5.5
new file mode 100644
index 000000000000..5ddd91c2da02
--- /dev/null
+++ b/net-libs/linc/files/digest-linc-0.5.5
@@ -0,0 +1 @@
+MD5 611219ed481b1a891d523a82d82f49e2 linc-0.5.5.tar.bz2 179324
diff --git a/net-libs/linc/linc-0.5.5.ebuild b/net-libs/linc/linc-0.5.5.ebuild
new file mode 100644
index 000000000000..c11317e490d5
--- /dev/null
+++ b/net-libs/linc/linc-0.5.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/linc/linc-0.5.5.ebuild,v 1.1 2002/11/13 05:10:33 spider Exp $
+
+IUSE="doc ssl"
+
+
+inherit libtool gnome.org
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A library to ease the writing of networked applications"
+HOMEPAGE="http://www.gnome.org/"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
+
+RDEPEND=">=dev-libs/glib-2.0.6
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-0.9-r2 )
+ >=dev-util/pkgconfig-0.12.0"
+
+src_compile() {
+ elibtoolize
+ local myconf
+ use doc \
+ && myconf="${myconf} --enable-gtk-doc" \
+ || myconf="${myconf} --disable-gtk-doc"
+
+ # if this is disabled (use) ORBit2 will fail to build. Just force it on
+
+ use ssl \
+ && myconf="${myconf} --with-openssl" \
+ || myconf="${myconf} --without-openssl"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+
+ dodoc AUTHORS ChangeLog COPYING HACKING MAINTAINERS README* NEWS TODO
+}