summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2009-01-29 21:34:05 +0000
committerThomas Sachau <tommy@gentoo.org>2009-01-29 21:34:05 +0000
commit1a41c1756cf9c68a6f555f156d2cd09cf2b9be75 (patch)
tree3168b49c8419b2d80ed1a0ce6ae3b1d2b429f549 /net-libs
parentUse mirror://gentoo (diff)
downloadhistorical-1a41c1756cf9c68a6f555f156d2cd09cf2b9be75.tar.gz
historical-1a41c1756cf9c68a6f555f156d2cd09cf2b9be75.tar.bz2
historical-1a41c1756cf9c68a6f555f156d2cd09cf2b9be75.zip
Initial commit. Fixes bug 238038
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/NativeThread/ChangeLog10
-rw-r--r--net-libs/NativeThread/Manifest5
-rw-r--r--net-libs/NativeThread/NativeThread-0_pre20080330.ebuild33
-rw-r--r--net-libs/NativeThread/files/Makefile.patch22
-rw-r--r--net-libs/NativeThread/metadata.xml9
5 files changed, 79 insertions, 0 deletions
diff --git a/net-libs/NativeThread/ChangeLog b/net-libs/NativeThread/ChangeLog
new file mode 100644
index 000000000000..47f44320f614
--- /dev/null
+++ b/net-libs/NativeThread/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-libs/NativeThread
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/NativeThread/ChangeLog,v 1.1 2009/01/29 21:34:05 tommy Exp $
+
+*NativeThread-0_pre20080330 (29 Jan 2009)
+
+ 29 Jan 2009; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ +files/Makefile.patch, +NativeThread-0_pre20080330.ebuild:
+ Initial commit. Fixes bug 238038
+
diff --git a/net-libs/NativeThread/Manifest b/net-libs/NativeThread/Manifest
new file mode 100644
index 000000000000..055c63012401
--- /dev/null
+++ b/net-libs/NativeThread/Manifest
@@ -0,0 +1,5 @@
+AUX Makefile.patch 759 RMD160 f3a2fc7c3bf6ed178015e85311bd50d84fa0061d SHA1 797a5c7cbc219b1b6147ef578ed48fe66ee2f873 SHA256 3974e6419e2023f6a48fbaf79be80c6fa9ea42b7db2008980497c4814c2b5108
+DIST NativeThread-0_pre20080330.tar.bz2 2707 RMD160 6b93881f53a2ed89096d4a1900c3b48e08cb0201 SHA1 ca68ea04fcb1d9fd9f8aaed34a3e92a1de6539d9 SHA256 ae5277c25420fc76f59d296400c20562e37ff0ad4ecab63e537b9a053ac5802c
+EBUILD NativeThread-0_pre20080330.ebuild 733 RMD160 c5576419ec0d0306a18941a9fc3088749dc7a7aa SHA1 81a0490f62374f1160000aeb3389c480c1ea05b1 SHA256 1e04bc70c9ddc55f52ec6582051a1b4091aadab7e9740f81238d104c7d03fc16
+MISC ChangeLog 413 RMD160 2631853f3ca63888f554120574427e3fe7612bea SHA1 88f20884424863c4baa685823edf8092f82077f1 SHA256 5f2d0c21f230b2e1ea09c5049461bbb2195b94cb8e03948a3ac1aa03f8ac6ff4
+MISC metadata.xml 243 RMD160 7be756104e00991666e4eca8aeec67344ecd58b3 SHA1 ac8db07adeb283df0ee6b8dc8f833c491e756199 SHA256 76e8c4cafe92af4eb083e9682c375a2f887458dac6ce8f2982976a96abcf8219
diff --git a/net-libs/NativeThread/NativeThread-0_pre20080330.ebuild b/net-libs/NativeThread/NativeThread-0_pre20080330.ebuild
new file mode 100644
index 000000000000..901381951b69
--- /dev/null
+++ b/net-libs/NativeThread/NativeThread-0_pre20080330.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/NativeThread/NativeThread-0_pre20080330.ebuild,v 1.1 2009/01/29 21:34:05 tommy Exp $
+
+inherit eutils flag-o-matic java-pkg-2 toolchain-funcs
+
+DESCRIPTION="NativeThread for priorities on linux for freenet"
+HOMEPAGE="http://www.freenetproject.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-p2p/freenet
+ >=virtual/jdk-1.4"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/Makefile.patch
+}
+
+src_compile() {
+ append-flags -fPIC
+ tc-export CC
+ emake || die
+}
+
+src_install() {
+ dolib.so lib${PN}.so || die
+}
diff --git a/net-libs/NativeThread/files/Makefile.patch b/net-libs/NativeThread/files/Makefile.patch
new file mode 100644
index 000000000000..e1f0209a6f3f
--- /dev/null
+++ b/net-libs/NativeThread/files/Makefile.patch
@@ -0,0 +1,22 @@
+--- Makefile 2008-03-03 13:59:06.000000000 +0100
++++ Makefile.new 2008-03-30 16:27:12.000000000 +0200
+@@ -1,14 +1,14 @@
+-CC = gcc
+ INC = $(JAVA_HOME)/include
+-CFLAGS = -Wall -O3 -fPIC
+-LDFLAGS = -shared -Wl,-soname,libnative.so -I$(INC) -I$(INC)/linux
++CFLAGS += -Wall
++LDFLAGS += -shared -Wl,-soname,libnative.so -I$(INC) -I$(INC)/linux
+ LIBS = -lc
+
+ all: clean libNativeThread.so
+
+ NativeThread.class:
+- javac java/NativeThread.java
+- mv java/NativeThread.class freenet/support/io/
++ javac -classpath /usr/share/freenet/lib/freenet.jar NativeThread.java
++ mkdir -p freenet/support/io
++ mv NativeThread.class freenet/support/io/
+
+ libNativeThread.so: NativeThread.c NativeThread.h
+ $(CC) $(CFLAGS) -o libNativeThread.so $(LDFLAGS) NativeThread.c $(LIBS)
diff --git a/net-libs/NativeThread/metadata.xml b/net-libs/NativeThread/metadata.xml
new file mode 100644
index 000000000000..fed3658eec53
--- /dev/null
+++ b/net-libs/NativeThread/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>tommy@gentoo.org</email>
+ <name>Thomas Sachau (Tommy[D])</name>
+ </maintainer>
+</pkgmetadata>
+