summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-03-04 18:35:19 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-03-04 18:35:19 +0000
commit0b4bf945f01c23240f8bfd7b1602a6bd1c565792 (patch)
tree6e35ad97c764c289b9975dcee1953fb8fd5c3ba6 /net-libs
parentadd info in changelog and marking as unstable (diff)
downloadhistorical-0b4bf945f01c23240f8bfd7b1602a6bd1c565792.tar.gz
historical-0b4bf945f01c23240f8bfd7b1602a6bd1c565792.tar.bz2
historical-0b4bf945f01c23240f8bfd7b1602a6bd1c565792.zip
version bump
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/soup/ChangeLog7
-rw-r--r--net-libs/soup/files/digest-soup-0.7.111
-rw-r--r--net-libs/soup/soup-0.7.11.ebuild51
3 files changed, 58 insertions, 1 deletions
diff --git a/net-libs/soup/ChangeLog b/net-libs/soup/ChangeLog
index c3eaa017a703..78e7b8ea8c7a 100644
--- a/net-libs/soup/ChangeLog
+++ b/net-libs/soup/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/soup
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/soup/ChangeLog,v 1.12 2003/03/04 17:55:58 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/soup/ChangeLog,v 1.13 2003/03/04 18:35:19 liquidx Exp $
+
+*soup-0.7.11 (04 Mar 2003)
+
+ 04 Mar 2003; Alastair Tse <liquidx@gentoo.org> soup-0.7.11.ebuild files/digest-soup-0.7.11 :
+ version bump. #16816.
14 Jan 2003; foser <foser@gentoo.org> soup-0.7.10.ebuild soup-0.7.4-r1.ebuild :
Fixed libxml dep (#13817)
diff --git a/net-libs/soup/files/digest-soup-0.7.11 b/net-libs/soup/files/digest-soup-0.7.11
new file mode 100644
index 000000000000..d0f9cca48b8f
--- /dev/null
+++ b/net-libs/soup/files/digest-soup-0.7.11
@@ -0,0 +1 @@
+MD5 61bb2fef816ce164af62f8a3a5bd782e soup-0.7.11.tar.bz2 323824
diff --git a/net-libs/soup/soup-0.7.11.ebuild b/net-libs/soup/soup-0.7.11.ebuild
new file mode 100644
index 000000000000..0f4e940fec91
--- /dev/null
+++ b/net-libs/soup/soup-0.7.11.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/soup/soup-0.7.11.ebuild,v 1.1 2003/03/04 18:35:19 liquidx Exp $
+
+IUSE="ssl doc"
+
+inherit gnome.org libtool
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Soup is a SOAP implementation"
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND=">=dev-util/pkgconfig-0.12.0
+ =dev-libs/glib-1.2*
+ dev-libs/libxml
+ dev-libs/popt
+ ssl? ( dev-libs/openssl )
+ doc? ( >=dev-util/gtk-doc-0.9-r2 )"
+
+LICENSE="GPL-2 | LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha"
+
+src_compile() {
+ elibtoolize
+
+ local myconf=""
+ use ssl \
+ && myconf="--enable-ssl" \
+ || myconf="--disable-ssl"
+
+ use doc \
+ && myconf="${myconf} --enable-gtk-doc" \
+ || myconf="${myconf} --disable-gtk-doc"
+
+ # there is a --enable-apache here.....
+
+ econf \
+ ${myconf} \
+ --with-libxml=1 || die
+ # Evolution 1.1 and 1.2 need it with libxml1
+
+ # dont always work with -j4 -- <azarah@gentoo.org> 9 Nov 2002
+ make || die
+}
+
+src_install() {
+ einstall || die
+
+ dodoc AUTHORS ABOUT-NLS COPYING* ChangeLog README* INSTALL NEWS TODO
+}