summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-03-06 06:20:41 +0000
committerAchim Gottinger <achim@gentoo.org>2001-03-06 06:20:41 +0000
commit3bec718764ff9ac07369bd757a46bef08e73b11f (patch)
tree575bcf9af303123f19cc3ea6ca71c66455f70ae6 /net-libs/libwww
parentUpdates (diff)
downloadhistorical-3bec718764ff9ac07369bd757a46bef08e73b11f.tar.gz
historical-3bec718764ff9ac07369bd757a46bef08e73b11f.tar.bz2
historical-3bec718764ff9ac07369bd757a46bef08e73b11f.zip
Updates and forgotten files
Diffstat (limited to 'net-libs/libwww')
-rw-r--r--net-libs/libwww/libwww-5.3.2-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-libs/libwww/libwww-5.3.2-r1.ebuild b/net-libs/libwww/libwww-5.3.2-r1.ebuild
new file mode 100644
index 000000000000..76924a76ade2
--- /dev/null
+++ b/net-libs/libwww/libwww-5.3.2-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libwww/libwww-5.3.2-r1.ebuild,v 1.1 2001/03/06 06:20:41 achim Exp $
+
+A=w3c-${P}.tar.gz
+S=${WORKDIR}/w3c-${P}
+DESCRIPTION="A general-purpose client side WEB API"
+SRC_URI="http://www.w3.org/Library/Distribution/${A}"
+HOMEPAGE="http://www.w3.org/Library/"
+
+DEPEND="virtual/glibc sys-devel/perl
+ >=sys-libs/zlib-1.1.3
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+RDEPEND="virtual/glibc
+ >=sys-libs/zlib-1.1.3"
+
+src_compile() {
+
+ local myconf
+
+ if [ "`use mysql`" ]
+ then
+ myconf="--with-mysql"
+ fi
+
+ if [ "`use ssl`" ]
+ then
+ myconf="${myconf} --with-ssl"
+ fi
+
+ try ./configure --prefix=/usr --host=${CHOST} --with-zlib \
+ --with-md5 --with-expat ${myconf}
+ try make
+
+}
+
+src_install () {
+
+ cd ${S}
+ try make prefix=${D}/usr install
+ dodoc COPYRIGH ChangeLog
+ docinto html
+ dodoc *.html
+
+}
+