summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-06-15 13:51:23 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-06-15 13:51:23 +0000
commit81b1f854dfb2d963d29038d386d1f35f38104417 (patch)
tree630b8e10d571b16b285ca67cf03aff29aeb746fc /net-libs/libosmocore
parentBump network to 2.3.0.14 (diff)
downloadhistorical-81b1f854dfb2d963d29038d386d1f35f38104417.tar.gz
historical-81b1f854dfb2d963d29038d386d1f35f38104417.tar.bz2
historical-81b1f854dfb2d963d29038d386d1f35f38104417.zip
Initial commit, based in part on ebuild by Peter Stuge.
Package-Manager: portage-2.2.0_alpha110/cvs/Linux x86_64
Diffstat (limited to 'net-libs/libosmocore')
-rw-r--r--net-libs/libosmocore/ChangeLog11
-rw-r--r--net-libs/libosmocore/Manifest5
-rw-r--r--net-libs/libosmocore/libosmocore-0.4.2.ebuild42
-rw-r--r--net-libs/libosmocore/libosmocore-9999.ebuild42
-rw-r--r--net-libs/libosmocore/metadata.xml12
5 files changed, 112 insertions, 0 deletions
diff --git a/net-libs/libosmocore/ChangeLog b/net-libs/libosmocore/ChangeLog
new file mode 100644
index 000000000000..1ecd0187686e
--- /dev/null
+++ b/net-libs/libosmocore/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-libs/libosmocore
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libosmocore/ChangeLog,v 1.1 2012/06/15 13:51:23 chithanh Exp $
+
+*libosmocore-0.4.2 (15 Jun 2012)
+*libosmocore-9999 (15 Jun 2012)
+
+ 15 Jun 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +libosmocore-0.4.2.ebuild, +libosmocore-9999.ebuild, +metadata.xml:
+ Initial commit, based in part on ebuild by Peter Stuge.
+
diff --git a/net-libs/libosmocore/Manifest b/net-libs/libosmocore/Manifest
new file mode 100644
index 000000000000..6e683e7ec720
--- /dev/null
+++ b/net-libs/libosmocore/Manifest
@@ -0,0 +1,5 @@
+DIST libosmocore-0.4.2.tar.bz2 259243 RMD160 63981dbb678e8c5ac4ae3da533dece0f6b8814aa SHA1 ff73e3fd4c7d27277eac9b40594c113b58328642 SHA256 8ed5d9727f5115a9637c1a84c5d10f950200bfe8907f641066ba3c79afce2f67
+EBUILD libosmocore-0.4.2.ebuild 988 RMD160 4e58716b873b16b3c69b950f48e03940c9cc0741 SHA1 e704f7db0db826fdd7c3aaf758992f23b25f772b SHA256 929fedf622c8e7e0bfe110b314cacc6b2da28bb58faa0a7863824713f7e5b1f6
+EBUILD libosmocore-9999.ebuild 987 RMD160 65e30b8a95f11a3334faddbd694c0b53eab19c91 SHA1 e696137fa900bf876034d198253cdb0106a1dfa0 SHA256 e1a3b487b836731334d89d4c9800f0cd19dd6f44a42d6810ff90745928aa2f6a
+MISC ChangeLog 479 RMD160 4a981f01be5128dde4e08ae648fd69842dd2af46 SHA1 188fa0d6a52f5a09244704d6ef31b4b5920228b5 SHA256 75b481a58210e46e4e2f4e236b1cae1f74d8abc9de4dd6a1293b036e65f44ed0
+MISC metadata.xml 355 RMD160 3c5e7e9cad447e355585a062deffb861ca525bff SHA1 38e408218292c93ef8765edf08e399bad2fe5db3 SHA256 e03c2a214c14669d427aab7b519597a4dde03cacb10732249a08ed9f903d4591
diff --git a/net-libs/libosmocore/libosmocore-0.4.2.ebuild b/net-libs/libosmocore/libosmocore-0.4.2.ebuild
new file mode 100644
index 000000000000..478ba0e7f75c
--- /dev/null
+++ b/net-libs/libosmocore/libosmocore-0.4.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libosmocore/libosmocore-0.4.2.ebuild,v 1.1 2012/06/15 13:51:23 chithanh Exp $
+
+EAPI="4"
+inherit autotools
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-2
+ SRC_URI=""
+ EGIT_REPO_URI="git://git.osmocom.org/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="http://cgit.osmocom.org/cgit/libosmocore/snapshot/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Utility functions for OsmocomBB, OpenBSC and related projects"
+HOMEPAGE="http://bb.osmocom.org/trac/wiki/libosmocore"
+
+LICENSE="GPL-2 LGPL-3"
+SLOT="0"
+IUSE="embedded"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-doc/doxygen"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable embedded)
+}
+
+src_install() {
+ default
+ # install to correct documentation directory
+ mv "${ED}"/usr/share/doc/${PN}/${PN}-* "${ED}"/usr/share/doc/${PF} || die
+ rmdir "${ED}"/usr/share/doc/${PN}/ || die
+}
diff --git a/net-libs/libosmocore/libosmocore-9999.ebuild b/net-libs/libosmocore/libosmocore-9999.ebuild
new file mode 100644
index 000000000000..f6248abfbf78
--- /dev/null
+++ b/net-libs/libosmocore/libosmocore-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libosmocore/libosmocore-9999.ebuild,v 1.1 2012/06/15 13:51:23 chithanh Exp $
+
+EAPI="4"
+inherit autotools
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-2
+ SRC_URI=""
+ EGIT_REPO_URI="git://git.osmocom.org/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="http://cgit.osmocom.org/cgit/libosmocore/snapshot/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Utility functions for OsmocomBB, OpenBSC and related projects"
+HOMEPAGE="http://bb.osmocom.org/trac/wiki/libosmocore"
+
+LICENSE="GPL-2 LGPL-3"
+SLOT="0"
+IUSE="embedded"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-doc/doxygen"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable embedded)
+}
+
+src_install() {
+ default
+ # install to correct documentation directory
+ mv "${ED}"/usr/share/doc/${PN}/${PN}-* "${ED}"/usr/share/doc/${PF} || die
+ rmdir "${ED}"/usr/share/doc/${PN}/ || die
+}
diff --git a/net-libs/libosmocore/metadata.xml b/net-libs/libosmocore/metadata.xml
new file mode 100644
index 000000000000..56e3a9ada2a2
--- /dev/null
+++ b/net-libs/libosmocore/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>chithanh@gentoo.org</email>
+ <name>Chí-Thanh Christopher Nguyễn</name>
+ </maintainer>
+ <use>
+ <flag name='embedded'>Build for embedded use and disable unsupported features</flag>
+ </use>
+</pkgmetadata>
+