summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-06-09 16:37:16 +0000
committerSven Wegener <swegener@gentoo.org>2005-06-09 16:37:16 +0000
commitde82598a04095807a9c85d4cb3abc1fd3ec8e300 (patch)
treed20a952e014be3d411d21b80c6b86f9f3e7e1d5e /net-irc
parentFixed FCNTL problem with Python 2.4 bug# 95533 (diff)
downloadhistorical-de82598a04095807a9c85d4cb3abc1fd3ec8e300.tar.gz
historical-de82598a04095807a9c85d4cb3abc1fd3ec8e300.tar.bz2
historical-de82598a04095807a9c85d4cb3abc1fd3ec8e300.zip
Revision bump to pull in a patch that uses the packaged icons as a default setting and fallback, if the user supplied directory is not accessible.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat-systray/ChangeLog9
-rw-r--r--net-irc/xchat-systray/Manifest11
-rw-r--r--net-irc/xchat-systray/files/2.4.5-default-icons.patch37
-rw-r--r--net-irc/xchat-systray/files/digest-xchat-systray-2.4.5-r21
-rw-r--r--net-irc/xchat-systray/xchat-systray-2.4.5-r2.ebuild59
5 files changed, 112 insertions, 5 deletions
diff --git a/net-irc/xchat-systray/ChangeLog b/net-irc/xchat-systray/ChangeLog
index b009046c5959..16a4dcc0f4b6 100644
--- a/net-irc/xchat-systray/ChangeLog
+++ b/net-irc/xchat-systray/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-irc/xchat-systray
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-systray/ChangeLog,v 1.20 2005/06/08 16:00:13 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-systray/ChangeLog,v 1.21 2005/06/09 16:37:16 swegener Exp $
+
+*xchat-systray-2.4.5-r2 (09 Jun 2005)
+
+ 09 Jun 2005; Sven Wegener <swegener@gentoo.org>
+ +files/2.4.5-default-icons.patch, +xchat-systray-2.4.5-r2.ebuild:
+ Revision bump to pull in a patch that uses the packaged icons as a default
+ setting and fallback, if the user supplied directory is not accessible.
08 Jun 2005; Sven Wegener <swegener@gentoo.org>
xchat-systray-2.4.5-r1.ebuild:
diff --git a/net-irc/xchat-systray/Manifest b/net-irc/xchat-systray/Manifest
index eb75cfaec67a..2b36f1042088 100644
--- a/net-irc/xchat-systray/Manifest
+++ b/net-irc/xchat-systray/Manifest
@@ -1,15 +1,18 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
+MD5 88bfb8cc831bb1bb6c1eb5b5e1919a9a xchat-systray-2.4.5-r2.ebuild 1561
MD5 942ce0f22aea83c40fc5179de7e85dce xchat-systray-2.4.5-r1.ebuild 1511
-MD5 3e7e842fdf5ab039d858017797107285 ChangeLog 2846
+MD5 6f37fa822b1f83d8e6ba3982599a6af5 ChangeLog 3155
MD5 44c39c6ad372a8e5a5e7ee3311f703a7 metadata.xml 160
MD5 f9fec2befb2bf0b3888f017d37a36a17 files/2.4.5-segfault-fix.patch 702
MD5 c7f2d25da598195290d93a826f3a99c3 files/digest-xchat-systray-2.4.5-r1 86
+MD5 c7f2d25da598195290d93a826f3a99c3 files/digest-xchat-systray-2.4.5-r2 86
+MD5 6a371b158e1a26ecf0077fa030a6b316 files/2.4.5-default-icons.patch 1717
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
-iD8DBQFCpxYoI1lqEGTUzyQRAkcqAKDAP6ZC15p+AeKIkETgkX8mP60IOACgnEyB
-PREBYepoQwbS7eLbSCEcLRg=
-=/16d
+iD8DBQFCqHBVI1lqEGTUzyQRArx1AJ0Z1shVEE7V1Ye2/yJu645QqyApnQCeMPGq
+uZTfEVgQbW9AuDsk/0ksuA8=
+=BtfX
-----END PGP SIGNATURE-----
diff --git a/net-irc/xchat-systray/files/2.4.5-default-icons.patch b/net-irc/xchat-systray/files/2.4.5-default-icons.patch
new file mode 100644
index 000000000000..a260bd04c68d
--- /dev/null
+++ b/net-irc/xchat-systray/files/2.4.5-default-icons.patch
@@ -0,0 +1,37 @@
+diff -Nur xchat-systray-integration-2.4.5.orig/src/menu.c xchat-systray-integration-2.4.5/src/menu.c
+--- xchat-systray-integration-2.4.5.orig/src/menu.c 2004-04-30 12:38:10.000000000 +0000
++++ xchat-systray-integration-2.4.5/src/menu.c 2005-06-09 16:30:54.609907253 +0000
+@@ -91,8 +91,8 @@
+ char temp[200];
+ if (filename)
+ {
+- if (imagepath) sprintf(temp,"%s/Menu/%s", imagepath ,filename);
+- else sprintf(temp,"%s/Menu/%s", xchat_get_info(ph, "xchatdir"),filename);
++ if (imagepath && 0 == access(imagepath, X_OK)) sprintf(temp,"%s/Menu/%s", imagepath ,filename);
++ else sprintf(temp,"/usr/share/xchat-systray/Menu/%s", filename);
+ tempbuffer= gdk_pixbuf_new_from_file(temp,NULL);
+ return tempbuffer;
+ }
+diff -Nur xchat-systray-integration-2.4.5.orig/src/systray.c xchat-systray-integration-2.4.5/src/systray.c
+--- xchat-systray-integration-2.4.5.orig/src/systray.c 2004-04-30 12:38:10.000000000 +0000
++++ xchat-systray-integration-2.4.5/src/systray.c 2005-06-09 16:30:47.170967680 +0000
+@@ -117,7 +117,7 @@
+ edit=TRUE;
+ go_change=TRUE;
+ go_identify=TRUE;
+- strcpy(imagepath,xchat_get_info(ph, "xchatdir"));
++ strcpy(imagepath, "/usr/share/xchat-systray");
+
+ }
+ // events handling
+@@ -190,8 +190,8 @@
+ char temp[200];
+ if (filename && type)
+ {
+- if (imagepath) sprintf(temp,"%s/%s/%s", imagepath ,type,filename);
+- else sprintf(temp,"%s/%s/%s", xchat_get_info(ph, "xchatdir"),type,filename);
++ if (imagepath && 0 == access(imagepath, X_OK)) sprintf(temp,"%s/%s/%s", imagepath ,type,filename);
++ else sprintf(temp,"/usr/share/xchat-systray/%s/%s", type,filename);
+ #ifdef _WIN32_
+ tempbuffer= ((HICON)LoadImage( tray_inst, temp, IMAGE_ICON, 16, 16, LR_LOADFROMFILE ));
+ #else
diff --git a/net-irc/xchat-systray/files/digest-xchat-systray-2.4.5-r2 b/net-irc/xchat-systray/files/digest-xchat-systray-2.4.5-r2
new file mode 100644
index 000000000000..7f98a7624e3c
--- /dev/null
+++ b/net-irc/xchat-systray/files/digest-xchat-systray-2.4.5-r2
@@ -0,0 +1 @@
+MD5 f7068053ff7cc63d5bf2fd8cfabe0c82 xchat-systray-integration-2.4.5-src.tar.gz 57953
diff --git a/net-irc/xchat-systray/xchat-systray-2.4.5-r2.ebuild b/net-irc/xchat-systray/xchat-systray-2.4.5-r2.ebuild
new file mode 100644
index 000000000000..24d6327b3828
--- /dev/null
+++ b/net-irc/xchat-systray/xchat-systray-2.4.5-r2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-systray/xchat-systray-2.4.5-r2.ebuild,v 1.1 2005/06/09 16:37:16 swegener Exp $
+
+inherit flag-o-matic eutils toolchain-funcs
+
+MY_P=${PN}-integration-${PV}
+
+DESCRIPTION="System tray plugin for X-Chat."
+SRC_URI="mirror://sourceforge/xchat2-plugins/${MY_P}-src.tar.gz"
+HOMEPAGE="http://blight.altervista.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha ~hppa"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.0.3
+ >=x11-libs/gtk+-2.0.3
+ >=net-irc/xchat-2.0.3"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.7"
+
+S="${WORKDIR}"/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PV}-segfault-fix.patch
+ epatch "${FILESDIR}"/${PV}-default-icons.patch
+}
+
+src_compile() {
+ append-flags -fPIC
+ emake -j1 CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/xchat/plugins
+ doexe systray.so || die "doexe failed"
+
+ insinto /usr/share/xchat-systray
+ doins -r src/images/{GTKTray,Menu} || die "doins failed"
+
+ dodoc Docs/{ChangeLog,README,TODO} || die "dodoc failed"
+}
+
+pkg_postinst() {
+ einfo
+ einfo "The icons have been installed in /usr/share/xchat-systray"
+ einfo
+ einfo "The icons path is a per-user setting and you need to set it or the icons"
+ einfo "will not show up in the menu. Please go to 'Systray settings' and set"
+ einfo "'Select icons path' to /usr/share/xchat-systray to set the icons path."
+ einfo
+}