summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Stine <battousai@gentoo.org>2004-04-22 01:30:34 +0000
committerBryan Stine <battousai@gentoo.org>2004-04-22 01:30:34 +0000
commit4d14dc42e7ee1e076d432a39d20d0b3c60c5944a (patch)
tree2b0051bec9031bfe5cfc67ffc92c40685172f5a2 /net-irc
parentgcc-3.4 patch (diff)
downloadhistorical-4d14dc42e7ee1e076d432a39d20d0b3c60c5944a.tar.gz
historical-4d14dc42e7ee1e076d432a39d20d0b3c60c5944a.tar.bz2
historical-4d14dc42e7ee1e076d432a39d20d0b3c60c5944a.zip
Version bump, cleanup. Fixes bug 48255.
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/kvirc/ChangeLog9
-rw-r--r--net-irc/kvirc/Manifest4
-rw-r--r--net-irc/kvirc/files/digest-kvirc-3.0.01
-rw-r--r--net-irc/kvirc/kvirc-3.0.0.ebuild60
4 files changed, 71 insertions, 3 deletions
diff --git a/net-irc/kvirc/ChangeLog b/net-irc/kvirc/ChangeLog
index 87be2dd83b08..20549f630cc2 100644
--- a/net-irc/kvirc/ChangeLog
+++ b/net-irc/kvirc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/kvirc
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/kvirc/ChangeLog,v 1.12 2004/01/04 02:37:52 caleb Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/kvirc/ChangeLog,v 1.13 2004/04/22 01:30:34 battousai Exp $
+
+ 21 Apr 2004; Bryan Stine <battousai@gentoo.org>; kvirc-3.0.0.ebuild:
+ Version bump to 3.0.0 release. This has a cleaned up ebuild and better
+ dependencies. This fixes bug #48255. Thanks to Alessandro Rossini
+ <aronnax@openlug.org> and Daniel Black <dragonheart@gentoo.org>.
03 Jan 2004; Caleb Tennis <caleb@gentoo.org> kvirc-3.0.0_beta1-r1.ebuild,
kvirc-3.0.0_beta2-r1.ebuild:
diff --git a/net-irc/kvirc/Manifest b/net-irc/kvirc/Manifest
index a1c87e4c5d2a..b6a7f63579c6 100644
--- a/net-irc/kvirc/Manifest
+++ b/net-irc/kvirc/Manifest
@@ -1,4 +1,6 @@
MD5 b25647abc9a253949ae796916a195fdc kvirc-3.0.0_beta2-r1.ebuild 2306
-MD5 fc6eccc995c55b44c5a611f4c6ba431b ChangeLog 2975
+MD5 0c7384233f11c5f6b93b22f6429eccde ChangeLog 3259
MD5 44c39c6ad372a8e5a5e7ee3311f703a7 metadata.xml 160
+MD5 3fe5adcd4c90e5f7ccf92a34c13b9ead kvirc-3.0.0.ebuild 1679
MD5 68d2153371007bdad609f225fdba63be files/digest-kvirc-3.0.0_beta2-r1 70
+MD5 4b55df13a25bb1556fa285ede1be937e files/digest-kvirc-3.0.0 65
diff --git a/net-irc/kvirc/files/digest-kvirc-3.0.0 b/net-irc/kvirc/files/digest-kvirc-3.0.0
new file mode 100644
index 000000000000..c411ad71f0ef
--- /dev/null
+++ b/net-irc/kvirc/files/digest-kvirc-3.0.0
@@ -0,0 +1 @@
+MD5 1c14226fbdb9fe309122e24b6505b64d kvirc-3.0.0.tar.bz2 2807216
diff --git a/net-irc/kvirc/kvirc-3.0.0.ebuild b/net-irc/kvirc/kvirc-3.0.0.ebuild
new file mode 100644
index 000000000000..2c5aa2990346
--- /dev/null
+++ b/net-irc/kvirc/kvirc-3.0.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/kvirc/kvirc-3.0.0.ebuild,v 1.4 2004/04/22 01:30:34 battousai Exp $
+
+inherit eutils kde
+
+DESCRIPTION="An advanced IRC Client"
+HOMEPAGE="http://www.kvirc.net/"
+SRC_URI="ftp://ftp.kvirc.net/pub/${PN}/${PV}/source/${P}.tar.bz2"
+
+LICENSE="kvirc"
+SLOT="3"
+KEYWORDS="~x86 ~amd64"
+IUSE="kde ipv6 ssl oss esd"
+
+RDEPEND="esd? ( media-sound/esound )
+ ssl? ( dev-libs/openssl )
+ oss? ( media-libs/audiofile )
+ >=x11-libs/qt-3
+ kde? ( >=kde-base/kdelibs-3 )
+ sys-devel/gettext"
+
+DEPEND="${RDEPEND}
+ sys-apps/gawk
+ sys-apps/grep
+ sys-devel/libtool
+ sys-apps/sed"
+
+use debug && RESTRICT="nostrip"
+
+src_compile() {
+
+ # use aa even when kde support is disabled; remove the splash screen
+ # to speed up the startup.
+ local myconf="--with-aa-fonts --without-splash-screen
+ --with-big-channels --with-pizza"
+
+ # For myconf, we can't do it the easy way (use_with) because the configure
+ # script will assume we're telling it not to include support.
+ myconf="${myconf}
+ `use_with debug debug-symbols`"
+ use kde || myconf="${myconf} --without-kde-support --without-arts-support"
+ use ipv6 || myconf="${myconf} --without-ipv6-support"
+ use esd || myconf="${myconf} --without-esd-support"
+ use ssl || myconf="${myconf} --without-ssl-support"
+
+ [ "$ARCH" == "x86" ] && myconf="$myconf --with-ix86-asm"
+
+ need-autoconf 2.5
+ need-automake 1.5
+
+ econf ${myconf} || die "failed to configure"
+ emake || die "failed to make"
+}
+
+src_install() {
+ emake install DESTDIR=${D} || die
+ emake docs DESTDIR=${D} || die
+ dodoc ChangeLog INSTALL README TODO
+}