summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-06-26 19:49:29 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-06-26 19:49:29 +0000
commitfd4e0e24cfafe05c6bdc6fdae99c4ff4e23484ee (patch)
tree8888bb6e0e2f7681cb5e029d6155a018f79c5501 /net-irc/supybot/supybot-0.77.2.ebuild
parent(no commit message) (diff)
downloadhistorical-fd4e0e24cfafe05c6bdc6fdae99c4ff4e23484ee.tar.gz
historical-fd4e0e24cfafe05c6bdc6fdae99c4ff4e23484ee.tar.bz2
historical-fd4e0e24cfafe05c6bdc6fdae99c4ff4e23484ee.zip
version bump (#53438)
Diffstat (limited to 'net-irc/supybot/supybot-0.77.2.ebuild')
-rw-r--r--net-irc/supybot/supybot-0.77.2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-irc/supybot/supybot-0.77.2.ebuild b/net-irc/supybot/supybot-0.77.2.ebuild
new file mode 100644
index 000000000000..450b796704ee
--- /dev/null
+++ b/net-irc/supybot/supybot-0.77.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/supybot/supybot-0.77.2.ebuild,v 1.1 2004/06/26 19:49:29 liquidx Exp $
+
+inherit distutils eutils
+
+MY_P=${P/s/S}
+
+DESCRIPTION="Python based extensible IRC infobot and channel bot"
+HOMEPAGE="http://supybot.sf.net/"
+SRC_URI="mirror://sourceforge/supybot/${MY_P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.3
+ >=dev-python/pysqlite-0.4.3"
+
+S=${WORKDIR}/${MY_P}
+
+PYTHON_MODNAME="supybot"
+DOCS="ACKS BUGS LICENSE TODO"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}; epatch ${FILESDIR}/${P}-cvsadditions-2004-06-10.patch
+}
+
+src_install() {
+ distutils_src_install
+ dodoc examples/Random.py
+ docinto developers
+ dodoc docs/*
+ docinto plugins
+ dodoc docs/plugins/*
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/supybot.rc supybot
+ insinto /etc/conf.d
+ newexe ${FILESDIR}/supybot.conf supybot
+}
+
+pkg_postinst() {
+ einfo "Use supybot-wizard to create a configuration file"
+}