summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-05-14 17:50:56 +0000
committerSven Wegener <swegener@gentoo.org>2005-05-14 17:50:56 +0000
commitffac22b93c9b4cbe2b2102fa40b4e8d99c8cff95 (patch)
tree511b89bbbd5286442dd53648f0319d2ab21abc43 /net-irc/scrollz/scrollz-1.9.5.ebuild
parentStable on x86 per security bug #91817 (diff)
downloadhistorical-ffac22b93c9b4cbe2b2102fa40b4e8d99c8cff95.tar.gz
historical-ffac22b93c9b4cbe2b2102fa40b4e8d99c8cff95.tar.bz2
historical-ffac22b93c9b4cbe2b2102fa40b4e8d99c8cff95.zip
Version bump, bug #92618.
Package-Manager: portage-2.0.51.21-r1
Diffstat (limited to 'net-irc/scrollz/scrollz-1.9.5.ebuild')
-rw-r--r--net-irc/scrollz/scrollz-1.9.5.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-irc/scrollz/scrollz-1.9.5.ebuild b/net-irc/scrollz/scrollz-1.9.5.ebuild
new file mode 100644
index 000000000000..a7d86660672a
--- /dev/null
+++ b/net-irc/scrollz/scrollz-1.9.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/scrollz/scrollz-1.9.5.ebuild,v 1.1 2005/05/14 17:50:56 swegener Exp $
+
+MY_P=ScrollZ-${PV}
+
+DESCRIPTION="Advanced IRC client based on ircII"
+SRC_URI="ftp://ftp.scrollz.com/pub/ScrollZ/source/${MY_P}.tar.gz"
+HOMEPAGE="http://www.scrollz.com/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ia64 ~amd64 ~ppc"
+IUSE="ipv6 socks5 ssl"
+
+DEPEND="virtual/libc
+ ssl? ( dev-libs/openssl )"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ econf \
+ --with-default-server=irc.freenode.net \
+ $(use_enable ipv6) \
+ $(use_enable socks5) \
+ $(use_with ssl) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/share/man/man1
+ einstall \
+ sharedir=${D}/usr/share \
+ mandir=${D}/usr/share/man/man1 \
+ install \
+ || die "einstall failed"
+ dodoc ChangeLog* README* || die "dodoc failed"
+
+ # fix erms of manpage
+ fperms 644 /usr/share/man/man1/scrollz.1
+}