summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Fitzgerald <gregf@gentoo.org>2003-11-23 16:17:43 +0000
committerGreg Fitzgerald <gregf@gentoo.org>2003-11-23 16:17:43 +0000
commit4f72ee606366eef43c872747e4df22c379481f1c (patch)
tree95a7826be8e9faaddc765bd724a9fdc345462932 /net-irc/irssi
parentVersion Bump. (diff)
downloadhistorical-4f72ee606366eef43c872747e4df22c379481f1c.tar.gz
historical-4f72ee606366eef43c872747e4df22c379481f1c.tar.bz2
historical-4f72ee606366eef43c872747e4df22c379481f1c.zip
Version Bump.
Diffstat (limited to 'net-irc/irssi')
-rw-r--r--net-irc/irssi/Manifest4
-rw-r--r--net-irc/irssi/files/digest-irssi-0.8.81
-rw-r--r--net-irc/irssi/irssi-0.8.8.ebuild79
3 files changed, 82 insertions, 2 deletions
diff --git a/net-irc/irssi/Manifest b/net-irc/irssi/Manifest
index 1f37288157ec..c15206f6e88e 100644
--- a/net-irc/irssi/Manifest
+++ b/net-irc/irssi/Manifest
@@ -1,11 +1,11 @@
-MD5 3906caafb3642f54c4eb9a12e9e09c75 ChangeLog 4456
+MD5 9a1a955aa9cd93361a37669538e4cef5 ChangeLog 4458
MD5 010f51ca1f64db3840d7d8ad57159429 irssi-0.8.5-r2.ebuild 1865
MD5 f8aa78b673a0a7536d33d273d37b1ba8 irssi-0.8.6-r2.ebuild 2372
MD5 ffeebf3d5d590c343d18887b3c595c42 irssi-0.8.6-r3.ebuild 2490
MD5 44c39c6ad372a8e5a5e7ee3311f703a7 metadata.xml 160
MD5 b0be3a93f4efacbe447f5e76dd6a7bfd irssi-0.8.6-r4.ebuild 2469
MD5 b0bf2474d39dca2a2102ebe53397cd4f irssi-0.8.6-r5.ebuild 2106
-MD5 695c39f7d2c415c3eac15325e4439dcf irssi-0.8.8.ebuild 2066
+MD5 8ef2fa23ff48259fa28e04da91de4e8b irssi-0.8.8.ebuild 2065
MD5 1920fb9f4aba0f95f26302d82430ffa8 files/digest-irssi-0.8.5-r2 64
MD5 cb17857da5af4446fef7e94d553277de files/digest-irssi-0.8.6-r2 64
MD5 cb17857da5af4446fef7e94d553277de files/digest-irssi-0.8.6-r3 64
diff --git a/net-irc/irssi/files/digest-irssi-0.8.8 b/net-irc/irssi/files/digest-irssi-0.8.8
new file mode 100644
index 000000000000..760aa3545735
--- /dev/null
+++ b/net-irc/irssi/files/digest-irssi-0.8.8
@@ -0,0 +1 @@
+MD5 7220d149b938012c96b064767dafc7de irssi-0.8.8.tar.bz2 758641
diff --git a/net-irc/irssi/irssi-0.8.8.ebuild b/net-irc/irssi/irssi-0.8.8.ebuild
new file mode 100644
index 000000000000..58dc192dce3f
--- /dev/null
+++ b/net-irc/irssi/irssi-0.8.8.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi/irssi-0.8.8.ebuild,v 1.1 2003/11/23 16:17:40 gregf Exp $
+
+IUSE="nls ipv6 perl ssl"
+
+inherit perl-module
+
+DESCRIPTION="A modular textUI IRC client with IPv6 support."
+SRC_URI="http://irssi.org/files/${P}.tar.bz2"
+HOMEPAGE="http://irssi.org/"
+
+DEPEND=">=dev-libs/glib-1.2
+ sys-libs/ncurses
+ >=sys-apps/sed-4
+ perl? ( dev-lang/perl )
+ ssl? ( dev-libs/openssl )
+ !net-irc/irssi-cvs
+ socks5? ( >=net-misc/dante-1.1.13 )"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~amd64 ~ia64"
+
+src_unpack() {
+ unpack ${A}
+
+ # Ugly hack to work around compression of the html files.
+ # Remove this if prepalldocs is changed to avoid gzipping html files.
+ cd ${S} && \
+ sed -i \
+ -e 's/[^ ]\+\.html//g' docs/Makefile.in || \
+ die "sed doc/Makefile.in failed"
+
+}
+
+src_compile() {
+ # Note: there is an option to build a GUI for irssi, but according
+ # to the website the GUI is no longer developed, so that option is
+ # not used here.
+ local myconf="--without-servertest --with-bot --with-proxy --with-ncurses"
+
+ myconf="${myconf} `use_enable nls`"
+ myconf="${myconf} `use_with perl`"
+ myconf="${myconf} `use_enable ipv6`"
+ myconf="${myconf} `use_with socks5 socks`"
+ if use ssl; then
+ myconf="${myconf} --with-openssl-include=/usr --with-openssl-libs=/usr"
+ else
+ myconf="${myconf} --disable-ssl"
+ fi
+
+ econf ${myconf} || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ myflags=""
+
+ if use perl; then
+ cd ${S}/src/perl/common; perl-module_src_prep
+ cd ${S}/src/perl/irc; perl-module_src_prep
+ cd ${S}/src/perl/textui; perl-module_src_prep
+ cd ${S}/src/perl/ui; perl-module_src_prep
+ cd ${S}
+ fi
+
+ make DESTDIR=${D} \
+ docdir=/usr/share/doc/${PF} \
+ gnulocaledir=${D}/usr/share/locale \
+ ${myflags} \
+ install || die
+
+ prepalldocs
+ dodoc AUTHORS ChangeLog README TODO NEWS
+ cd ${S}/docs
+ dohtml -r . || die "dohtml failed"
+}