summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Short <zul@gentoo.org>2004-03-11 17:15:39 +0000
committerChuck Short <zul@gentoo.org>2004-03-11 17:15:39 +0000
commitac8c82997c40a92170e45c6867198b139f067eaa (patch)
tree6318946f305742d42945a31299bd4362f9f1180e /net-irc/epic4
parentVersion bump, closes #44270. (diff)
downloadhistorical-ac8c82997c40a92170e45c6867198b139f067eaa.tar.gz
historical-ac8c82997c40a92170e45c6867198b139f067eaa.tar.bz2
historical-ac8c82997c40a92170e45c6867198b139f067eaa.zip
Version bump, closes #44270.
Diffstat (limited to 'net-irc/epic4')
-rw-r--r--net-irc/epic4/Manifest2
-rw-r--r--net-irc/epic4/epic4-2.0.ebuild72
-rw-r--r--net-irc/epic4/files/digest-epic4-2.02
3 files changed, 75 insertions, 1 deletions
diff --git a/net-irc/epic4/Manifest b/net-irc/epic4/Manifest
index 7cf3ae471509..2c653f78ba85 100644
--- a/net-irc/epic4/Manifest
+++ b/net-irc/epic4/Manifest
@@ -5,7 +5,7 @@ MD5 cff70b15f7a9c00d620cf17f2ed80b92 epic4-1.1.12.ebuild 2201
MD5 0660625f0aea6abaed7c16bde6493ea1 epic4-1.2.6.ebuild 2044
MD5 44cca8b507c275ecb34782c066bcacd0 epic4-2.0.ebuild 1888
MD5 aebf2b3817bd3abf142ab73131068cb9 epic4-1.1.14.ebuild 2055
-MD5 5fbfc22e008b4e8b173d01dc5f76b003 ChangeLog 5254
+MD5 b07feada70a1c63430aa3196dd15a1ce ChangeLog 5373
MD5 298bd193ee2ce05867340e8ff0565854 epic4-1.1.16.ebuild 1975
MD5 44c39c6ad372a8e5a5e7ee3311f703a7 metadata.xml 160
MD5 b0467b5ce87a9f2aadbd48754473b257 epic4-1.1.11.ebuild 2037
diff --git a/net-irc/epic4/epic4-2.0.ebuild b/net-irc/epic4/epic4-2.0.ebuild
new file mode 100644
index 000000000000..94e5dd001f93
--- /dev/null
+++ b/net-irc/epic4/epic4-2.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+IUSE="ipv6 perl ssl"
+
+DESCRIPTION="Epic4 IRC Client"
+SRC_URI="ftp://ftp.epicsol.org/pub/epic/EPIC4-PRODUCTION/${P}.tar.bz2
+ ftp://prbh.org/pub/epic/EPIC4-PRODUCTION/epic4-help-20040308.tar.gz"
+HOMEPAGE="http://epicsol.org"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~ppc ~ia64 ~alpha ~hppa"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ perl? ( >=dev-lang/perl-5.6.1 )
+ ssl? ( >=dev-libs/openssl-0.9.5 )"
+
+inherit flag-o-matic
+replace-flags "-O?" "-O"
+
+src_compile() {
+ myconf=""
+
+ myconf="${myconf} `use_with ipv6`"
+ myconf="${myconf} `use_with perl`"
+ myconf="${myconf} `use_with ssl`"
+
+ epatch ${FILESDIR}/epic-defaultserver.patch || die "patch failed"
+
+ econf \
+ --libexecdir=/usr/lib/misc \
+ ${myconf} || die
+
+ make || die
+}
+
+src_install () {
+ einstall \
+ sharedir=${D}/usr/share \
+ libexecdir=${D}/usr/lib/misc || die
+
+ rm -f ${D}/usr/bin/epic
+ dosym epic-EPIC4-${PV} /usr/bin/epic
+
+ dodoc BUG_FORM COPYRIGHT README KNOWNBUGS VOTES
+ docinto doc
+ cd doc
+ dodoc *.txt colors EPIC* IRCII_VERSIONS local_vars missing new-load
+ dodoc nicknames outputhelp server_groups SILLINESS TS4
+
+ dodir /usr/share/epic
+ tar zxvf ${DISTDIR}/epic4-help-20040308.tar.gz -C ${D}/usr/share/epic
+
+ rm -f ${D}/usr/share/epic/help/Makefile
+ rm -rf ${D}/usr/share/epic/help/CVS
+
+ chown -R root.root ${D}/usr/share/epic/help
+}
+
+pkg_postinst() {
+ einfo "If /usr/share/epic/script/local does not exist, I will now"
+ einfo "create it. If you do not like the look/feel of this file, or"
+ einfo "if you'd prefer to use your own script, simply remove this"
+ einfo "file. If you want to prevent this file from being installed"
+ einfo "in the future, simply create an empty file with this name."
+
+ if [ ! -e /usr/share/epic/script/local ]; then
+ cp ${FILESDIR}/local /usr/share/epic/script/
+ fi
+}
diff --git a/net-irc/epic4/files/digest-epic4-2.0 b/net-irc/epic4/files/digest-epic4-2.0
new file mode 100644
index 000000000000..83f5adc67019
--- /dev/null
+++ b/net-irc/epic4/files/digest-epic4-2.0
@@ -0,0 +1,2 @@
+MD5 81c50c94762bd33349826b2f5b5e6278 epic4-2.0.tar.bz2 627102
+MD5 5492fba9d0794f8ceb2fa0837ad847fa epic4-help-20040308.tar.gz 300509