summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2004-09-12 03:27:05 +0000
committerSven Wegener <swegener@gentoo.org>2004-09-12 03:27:05 +0000
commit0fe0043d4a965e5a2e6c2f5c38f9b30b2a7eeeac (patch)
tree7054e44e78c6efb01e0d88517fcd753a39273730 /net-irc/eggdrop
parentAdded bash-completion script (please test). (diff)
downloadhistorical-0fe0043d4a965e5a2e6c2f5c38f9b30b2a7eeeac.tar.gz
historical-0fe0043d4a965e5a2e6c2f5c38f9b30b2a7eeeac.tar.bz2
historical-0fe0043d4a965e5a2e6c2f5c38f9b30b2a7eeeac.zip
Added documentation to eggdrop-installer about how to create the user file and how to start the bot correctly. Closes bug #63578.
Diffstat (limited to 'net-irc/eggdrop')
-rw-r--r--net-irc/eggdrop/ChangeLog6
-rw-r--r--net-irc/eggdrop/Manifest12
-rw-r--r--net-irc/eggdrop/files/eggdrop-installer120
3 files changed, 66 insertions, 72 deletions
diff --git a/net-irc/eggdrop/ChangeLog b/net-irc/eggdrop/ChangeLog
index 68da28a474a9..52e9c097243b 100644
--- a/net-irc/eggdrop/ChangeLog
+++ b/net-irc/eggdrop/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/eggdrop
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/eggdrop/ChangeLog,v 1.25 2004/08/28 20:42:37 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/eggdrop/ChangeLog,v 1.26 2004/09/12 03:27:05 swegener Exp $
+
+ 12 Sep 2004; Sven Wegener <swegener@gentoo.org> files/eggdrop-installer:
+ Added documentation to eggdrop-installer about how to create the user file and
+ how to start the bot correctly. Closes bug #63578.
*eggdrop-1.6.17 (28 Aug 2004)
diff --git a/net-irc/eggdrop/Manifest b/net-irc/eggdrop/Manifest
index 6882e243c18a..77361c31247d 100644
--- a/net-irc/eggdrop/Manifest
+++ b/net-irc/eggdrop/Manifest
@@ -1,7 +1,7 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 3f1e10889c6e1eaf8780d3a805066105 ChangeLog 4393
+MD5 644a991ea9d6be37a68bf017e437c14d ChangeLog 4603
MD5 81b7809bb877adad85d21033af3cdb3e eggdrop-1.6.15-r1.ebuild 2298
MD5 300d3768f2f66fab7b5151c429dea85f eggdrop-1.6.15-r2.ebuild 2757
MD5 96e1d60a7f7de6f222a7ca068e3bad16 eggdrop-1.6.15.ebuild 1800
@@ -17,12 +17,12 @@ MD5 e410ac6d9adce910c8f37daf99a4b0e1 files/eggdrop-1.6.15-config.patch 6182
MD5 de237a9eaabae91f41afbd6d18448320 files/eggdrop-1.6.15-configure-in.patch 575
MD5 2f73d0025c666719612e4d05c47a46dd files/eggdrop-1.6.15-mysql-use_ssl-fix.patch 300
MD5 86513844ef13a664bc5bf7d1a68d2d59 files/eggdrop-1.6.15-potential-undef-tm-struct.patch 523
-MD5 f2630d4e23d41f740a100a1ccfd58853 files/eggdrop-installer 2898
MD5 6b09026c13cde0090d7b943e6a4e1535 files/digest-eggdrop-1.6.17 145
+MD5 dbe1e8b9a8c086b7a1182f1819bf3a12 files/eggdrop-installer 2271
-----BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.5 (GNU/Linux)
+Version: GnuPG v1.2.6 (GNU/Linux)
-iD8DBQFBMO5CI1lqEGTUzyQRAiXsAKCoKTgcESACenqE6bmBjtyJL4/IWACgmt2E
-RCYWM5F0A2NTv+JI7fxRZBo=
-=HBtn
+iD8DBQFBQ8IUI1lqEGTUzyQRAs9TAJwMZOzHn7fuYO1dlCgu9d/jvLRKsACdH/Oi
+gXwdXkCv/sN7uDB1gNLytYo=
+=uhWU
-----END PGP SIGNATURE-----
diff --git a/net-irc/eggdrop/files/eggdrop-installer b/net-irc/eggdrop/files/eggdrop-installer
index 9f6d3a47c7d6..0f57c493d177 100644
--- a/net-irc/eggdrop/files/eggdrop-installer
+++ b/net-irc/eggdrop/files/eggdrop-installer
@@ -1,94 +1,84 @@
#!/bin/bash
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/eggdrop/files/eggdrop-installer,v 1.6 2004/07/05 01:29:28 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/eggdrop/files/eggdrop-installer,v 1.7 2004/09/12 03:27:05 swegener Exp $
source /etc/init.d/functions.sh || {
- echo "$0: Could not source /etc/init.d/functions.sh!"
- exit 1
+ echo "${0}: Could not source /etc/init.d/functions.sh!"
+ exit 1
}
# Checks to see if user is trying to install eggdrop as root.
root_check() {
+ einfo "Installing Eggdrop"
+ einfo
-echo "Installing Eggdrop"
-if [ "$HOME" = "/root" ] || [ `whoami` == "root" ];
-then
- einfo "You should not be installing eggdrop as root."
- einfo ""
- einfo "Installing eggdrop as root leaves your computer vulnerable"
- einfo "to attack from other irc clients. Please use the eggdrop-installer"
- einfo "script as the user who you wish to run eggdrop with"
- exit 1
-else
- install_eggdrop
-fi
-
+ if [ "${HOME}" = "/root" ] || [ "$(whoami)" == "root" ]
+ then
+ einfo "You should not be installing eggdrop as root."
+ einfo
+ einfo "Installing eggdrop as root leaves your computer vulnerable"
+ einfo "to attack from other irc clients. Please use the eggdrop-installer"
+ einfo "script as the user who you wish to run eggdrop with"
+ exit 1
+ else
+ install_eggdrop
+ fi
}
# Usage information
usage() {
-cat << "USAGE_END"
-Usage: eggbot-installer [bot-name]
+ cat <<USAGE_END
+Usage: eggdrop-installer <bot-name>
Install eggdrop for a specific user, creating the directories and files
needed for eggdrop to run securely and safely.
USAGE_END
-
-exit 1
+ exit 1
}
-install_eggdrop()
-{
- if [ -e $HOME/.eggdrop/$bot_name ];
- then
- einfo "Already found a bot home directory for $bot_name"
- exit 1
- fi
+install_eggdrop() {
+ bot_dir="${HOME}/.eggdrop/${bot_name}"
- if [ ! -d $HOME/.eggdrop ]
- then
- mkdir -p $HOME/.eggdrop
- fi
- einfo "Creating directories for your $bot_name ..."
- mkdir -p $HOME/.eggdrop/$bot_name
- mkdir -p $HOME/.eggdrop/$bot_name/logs
- mkdir -p $HOME/.eggdrop/$bot_name/filesys
- mkdir -p $HOME/.eggdrop/$bot_name/filesys/incoming
- mkdir -p $HOME/.eggdrop/$bot_name/text
- mkdir -p $HOME/.eggdrop/$bot_name/tmp
- mkdir -p $HOME/.eggdrop/$bot_name/scripts
- # Added because of bug #3073
- mkdir -p $HOME/.eggdrop/$bot_name/var
-
+ if [ -d "${bot_dir}" ]
+ then
+ einfo "Already found a bot home directory for ${bot_name}"
+ exit 1
+ fi
- einfo "Creating symlinks to required files for your bot to run ...."
- ln -s /opt/eggdrop/help $HOME/.eggdrop/$bot_name/help
- ln -s /opt/eggdrop/language $HOME/.eggdrop/$bot_name/language
- ln -s /opt/eggdrop/modules $HOME/.eggdrop/$bot_name/modules
- # Added because of bug #3073
- ln -s /opt/eggdrop/eggdrop $HOME/.eggdrop/$bot_name/eggdrop
+ einfo "Creating directories for your ${bot_name}..."
+ for dir in logs filesys/incoming text tmp scripts var
+ do
+ mkdir -p "${bot_dir}/${dir}"
+ done
- einfo "Copying motd and banner ... "
- cp /opt/eggdrop/text/* $HOME/.eggdrop/$bot_name/text
+ einfo "Creating symlinks to required files for your bot to run..."
+ for file in help language modules eggdrop
+ do
+ ln -s "/opt/eggdrop/${file}" "${bot_dir}/${file}"
+ done
- # I changed this from a symlink to a direct copy because the user
- # might not have write permissions to /opt/eggdrop/scripts
- # as well as they might have their own custom scripts. - zul<chuck_short@rogers.com>
- cp /opt/eggdrop/scripts/* $HOME/.eggdrop/$bot_name/scripts
+ einfo "Copying motd, banner, scripts and config file..."
+ cp /opt/eggdrop/text/* "${bot_dir}/text"
+ cp /opt/eggdrop/scripts/* "${bot_dir}/scripts"
+ cp /opt/eggdrop/eggdrop.conf "${bot_dir}/eggdrop.conf"
- einfo "Finished..."
-
- einfo "Please edit your $HOME/.eggdrop/$bot_name/eggdrop.conf "
- einfo "If you need any help pleaese refer to the man page, or "
- einfo "eggdrop website at http://www.egghelper.org"
-
- cp /opt/eggdrop/eggdrop.conf $HOME/.eggdrop/$bot_name/eggdrop.conf
+ einfo "Finished..."
+ einfo
+ einfo "Please edit your ${bot_dir}/eggdrop.conf!"
+ einfo
+ einfo "The bot needs to be run from the ${bot_dir} directory."
+ einfo "Run 'cd ${bot_dir} && ./eggdrop -m eggdrop.conf'"
+ einfo "to create the user file and then remove the -m command line option"
+ einfo "to start your eggdrop bot."
+ einfo
+ einfo "If you need any help pleaese refer to the man page, or"
+ einfo "eggdrop website at http://www.egghelper.org"
}
-if [ ! -n "$1" ]
+if [ ! -n "${1}" ]
then
- usage
+ usage
else
- bot_name="$1"
- root_check
+ bot_name="${1}"
+ root_check
fi