summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-04 00:16:12 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-04 00:16:12 +0000
commitba0a4e5c32808d8a5d029f0b0e26a80e9173fe6c (patch)
tree127fbb65735709166cb7ac235f11ee6d7afbde62 /net-im
parentNow finds it's help and configuration files correctly (diff)
downloadhistorical-ba0a4e5c32808d8a5d029f0b0e26a80e9173fe6c.tar.gz
historical-ba0a4e5c32808d8a5d029f0b0e26a80e9173fe6c.tar.bz2
historical-ba0a4e5c32808d8a5d029f0b0e26a80e9173fe6c.zip
dependencie fixes and updates
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gtk+licq/gtk+licq-0.50.1.ebuild11
-rw-r--r--net-im/licq/files/digest-licq-1.0.3-r11
-rw-r--r--net-im/licq/licq-1.0.3-r1.ebuild55
3 files changed, 62 insertions, 5 deletions
diff --git a/net-im/gtk+licq/gtk+licq-0.50.1.ebuild b/net-im/gtk+licq/gtk+licq-0.50.1.ebuild
index 240304401528..40f7b9815d7b 100644
--- a/net-im/gtk+licq/gtk+licq-0.50.1.ebuild
+++ b/net-im/gtk+licq/gtk+licq-0.50.1.ebuild
@@ -7,13 +7,14 @@ DESCRIPTION="gtk+licq"
SRC_URI="http://gtk.licq.org/download/${A}"
HOMEPAGE="http://gtk.licq.org"
-DEPEND=">=net-im/licq-1.0.2
+DEPEND="virtual/glibc sys-devel/perl
+ >=net-im/licq-1.0.2
>=x11-libs/gtk+-1.2.0"
-src_unpack() {
- unpack ${A}
- cd ${S}
-}
+RDEPEND="virtual/glibc >=net-im/licq-1.0.2
+ >=x11-libs/gtk+-1.2.0
+ gnome? ( gnome-base/gnome-core )"
+
src_compile() {
local myconf
diff --git a/net-im/licq/files/digest-licq-1.0.3-r1 b/net-im/licq/files/digest-licq-1.0.3-r1
new file mode 100644
index 000000000000..442083ca1cc5
--- /dev/null
+++ b/net-im/licq/files/digest-licq-1.0.3-r1
@@ -0,0 +1 @@
+MD5 894d7c27c0799c8b31dda134fe14b257 licq-1.0.3.tar.gz
diff --git a/net-im/licq/licq-1.0.3-r1.ebuild b/net-im/licq/licq-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..3f3cd3ce9cb1
--- /dev/null
+++ b/net-im/licq/licq-1.0.3-r1.ebuild
@@ -0,0 +1,55 @@
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jules Gagnon <eonwe@users.sourceforge.net>
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="licq"
+SRC_URI="http://download.sourceforge.net/${PN}/${A}
+ ftp://ftp.fanfic.org/pub/${PN}/srcs/${A}
+ ftp://licq.darkorb.net/${A}
+ ftp://ftp.fr.licq.org/pub/${PN}/srcs/${A}
+ ftp://ftp.ru.licq.org/pub/${PN}/srcs/${A}
+ ftp://ftp.pt.licq.org/pub/mirrors/${PN}/srcs/${A}
+ ftp://mirror.itcnet.ro/pub/${PN}/srcs/${A}"
+HOMEPAGE="http://www.licq.org"
+
+DEPEND="virtual/glibc
+ qt? ( >=x11-libs/qt-x11-2.2.1 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ local myconf
+ if [ -z "`use ssl`" ]
+ then
+ myconf="--disable-openssl"
+ fi
+ if [ "`use socks5`" ]
+ then
+ myconf="${myconf} --enable-socks5"
+ fi
+ try ./configure --host=${CHOST} --prefix=/usr ${myconf}
+ try make
+ if [ "`use qt`" ]
+ then
+ cd ./plugins/qt-gui-1.0.3
+ try ./configure --host=${CHOST} --prefix=/usr
+ try make
+ cd ../..
+ fi
+}
+
+src_install() {
+ try make prefix=${D}/usr install
+ dodoc README.OPENSSL doc/*
+ if [ "`use qt`" ]
+ then
+ cd ./plugins/qt-gui-1.0.3
+ try make prefix=${D}/usr install
+ cd ../..
+ fi
+}
+