summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2003-11-12 19:34:15 +0000
committerDon Seiler <rizzo@gentoo.org>2003-11-12 19:34:15 +0000
commit8d4042ee04762c59d4930b00426c658ef80a6a9a (patch)
treeca3add042c13b6613aee9d6c317f30317d521d9f /net-im
parentAdding cjk patch for bug 24657 (diff)
downloadhistorical-8d4042ee04762c59d4930b00426c658ef80a6a9a.tar.gz
historical-8d4042ee04762c59d4930b00426c658ef80a6a9a.tar.bz2
historical-8d4042ee04762c59d4930b00426c658ef80a6a9a.zip
Adding cjk patch for bug 24657
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gaim/Manifest4
-rw-r--r--net-im/gaim/files/digest-gaim-0.72-r22
-rw-r--r--net-im/gaim/files/gaim_cjk_gtkconv.patch31
-rw-r--r--net-im/gaim/gaim-0.72-r2.ebuild93
4 files changed, 128 insertions, 2 deletions
diff --git a/net-im/gaim/Manifest b/net-im/gaim/Manifest
index 3913d9fc3dfe..6d5bb8b13420 100644
--- a/net-im/gaim/Manifest
+++ b/net-im/gaim/Manifest
@@ -1,11 +1,11 @@
MD5 bed467c3e7077888cf4fd615c5f47678 gaim-0.67.ebuild 2185
-MD5 342e4551242434866e8f931de7b1a842 gaim-0.72-r2.ebuild 2878
+MD5 d1b0d9704741e21d73fffe71adfb4b7e gaim-0.72-r2.ebuild 2878
MD5 7f89f602fb6fe4954a39c6909cbf3333 gaim-0.71-r2.ebuild 2658
MD5 4a04b7141773d5909599119a5659e025 gaim-0.72-r1.ebuild 2511
MD5 9319539d29d9fb3908789ccf6026d7db gaim-0.66-r3.ebuild 1991
MD5 9c060fe66488650173c0a493e8744b0a gaim-0.72.ebuild 2508
MD5 1a9b1940485519f26cffa675c833ca7d gaim-0.70-r2.ebuild 2506
-MD5 9444d34024475ebe88e07549b131f4e2 ChangeLog 15254
+MD5 450ec2f5975eba3953141b158191f68f ChangeLog 15254
MD5 dc9ef26d3efea7cbe38cbe534cdeaa53 metadata.xml 510
MD5 5993641de8d56c2c433f252997c3c39c files/digest-gaim-0.67 135
MD5 e6a8773cabdf14d7422e573723258437 files/digest-gaim-0.72 135
diff --git a/net-im/gaim/files/digest-gaim-0.72-r2 b/net-im/gaim/files/digest-gaim-0.72-r2
new file mode 100644
index 000000000000..bd08cc5b99b3
--- /dev/null
+++ b/net-im/gaim/files/digest-gaim-0.72-r2
@@ -0,0 +1,2 @@
+MD5 2eb9478126ffc76b9a5f3cbf7cd82062 gaim-0.72.tar.bz2 3165345
+MD5 c7cea5b99b2e05f083db77032b0457d5 gaim-encryption-2.17.tar.gz 316928
diff --git a/net-im/gaim/files/gaim_cjk_gtkconv.patch b/net-im/gaim/files/gaim_cjk_gtkconv.patch
new file mode 100644
index 000000000000..9b94bcfacad3
--- /dev/null
+++ b/net-im/gaim/files/gaim_cjk_gtkconv.patch
@@ -0,0 +1,31 @@
+diff -uNr gaim-0.72.orig/src/gtkconv.c gaim-0.72/src/gtkconv.c
+--- gaim-0.72.orig/src/gtkconv.c 2003-09-07 01:22:47.000000000 +0900
++++ gaim-0.72/src/gtkconv.c 2003-09-07 01:25:08.000000000 +0900
+@@ -1136,12 +1136,28 @@
+ GaimConversation *conv;
+ GaimGtkConversation *gtkconv;
+ GaimGtkWindow *gtkwin;
++ gboolean im_context_retval = FALSE;
++ static guint32 last_event_time;
+
+ conv = (GaimConversation *)data;
+ gtkconv = GAIM_GTK_CONVERSATION(conv);
+ win = gaim_conversation_get_window(conv);
+ gtkwin = GAIM_GTK_WINDOW(win);
+
++ /*
++ * Check if the input method handles this keyevent or we can use it.
++ * We need to check the event time, otherwise the gtk xim module gets into an event loop (bug?)
++ * Maybe this is not the best solution, but it works.
++ */
++
++ if (last_event_time != event->time) {
++ im_context_retval = gtk_im_context_filter_keypress(GTK_TEXT_VIEW(gtkconv->entry)->im_context, event);
++ }
++ last_event_time = event->time;
++ if (im_context_retval == TRUE) {
++ return TRUE;
++ }
++
+ if (event->keyval == GDK_Page_Up) {
+ g_signal_stop_emission_by_name(G_OBJECT(entry), "key_press_event");
diff --git a/net-im/gaim/gaim-0.72-r2.ebuild b/net-im/gaim/gaim-0.72-r2.ebuild
new file mode 100644
index 000000000000..f97c6a5a1b0b
--- /dev/null
+++ b/net-im/gaim/gaim-0.72-r2.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-0.72-r2.ebuild,v 1.1 2003/11/12 19:34:12 rizzo Exp $
+
+IUSE="nls perl spell nas ssl cjk"
+
+DESCRIPTION="GTK Instant Messenger client"
+HOMEPAGE="http://gaim.sourceforge.net/"
+EV=2.17
+SRC_URI="mirror://sourceforge/gaim/${P}.tar.bz2
+ ssl? ( mirror://sourceforge/gaim-encryption/gaim-encryption-${EV}.tar.gz )"
+RESTRICT="nomirror"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="=sys-libs/db-1*
+ >=x11-libs/gtk+-2.0
+ >=dev-libs/glib-2.0
+ nas? ( >=media-libs/nas-1.4.1-r1 )
+ sys-devel/gettext
+ media-libs/libao
+ >=media-libs/audiofile-0.2.0
+ perl? ( >=dev-lang/perl-5.6.1
+ >=sys-apps/sed-4.0.0 )
+ dev-libs/nss
+ spell? ( >=app-text/gtkspell-2.0.2 )"
+
+src_unpack() {
+ unpack ${A} || die
+ use cjk && epatch ${FILESDIR}/gaim_cjk_gtkconv.patch
+
+ use ssl && {
+ cd ${S}/plugins
+ unpack gaim-encryption-${EV}.tar.gz
+ }
+}
+
+src_compile() {
+
+ local myconf
+ use perl || myconf="${myconf} --disable-perl"
+ use spell || myconf="${myconf} --disable-gtkspell"
+ use nls || myconf="${myconf} --disable-nls"
+ use nas && myconf="${myconf} --enable-nas" || myconf="${myconf} --disable-nas"
+ myconf="${myconf} --with-nspr-includes=/usr/include/nspr"
+ myconf="${myconf} --with-nss-includes=/usr/include/nss"
+
+ econf ${myconf} || die "Configuration failed"
+ use perl && sed -i -e 's:^\(PERL_MM_PARAMS =.*PREFIX=\)\(.*\):\1'${D}'\2:' plugins/perl/Makefile
+ emake || MAKEOPTS="${MAKEOPTS} -j1" emake || die "Make failed"
+
+ use ssl && {
+ local myencconf
+ cd ${S}/plugins/gaim-encryption-${EV}
+
+ myencconf="${myencconf} --with-nspr-includes=/usr/include/nspr"
+ myencconf="${myencconf} --with-nss-includes=/usr/include/nss"
+ econf ${myencconf} || die "Configuration failed for encryption"
+ emake || die "Make failed for encryption"
+ }
+}
+
+src_install() {
+ einstall || die "Install failed"
+ use ssl && {
+ cd ${S}/plugins/gaim-encryption-${EV}
+ einstall || die "Install failed for encryption"
+ cd ${S}
+ }
+ dodoc ABOUT-NLS AUTHORS COPYING HACKING INSTALL NEWS PROGRAMMING_NOTES README ChangeLog VERSION
+}
+
+pkg_postinst() {
+ if [ `use cjk` ]; then
+ ewarn
+ ewarn "You have chosen (by selecting 'USE=cjk') to compile with"
+ ewarn "a patch for CJK support. Please be aware that this patch"
+ ewarn "causes problems with skkinput. kinput2 works fine. Details"
+ ewarn "can be found at http://bugs.gentoo.org/show_bug.cgi?id=24657#c23"
+ ewarn
+ fi
+
+ if [ `use ssl` ]; then
+ ewarn
+ ewarn "You have chosen (by selecting 'USE=ssl') to install"
+ ewarn "the gaim-encryption plugin ( http://gaim-encryption.sf.net/ )"
+ ewarn "this plugin is NOT supported by the Gaim project, and if you"
+ ewarn "expierence problems related to it, contact the Gentoo project"
+ ewarn "via http://bugs.gentoo.org/ or the gaim-encryption project."
+ fi
+}