summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2005-11-12 12:02:08 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2005-11-12 12:02:08 +0000
commit8ac855920abfa1f2ccc8b6c827b06a91c187fe69 (patch)
tree01f964f2b82f3f6c542764657c76ac2d3e432123 /net-im
parentversion bump (diff)
downloadhistorical-8ac855920abfa1f2ccc8b6c827b06a91c187fe69.tar.gz
historical-8ac855920abfa1f2ccc8b6c827b06a91c187fe69.tar.bz2
historical-8ac855920abfa1f2ccc8b6c827b06a91c187fe69.zip
+ config.cache using
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'net-im')
-rw-r--r--net-im/licq/ChangeLog7
-rw-r--r--net-im/licq/Manifest4
-rw-r--r--net-im/licq/files/digest-licq-1.3.2-r11
-rw-r--r--net-im/licq/licq-1.3.2-r1.ebuild219
4 files changed, 229 insertions, 2 deletions
diff --git a/net-im/licq/ChangeLog b/net-im/licq/ChangeLog
index 9db68a5a7323..cbc077a92333 100644
--- a/net-im/licq/ChangeLog
+++ b/net-im/licq/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/licq
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/licq/ChangeLog,v 1.67 2005/10/21 16:08:34 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/ChangeLog,v 1.68 2005/11/12 12:02:08 voxus Exp $
+
+*licq-1.3.2-r1 (12 Nov 2005)
+
+ 12 Nov 2005; Konstantin Arkhipov <voxus@gentoo.org> +licq-1.3.2-r1.ebuild:
+ Now using configure's cache to speed up things a bit.
*licq-1.3.2 (21 Oct 2005)
diff --git a/net-im/licq/Manifest b/net-im/licq/Manifest
index a628ad103cad..f7544cf4a79f 100644
--- a/net-im/licq/Manifest
+++ b/net-im/licq/Manifest
@@ -1,4 +1,4 @@
-MD5 8637c8dbfc8abe0e9f51b11886437ec4 ChangeLog 10974
+MD5 3782305b6f92017d9435f6f11881f629 ChangeLog 11138
MD5 c18e90be9c36c7efb06211733ad765ff files/1.2.7-debugflag.patch 396
MD5 5f64e4b71c311ff7b6489953fc8bf1f9 files/1.2.7-nptl.patch 1178
MD5 5dbb2a47d1d863a55f564e874c871d30 files/1.3.0-gpgme3_hack.patch 878
@@ -8,7 +8,9 @@ MD5 60faacd9044ad4dd88db77e0bd53dc7f files/1.3.2-email_typo.patch 620
MD5 3795e526fdf015e985be17fca698e2d1 files/digest-licq-1.2.7 64
MD5 b0a924ef22c21dd596d7918631f18559 files/digest-licq-1.3.0 64
MD5 b7d176e7d3091d82fed1f4931604b327 files/digest-licq-1.3.2 64
+MD5 b7d176e7d3091d82fed1f4931604b327 files/digest-licq-1.3.2-r1 64
MD5 f30c97a120a37f90edd8abdf612cd52a licq-1.2.7.ebuild 3368
MD5 f8691d71dd37438ad228897e6e32b908 licq-1.3.0.ebuild 3800
+MD5 39976c399125cfc20eb56d93a9c13bdd licq-1.3.2-r1.ebuild 4997
MD5 be3db28b37bde83712d9f00b55ffc640 licq-1.3.2.ebuild 4868
MD5 7adc6310a4dbd42bad26caa80683d4ec metadata.xml 249
diff --git a/net-im/licq/files/digest-licq-1.3.2-r1 b/net-im/licq/files/digest-licq-1.3.2-r1
new file mode 100644
index 000000000000..38bccae79e8a
--- /dev/null
+++ b/net-im/licq/files/digest-licq-1.3.2-r1
@@ -0,0 +1 @@
+MD5 0471bb8fed91eefb23dfe153c9a4a806 licq-1.3.2.tar.bz2 3980117
diff --git a/net-im/licq/licq-1.3.2-r1.ebuild b/net-im/licq/licq-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..7f3c8e73a148
--- /dev/null
+++ b/net-im/licq/licq-1.3.2-r1.ebuild
@@ -0,0 +1,219 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/licq-1.3.2-r1.ebuild,v 1.1 2005/11/12 12:02:08 voxus Exp $
+
+inherit eutils kde-functions multilib
+
+DESCRIPTION="ICQ Client with v8 support"
+HOMEPAGE="http://www.licq.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~ia64 ~amd64"
+IUSE="ssl socks5 qt kde ncurses crypt msn"
+
+# we can't have conditional dependencies so "use kde && inherit kde"
+# won't work -- messes up dep caching.
+
+# need-kde and their eclass friends inject things into DEPEND. But we only
+# want them enabled if the kde USE flag is set. We get around this in the
+# following dep lines:
+RDEPEND="kde? ( >=kde-base/kdelibs-3.0 )"
+DEPEND="kde? ( >=kde-base/kdelibs-3.0 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ qt? ( =x11-libs/qt-3* )
+ ncurses? ( sys-libs/ncurses >=dev-libs/cdk-4.9.11.20031210-r1 )
+ crypt? ( >=app-crypt/gpgme-1.0.0 )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ use ncurses && epatch ${FILESDIR}/1.3.0-suse_bool.patch
+
+ if use kde
+ then
+ # fix for #12436
+ inherit
+ ebegin "Setting kde plugin as default"
+ cp ${S}/src/licq.conf.h ${T}
+ sed "s:Plugin1 = qt-gui:Plugin1 = kde-gui:" \
+ ${T}/licq.conf.h > ${S}/src/licq.conf.h
+ eend $?
+ else
+ if ! use qt
+ then
+ ebegin "Setting console plugin as default..."
+ cp ${S}/src/licq.conf.h ${T}
+ sed "s:Plugin1 = qt-gui:Plugin1 = console:" \
+ ${T}/licq.conf.h > ${S}/src/licq.conf.h
+ eend $?
+ fi
+ fi
+
+ # Install plugins in the correct libdir
+ sed -i -e "s:lib/licq/:$(get_libdir)/licq/:" \
+ ${S}/include/licq_constants.h || die "sed failed"
+ sed -i -e 's:$(prefix)/lib:@libdir@:' \
+ ${S}/plugins/*/src/Makefile.{in,am} || die "sed failed"
+}
+
+src_compile() {
+
+ use ssl || myconf="${myconf} --disable-openssl"
+ use socks5 && myconf="${myconf} --enable-socks5"
+
+ if use crypt
+ then
+ myconf="${myconf} --enable-gpgme"
+ else
+ myconf="${myconf} --disable-gpgme"
+ fi
+
+ for n in `echo auto-reply console email msn qt-gui rms`; do
+ cd ${S}/plugins/${n}
+
+ ebegin "Recreating configure in plugins/${n}"
+ rm -f Makefile && make -f Makefile.cvs 2>&1 > /dev/null
+ eend ${?}
+ done
+
+ cd ${S}
+
+ # bug #21009
+ find . -name 'configure' -exec sed -e "s:sed 's/-g:sed 's/^-g:" -i {} \;
+
+ econf ${myconf} -C || die
+
+ CONFCACHE="--cache-file=${S}/config.cache"
+
+ use crypt && {
+ # workaround for gpgme's headers inclusion path
+ sed \
+ -e "s:FAULT_INCLUDES =:FAULT_INCLUDES = -I/usr/include/gpgme:" \
+ -i ${S}/src/Makefile
+ }
+
+ emake || die
+
+ # Create the various plug-ins
+
+ # First, the Qt plug-in
+ if use qt
+ then
+ set-qtdir 3
+ set-kdedir 3
+
+ use kde && myconf="${myconf} --with-kde"
+
+ # Problems finding qt on multilib systems
+ myconf="${myconf} --with-qt-libraries=${QTDIR}/$(get_libdir)"
+
+ # note! watch the --prefix=/usr placement;
+ # licq itself installs into /usr, but the
+ # optional kde/qt interface (to which second_conf belogns)
+ # installs its files in $KDE3DIR/{lib,share}/licq
+
+ cd ${S}/plugins/qt-gui
+ einfo "Compiling Qt GUI plug-in"
+ econf ${myconf} ${CONFCACHE} || die
+ emake || die
+ fi
+
+ # Now the console plug-in
+ if use ncurses
+ then
+ cd ${S}/plugins/console
+ einfo "Compiling the Console plug-in"
+ econf ${CONFCACHE} || die
+ emake || die
+ fi
+
+ # The Auto-Responder plug-in
+ cd ${S}/plugins/auto-reply
+ einfo "Compiling the Auto-Reply plug-in"
+ econf ${CONFCACHE} || die
+ emake || die
+
+ # The Remote Management Service
+ cd ${S}/plugins/rms
+ einfo "Compiling Remote Management Services plug-in"
+ econf ${CONFCACHE} || die
+ emake || die
+
+ # MSN PLugin
+ if use msn
+ then
+ cd ${S}/plugins/msn
+ einfo "Compiling MSN plug-in"
+ econf ${CONFCACHE} || die
+ emake || die
+ fi
+
+ # Email PLugin
+ cd ${S}/plugins/email
+ epatch ${FILESDIR}/${PV}-email_typo.patch
+ einfo "Compiling Email plug-in"
+ econf ${CONFCACHE} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc ChangeLog INSTALL README* doc/*
+
+ # Install the plug-ins
+ if use qt
+ then
+ cd ${S}/plugins/qt-gui
+ make DESTDIR=${D} install || die
+ docinto plugins/qt-gui
+ dodoc README*
+
+ fi
+
+ if use ncurses
+ then
+ cd ${S}/plugins/console
+ make DESTDIR=${D} install || die
+ docinto plugins/console
+ dodoc README
+ fi
+
+ if use msn
+ then
+ cd ${S}/plugins/msn
+ make DESTDIR=${D} install || die
+ docinto plugins/msn
+ dodoc README
+ fi
+
+ cd ${S}/plugins/auto-reply
+ make DESTDIR=${D} install || die
+ docinto plugins/auto-reply
+ dodoc README licq_autoreply.conf
+
+ cd ${S}/plugins/rms
+ make DESTDIR=${D} install || die
+ docinto plugins/rms
+ dodoc README licq_rms.conf
+
+ exeinto /usr/share/${PN}/upgrade
+ doexe ${S}/upgrade/*
+
+ # fixes bug #22136
+ rm -fR ${D}/var
+}
+
+pkg_postinst() {
+ echo
+ ewarn
+ ewarn "If you're upgrading from <=licq-1.3.0 - you have to manually "
+ ewarn "upgrade your existing licq installation. Please backup your "
+ ewarn "settings and look into: /usr/share/licq/upgrade for scripts."
+ ewarn
+ echo
+}