summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2004-03-17 19:50:00 +0000
committerMichael Januszewski <spock@gentoo.org>2004-03-17 19:50:00 +0000
commit5767802c2d7f0539f3ca91ecad99ce7f252b4730 (patch)
tree651d8c652b6c3478dd3e31a198d5a1db4a8d9ddc /net-im
parenttidy (diff)
downloadhistorical-5767802c2d7f0539f3ca91ecad99ce7f252b4730.tar.gz
historical-5767802c2d7f0539f3ca91ecad99ce7f252b4730.tar.bz2
historical-5767802c2d7f0539f3ca91ecad99ce7f252b4730.zip
Fixed Perl support, added preliminary support for gtkspell.
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gnugadu/ChangeLog5
-rw-r--r--net-im/gnugadu/Manifest4
-rw-r--r--net-im/gnugadu/gnugadu-2.0_pre8.ebuild12
3 files changed, 14 insertions, 7 deletions
diff --git a/net-im/gnugadu/ChangeLog b/net-im/gnugadu/ChangeLog
index 77fe427bd9bb..a8e811c1426b 100644
--- a/net-im/gnugadu/ChangeLog
+++ b/net-im/gnugadu/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-im/gnugadu
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gnugadu/ChangeLog,v 1.3 2004/03/17 16:03:05 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gnugadu/ChangeLog,v 1.4 2004/03/17 19:50:00 spock Exp $
+
+ 17 Mar 2004; Michal Januszewski <spock@gentoo.org> gnugadu-2.0_pre8.ebuild:
+ Fixed Perl support, added preliminary support for gtkspell.
*gnugadu-2.0_pre8 (17 Mar 2004)
diff --git a/net-im/gnugadu/Manifest b/net-im/gnugadu/Manifest
index e8d8ec68ee11..09ce171722ef 100644
--- a/net-im/gnugadu/Manifest
+++ b/net-im/gnugadu/Manifest
@@ -1,7 +1,7 @@
MD5 04c375152de7139ace81ad43c46ce6c5 gnugadu-2.0_pre6.ebuild 1256
-MD5 e55e34aaadafad6e696c35fdeaebedde gnugadu-2.0_pre8.ebuild 1288
+MD5 b1852c4afef94366c6f2ea1385dda5cc gnugadu-2.0_pre8.ebuild 1440
MD5 ccfc59a189a22da6a3d69f093b380aec gnugadu-2.0_pre7.ebuild 1288
-MD5 cc8f146c20c87cfb85b064dcd77aae08 ChangeLog 766
+MD5 d34a56e0cd643ab2a6f6ba279379e6dd ChangeLog 907
MD5 d94d306da3804e41296e1bf04c7c9cae metadata.xml 255
MD5 baa3a461b1bc11936966878547fb5233 files/digest-gnugadu-2.0_pre6 64
MD5 9e3c7a139cbf838ed9e6863762c42546 files/digest-gnugadu-2.0_pre7 64
diff --git a/net-im/gnugadu/gnugadu-2.0_pre8.ebuild b/net-im/gnugadu/gnugadu-2.0_pre8.ebuild
index b1edb407ec06..7a183edb0ab1 100644
--- a/net-im/gnugadu/gnugadu-2.0_pre8.ebuild
+++ b/net-im/gnugadu/gnugadu-2.0_pre8.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gnugadu/gnugadu-2.0_pre8.ebuild,v 1.1 2004/03/17 16:03:05 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gnugadu/gnugadu-2.0_pre8.ebuild,v 1.2 2004/03/17 19:50:00 spock Exp $
-IUSE="debug tlen esd oss xosd arts jabber perl"
+IUSE="debug tlen esd oss xosd arts jabber perl spell"
MY_P="gg2-2.0pre8"
S="${WORKDIR}/${MY_P}"
@@ -24,19 +24,23 @@ DEPEND=">=x11-libs/gtk+-2.2.0
>=net-im/ekg-1.4
arts? ( >=kde-base/arts-0.9.5 )
esd? ( media-sound/esound )
- tlen? ( net-libs/libtlen )"
+ tlen? ( net-libs/libtlen )
+ spell? ( app-text/gtkspell )"
src_compile() {
myconf="--with-gui --with-gadu --with-remote --with-docklet_system_tray --with-docklet_dockapp --with-sms --with-update --with-external"
+ # we don't use this just yet as it appears to be somewhat broken
+ # use spell && myconf="${myconf} --with-gtkspell"
+
econf ${myconf} \
`use_enable debug` \
`use_with oss` \
`use_with esd` \
`use_with xosd` \
`use_with arts` \
- `use_enable perl` \
+ `use_with perl` \
`use_with tlen` \
`use_with jabber` || die
emake || die