summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Medinas <metalgod@gentoo.org>2005-09-06 00:56:19 +0000
committerLuis Medinas <metalgod@gentoo.org>2005-09-06 00:56:19 +0000
commit3ea53d5a4ee4f88aa707314c0f06868b2a1764a5 (patch)
tree20ba9328d4a5919da4a1532349b36d8faf1c2300 /net-im/tmsnc
parentAdded to ~sparc. (diff)
downloadhistorical-3ea53d5a4ee4f88aa707314c0f06868b2a1764a5.tar.gz
historical-3ea53d5a4ee4f88aa707314c0f06868b2a1764a5.tar.bz2
historical-3ea53d5a4ee4f88aa707314c0f06868b2a1764a5.zip
New Package. Thanks to Pedro Algarvio <ufs@sapo.pt> for the inital import.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'net-im/tmsnc')
-rw-r--r--net-im/tmsnc/ChangeLog9
-rw-r--r--net-im/tmsnc/Manifest14
-rw-r--r--net-im/tmsnc/files/digest-tmsnc-0.2.41
-rw-r--r--net-im/tmsnc/metadata.xml16
-rw-r--r--net-im/tmsnc/tmsnc-0.2.4.ebuild38
5 files changed, 78 insertions, 0 deletions
diff --git a/net-im/tmsnc/ChangeLog b/net-im/tmsnc/ChangeLog
new file mode 100644
index 000000000000..faa19cc01dd2
--- /dev/null
+++ b/net-im/tmsnc/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-im/tmsnc
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/tmsnc/ChangeLog,v 1.1 2005/09/06 00:56:19 metalgod Exp $
+
+*tmsnc-0.2.4 (06 Sep 2005)
+
+ 06 Sep 2005; Luis Medinas <metalgod@gentoo.org> +tmsnc-0.2.4.ebuild:
+ New package. Thanks to Pedro Algarvio <ufs@sapo.pt> for the initial report.
+
diff --git a/net-im/tmsnc/Manifest b/net-im/tmsnc/Manifest
new file mode 100644
index 000000000000..6c1cbec5f568
--- /dev/null
+++ b/net-im/tmsnc/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 177f04d7f9b9d0fdb6098ea18ba57eb6 tmsnc-0.2.4.ebuild 1113
+MD5 36f66a009fb5b92f99a38268b1aeef78 ChangeLog 377
+MD5 5c9b94cb2db83edb8f198bc23fdbcffa metadata.xml 576
+MD5 fb5cdbfe31d6f8753f77a5d0868b5ff4 files/digest-tmsnc-0.2.4 63
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFDHPbxwUpWvClEHQoRAvXMAJ9y3sCawkmG3qx6dZpWhxnlBWaHZQCeJ9LG
+ZrDIy0o5ueysgP7xGt5UFAs=
+=n1y5
+-----END PGP SIGNATURE-----
diff --git a/net-im/tmsnc/files/digest-tmsnc-0.2.4 b/net-im/tmsnc/files/digest-tmsnc-0.2.4
new file mode 100644
index 000000000000..1cd352227dbf
--- /dev/null
+++ b/net-im/tmsnc/files/digest-tmsnc-0.2.4
@@ -0,0 +1 @@
+MD5 8e9d82ff81189c4dc364989818f02d8b tmsnc-0.2.4.tar.gz 205502
diff --git a/net-im/tmsnc/metadata.xml b/net-im/tmsnc/metadata.xml
new file mode 100644
index 000000000000..a014315639db
--- /dev/null
+++ b/net-im/tmsnc/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd></herd>
+<maintainer>
+<email>metalgod@gentoo.org</email>
+<name>Luis Medinas</name>
+</maintainer>
+<longdescription lang="en">
+TMSNC is a textbased (console) MSN client written in C. TMSNC should work on
+most Unix (Linux, BSD, MacOS) compatible operating systems. The goal of this
+project is to create a client like MSN Messenger (with sound, webcam and file
+transfer support), but without any graphical features.
+</longdescription>
+</pkgmetadata>
+
diff --git a/net-im/tmsnc/tmsnc-0.2.4.ebuild b/net-im/tmsnc/tmsnc-0.2.4.ebuild
new file mode 100644
index 000000000000..c1f22c68f3a3
--- /dev/null
+++ b/net-im/tmsnc/tmsnc-0.2.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/tmsnc/tmsnc-0.2.4.ebuild,v 1.1 2005/09/06 00:56:19 metalgod Exp $
+
+DESCRIPTION="TMSNC is a textbased MSN client written in C."
+HOMEPAGE="http://tmsnc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tmsnc/${P}.tar.gz"
+
+LICENSE="IRPDL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls ssl talkfilters"
+
+DEPEND="virtual/libc
+ >=sys-libs/ncurses-5.4
+ nls? ( sys-devel/gettext )
+ ssl? ( >=dev-libs/openssl-0.9.7d )
+ talkfilters? ( >=app-text/talkfilters-2.3.4 )"
+
+src_compile() {
+ local myconf
+ use nls \
+ || myconf="${myconf} --disable-nls"
+ use ssl \
+ || myconf="${myconf} --without-ssl"
+ use talkfilters \
+ || myconf="${myconf} --without-talkfilters"
+ econf ${myconf} || die "Configure failed"
+ emake || die "Make failed"
+}
+src_install() {
+ make DESTDIR=${D} install || die "Make install failed"
+ dodoc AUTHORS ChangeLog README NEWS
+}
+pkg_postinst() {
+ einfo "If you want talkfilters support you need to add"
+ einfo "USE=talkfilters to enable support in this package"
+}