summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2003-10-13 21:50:20 +0000
committerStefan Knoblich <stkn@gentoo.org>2003-10-13 21:50:20 +0000
commit4840d1b8ba9c806e12be32e474514f42ff93d4b3 (patch)
tree0f4e815bf2cd002d74a05f427be62b9691bada48 /net-im/linphone/linphone-0.12.0.ebuild
parentmake openh323u.mak pathes point to right locations, (required for other apps) (diff)
downloadhistorical-4840d1b8ba9c806e12be32e474514f42ff93d4b3.tar.gz
historical-4840d1b8ba9c806e12be32e474514f42ff93d4b3.tar.bz2
historical-4840d1b8ba9c806e12be32e474514f42ff93d4b3.zip
new maintainer. version bumped
Diffstat (limited to 'net-im/linphone/linphone-0.12.0.ebuild')
-rw-r--r--net-im/linphone/linphone-0.12.0.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/net-im/linphone/linphone-0.12.0.ebuild b/net-im/linphone/linphone-0.12.0.ebuild
new file mode 100644
index 000000000000..c22908544e54
--- /dev/null
+++ b/net-im/linphone/linphone-0.12.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/linphone/linphone-0.12.0.ebuild,v 1.1 2003/10/13 21:50:14 stkn Exp $
+
+IUSE="doc gnome gtk2 gtk nls xv alsa"
+
+DESCRIPTION="Linphone is a Web phone with a GNOME interface."
+HOMEPAGE="http://www.linphone.org/?lang=us"
+SRC_URI="http://simon.morlat.free.fr/download/${PV}/source/${P}.tar.gz"
+
+SLOT="1"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm"
+
+DEPEND="dev-libs/glib
+ >=net-libs/libosip-0.9.6
+ dev-util/pkgconfig
+ xv? ( dev-lang/nasm )
+ gtk? ( =x11-libs/gtk+-1.2* )
+ gtk2? ( >=x11-libs/gtk+-2 )
+ gnome? ( gnome-base/gnome-panel
+ gnome-base/libgnome
+ gnome-base/libgnomeui )
+ alsa? ( >media-libs/alsa-lib-0.5 )
+ doc? ( dev-util/gtk-doc )"
+
+src_compile() {
+
+ local myconf
+
+ if use gnome
+ then
+ use gtk2 && myconf="${myconf} --enable-platform-gnome-2"
+ else
+ use gnome || myconf="${myconf}--enable-gnome_ui=no"
+ fi
+
+ if use gtk && use doc
+ then
+ myconf="${myconf} --enable-gtk-doc"
+ else
+ myconf="${myconf} --disable-gtk-doc"
+ fi
+
+ econf \
+ `use_enable alsa` \
+ `use_enable nls` \
+ ${myconf} || die
+ emake || die
+}
+
+src_install () {
+ dodoc ABOUT-NLS COPYING README AUTHORS BUGS INSTALL NEWS ChangeLog TODO
+ einstall PIXDESTDIR=${D} || die
+}