summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2004-03-14 12:08:56 +0000
committerHeinrich Wendel <lanius@gentoo.org>2004-03-14 12:08:56 +0000
commit6766d73ac90daea142d24145b8ce2f5b6710fd32 (patch)
tree0fe1813c0733bbda6082cc7bcc44d01ade8ff0ea /net-im/licq
parentdon't try to assign to A; header fix (diff)
downloadhistorical-6766d73ac90daea142d24145b8ce2f5b6710fd32.tar.gz
historical-6766d73ac90daea142d24145b8ce2f5b6710fd32.tar.bz2
historical-6766d73ac90daea142d24145b8ce2f5b6710fd32.zip
compile with nptl, bug #44126
Diffstat (limited to 'net-im/licq')
-rw-r--r--net-im/licq/ChangeLog6
-rw-r--r--net-im/licq/Manifest7
-rw-r--r--net-im/licq/files/1.2.7-nptl.patch34
-rw-r--r--net-im/licq/licq-1.2.7.ebuild5
4 files changed, 46 insertions, 6 deletions
diff --git a/net-im/licq/ChangeLog b/net-im/licq/ChangeLog
index 2930e2e5009a..f8f33c885407 100644
--- a/net-im/licq/ChangeLog
+++ b/net-im/licq/ChangeLog
@@ -1,10 +1,14 @@
# ChangeLog for net-im/licq
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/licq/ChangeLog,v 1.34 2004/02/17 23:07:25 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/ChangeLog,v 1.35 2004/03/14 12:08:56 lanius Exp $
17 Feb 2004; Aron Griffis <agriffis@gentoo.org> licq-1.2.7.ebuild:
stable on alpha and ia64
+ 14 Mar 2004; Heinrich Wendel <lanius@gentoo.org> licq-1.2.7.ebuild,
+ files/1.2.7-nptl.patch:
+ compile with nptl, bug #44126
+
19 Oct 2003; Heinrich Wendel <lanius@gentoo.org> licq-1.2.6-r1.ebuild,
licq-1.2.6.ebuild, licq-1.2.7.ebuild:
cleanups, bug #22136
diff --git a/net-im/licq/Manifest b/net-im/licq/Manifest
index c63d9a395553..e24c9f15a396 100644
--- a/net-im/licq/Manifest
+++ b/net-im/licq/Manifest
@@ -1,4 +1,5 @@
-MD5 730fa026d7b6ea01c0598e39757e6497 ChangeLog 5259
-MD5 9b94ed29a877d04f9279621cf181e809 licq-1.2.7.ebuild 3537
-MD5 c18e90be9c36c7efb06211733ad765ff files/1.2.7-debugflag.patch 396
+MD5 e78ebaeb51eedfa2e396528232032d3b licq-1.2.7.ebuild 3545
+MD5 e208048c77714d745674e05a3b423e46 ChangeLog 5386
MD5 3795e526fdf015e985be17fca698e2d1 files/digest-licq-1.2.7 64
+MD5 c18e90be9c36c7efb06211733ad765ff files/1.2.7-debugflag.patch 396
+MD5 5f64e4b71c311ff7b6489953fc8bf1f9 files/1.2.7-nptl.patch 1178
diff --git a/net-im/licq/files/1.2.7-nptl.patch b/net-im/licq/files/1.2.7-nptl.patch
new file mode 100644
index 000000000000..0308b33bde31
--- /dev/null
+++ b/net-im/licq/files/1.2.7-nptl.patch
@@ -0,0 +1,34 @@
+Index: configure.in
+===================================================================
+RCS file: /cvsroot/licq/licq/configure.in,v
+retrieving revision 1.63
+diff -u -d -p -r1.63 configure.in
+--- configure.in 2 Jul 2003 04:44:47 -0000 1.63
++++ configure.in 1 Jan 2004 01:46:12 -0000
+@@ -142,6 +142,8 @@ dlopen(NULL, RTLD_NOW)
+
+ AC_CHECK_FUNCS(inet_addr inet_aton mktime select strdup strerror hstrerror readdir_r)
+
++AC_CHECK_FUNC(pthread_kill_other_threads_np,[AC_DEFINE([HAVE_PTHREAD_KILL_OTHER_THREADS_NP],
++[], [we are not using NTPL])])
+ AC_CHECK_SOCKS5
+ LICQ_CHECK_OPENSSL
+
+Index: src/sighandler.c
+===================================================================
+RCS file: /cvsroot/licq/licq/src/sighandler.c,v
+retrieving revision 1.5
+diff -u -d -p -r1.5 sighandler.c
+--- src/sighandler.c 16 Jun 2003 17:09:46 -0000 1.5
++++ src/sighandler.c 1 Jan 2004 01:46:12 -0000
+@@ -83,7 +83,10 @@ void licq_handle_sigsegv(int s)
+ fprintf(stderr, "%s\n", res[0]);*/
+ }
+ fprintf(stderr, "Attempting to generate core file.\n");
++
++ #ifdef HAVE_PTHREAD_KILL_OTHER_THREADS_NP
+ pthread_kill_other_threads_np();
++ #endif
+ #endif
+
+ abort();
diff --git a/net-im/licq/licq-1.2.7.ebuild b/net-im/licq/licq-1.2.7.ebuild
index 442574b2d713..528b110ad70c 100644
--- a/net-im/licq/licq-1.2.7.ebuild
+++ b/net-im/licq/licq-1.2.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/licq/licq-1.2.7.ebuild,v 1.10 2004/02/17 23:07:25 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/licq-1.2.7.ebuild,v 1.11 2004/03/14 12:08:56 lanius Exp $
DESCRIPTION="ICQ Client with v8 support"
HOMEPAGE="http://www.licq.org/"
@@ -45,7 +45,8 @@ src_unpack() {
fi
fi
cd ${S}
- patch -p0 < ${FILESDIR}/1.2.7-debugflag.patch || die "patch failed"
+ epatch ${FILESDIR}/1.2.7-debugflag.patch
+ epatch ${FILESDIR}/1.2.7-nptl.patch
}
src_compile() {