summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2003-01-31 18:08:10 +0000
committerDan Armak <danarmak@gentoo.org>2003-01-31 18:08:10 +0000
commit1b4a9f096ae8c3984ba1bcb10308d34d9722c55e (patch)
tree25ef461f6243ef95a67281b28036b100461637f9 /net-im/licq
parentthe new version for gnome 2.2rc2 (diff)
downloadhistorical-1b4a9f096ae8c3984ba1bcb10308d34d9722c55e.tar.gz
historical-1b4a9f096ae8c3984ba1bcb10308d34d9722c55e.tar.bz2
historical-1b4a9f096ae8c3984ba1bcb10308d34d9722c55e.zip
new rev to fix bug #12436: create a symlink from the qt-only gui plugin to the kde
one when the kde plugin is built
Diffstat (limited to 'net-im/licq')
-rw-r--r--net-im/licq/ChangeLog11
-rw-r--r--net-im/licq/files/digest-licq-1.2.4-r11
-rw-r--r--net-im/licq/licq-1.2.4-r1.ebuild72
3 files changed, 82 insertions, 2 deletions
diff --git a/net-im/licq/ChangeLog b/net-im/licq/ChangeLog
index bd3bb7c2559c..648dac9e6e29 100644
--- a/net-im/licq/ChangeLog
+++ b/net-im/licq/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/licq
-# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-im/licq/ChangeLog,v 1.10 2003/01/29 19:09:43 hannes Exp $
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/ChangeLog,v 1.11 2003/01/31 18:08:10 danarmak Exp $
+
+*licq-1.2.4-r1 (31 Jan 2003)
+
+ 31 Jan 2003; Dan Armak <danarmak@gentoo.org> ChangeLog :
+
+ Fix bug #12436: create a symlink from the qt-only gui plugin to the kde
+ one when the kde plugin is built.
*licq-1.2.4 (29 Jan 2003)
diff --git a/net-im/licq/files/digest-licq-1.2.4-r1 b/net-im/licq/files/digest-licq-1.2.4-r1
new file mode 100644
index 000000000000..42f62183e2b1
--- /dev/null
+++ b/net-im/licq/files/digest-licq-1.2.4-r1
@@ -0,0 +1 @@
+MD5 3267518199e440a2c7be5e608b05bfd4 licq-1.2.4.tar.bz2 2952409
diff --git a/net-im/licq/licq-1.2.4-r1.ebuild b/net-im/licq/licq-1.2.4-r1.ebuild
new file mode 100644
index 000000000000..844636ee3bd0
--- /dev/null
+++ b/net-im/licq/licq-1.2.4-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/licq-1.2.4-r1.ebuild,v 1.1 2003/01/31 18:08:10 danarmak Exp $
+
+IUSE="ssl socks5 qt kde"
+
+DESCRIPTION="ICQ Client with v8 support"
+HOMEPAGE="http://www.licq.org"
+LICENSE="GPL-2"
+
+DEPEND="${DEPEND}
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ qt? ( >=x11-libs/qt-3.0.0 )"
+
+SRC_URI="http://download.sourceforge.net/licq/${P}.tar.bz2"
+SLOT="2"
+KEYWORDS="~x86"
+
+use kde && inherit kde-base
+use kde && need-kde 3.0
+
+src_compile() {
+
+ local first_conf
+ use ssl || first_conf = "${first_conf} --disable-openssl"
+ use socks5 && first_conf = "${first_conf} --enable-socks5"
+
+ ./configure --host=${CHOST} --prefix=/usr ${first_conf} || die
+ emake || die
+
+ if [ "`use qt`" ]
+ then
+ # A hack to build against the latest QT:
+ local v
+ for v in /usr/qt/[0-9]
+ do
+ [ -d "${v}" ] && export QTDIR="${v}"
+ done
+ use kde && kde_src_compile myconf
+ use kde && second_conf="${second_conf} ${myconf} --with-kde"
+
+ # note! watch the --prefix=/usr placement;
+ # licq itself installs into /usr, but the
+ # optional kde/qt interface (to which second_conf belogns)
+ # installs its files in $KDE3DIR/{lib,share}/licq
+
+ cd plugins/qt-gui
+ ./configure --host=${CHOST} ${second_conf} --prefix=/usr || die
+ emake || die
+ fi
+
+}
+
+src_install() {
+
+ cd ${S}
+ make DESTDIR=${D} install || die
+ if [ "`use qt`" ]
+ then
+ cd plugins/qt-gui
+ make DESTDIR=${D} install || die
+
+ # fix bug #12436, see my comment there
+ if [ "`use kde`" ]; then
+ cd $D/usr/lib/licq
+ ln -s licq_kde-gui.la licq_qt-gui.la
+ ln -s licq_kde-gui.so licq_qt-gui.so
+ fi
+
+ fi
+
+}