summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-02-07 20:47:56 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-02-07 20:47:56 +0000
commitcfb447da2f7cdb2195d7df1ea31746df7ef75546 (patch)
treee97af5c9cad5e82251852b4329080f224ee7f949 /net-im/licq/licq-1.2.4-r2.ebuild
parentAdded hppa to keywords. (diff)
downloadhistorical-cfb447da2f7cdb2195d7df1ea31746df7ef75546.tar.gz
historical-cfb447da2f7cdb2195d7df1ea31746df7ef75546.tar.bz2
historical-cfb447da2f7cdb2195d7df1ea31746df7ef75546.zip
plugin correction
Diffstat (limited to 'net-im/licq/licq-1.2.4-r2.ebuild')
-rw-r--r--net-im/licq/licq-1.2.4-r2.ebuild28
1 files changed, 24 insertions, 4 deletions
diff --git a/net-im/licq/licq-1.2.4-r2.ebuild b/net-im/licq/licq-1.2.4-r2.ebuild
index 8ebdf9783541..06e3f763ac11 100644
--- a/net-im/licq/licq-1.2.4-r2.ebuild
+++ b/net-im/licq/licq-1.2.4-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/licq/licq-1.2.4-r2.ebuild,v 1.4 2003/02/07 15:13:59 lordvan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/licq-1.2.4-r2.ebuild,v 1.5 2003/02/07 20:47:56 seemant Exp $
-IUSE="ssl socks5 qt kde ncurses"
+IUSE="ssl socks5 qt kde gtk ncurses"
use kde && inherit kde-base
use kde && need-kde 3.0
@@ -21,6 +21,28 @@ SRC_URI="http://download.sourceforge.net/licq/${P}.tar.bz2"
SLOT="2"
KEYWORDS="x86"
+src_unpack() {
+ unpack ${A}
+
+ if [ -z "`use qt`" ]
+ then
+ if [ -z "`use gtk`" ]
+ then
+ ebegin "Setting console plugin as default..."
+ cp ${S}/src/licq.conf.h ${T}
+ sed "s:Plugin1 = qt-gui:Plugin1 = console:" \
+ ${T}/licq.conf.h > ${S}/src/licq.conf.h
+ eend $?
+ else
+ ebegin "Setting GTK plugin as default..."
+ cp ${S}/src/licq.conf.h ${T}
+ sed "s:Plugin1 = qt-gui:Plugin1 = gtk-gui:" \
+ ${T}/licq.conf.h > ${S}/src/licq.conf.h
+ eend $?
+ fi
+ fi
+}
+
src_compile() {
local first_conf
@@ -136,6 +158,4 @@ src_install() {
make DESTDIR=${D} install || die
docinto plugins/rms
dodoc README licq_rms.conf
-
-
}