summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimone Gotti <motaboy@gentoo.org>2004-11-24 23:35:59 +0000
committerSimone Gotti <motaboy@gentoo.org>2004-11-24 23:35:59 +0000
commite4e6cf32dc9240f1ed3db33f37350549016aecc6 (patch)
tree62612733c44c3fcabb09eebb0a804b5a9496a0f9 /net-im/kmess
parentAdded missing digest entries. (diff)
downloadhistorical-e4e6cf32dc9240f1ed3db33f37350549016aecc6.tar.gz
historical-e4e6cf32dc9240f1ed3db33f37350549016aecc6.tar.bz2
historical-e4e6cf32dc9240f1ed3db33f37350549016aecc6.zip
Added a patch to fix various compilation problems. Fixes bug #62793. Also added missing metadata.xml.
Diffstat (limited to 'net-im/kmess')
-rw-r--r--net-im/kmess/ChangeLog7
-rw-r--r--net-im/kmess/Manifest6
-rw-r--r--net-im/kmess/files/kmess-1.3-compilation-fix.patch46
-rw-r--r--net-im/kmess/kmess-1.3.ebuild10
-rw-r--r--net-im/kmess/metadata.xml5
5 files changed, 69 insertions, 5 deletions
diff --git a/net-im/kmess/ChangeLog b/net-im/kmess/ChangeLog
index 2700585e0acf..e0d8616e3a16 100644
--- a/net-im/kmess/ChangeLog
+++ b/net-im/kmess/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/kmess
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/kmess/ChangeLog,v 1.16 2004/06/28 20:36:44 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/kmess/ChangeLog,v 1.17 2004/11/24 23:35:59 motaboy Exp $
+
+ 25 Nov 2004; Simone Gotti <motaboy@gentoo.org> +metadata.xml,
+ +files/kmess-1.3-compilation-fix.patch, kmess-1.3.ebuild:
+ Added a patch to fix various compilation problems. Fixes bug #62793. Also
+ added missing metadata.xml.
28 Jun 2004; Carsten Lohrke <carlo@gentoo.org> kmess-1.2.1.ebuild,
kmess-1.3.ebuild:
diff --git a/net-im/kmess/Manifest b/net-im/kmess/Manifest
index 897a5f0c6547..5736754638b5 100644
--- a/net-im/kmess/Manifest
+++ b/net-im/kmess/Manifest
@@ -1,5 +1,7 @@
-MD5 18d2d5c45281e2fecba4cad9647c2d74 kmess-1.3.ebuild 457
+MD5 e03feda925e250782478c0a663bae093 kmess-1.3.ebuild 541
MD5 bbff0837faec9229d6102f9a6e443fcc kmess-1.2.1.ebuild 454
-MD5 31ef7073273832025109ae442086b5d6 ChangeLog 2533
+MD5 9d4dc9d9814de2d0cdeb844af1568b9b ChangeLog 2766
+MD5 77a747b5fbf7edf698a0c698141ecf02 metadata.xml 163
MD5 643bf57d56166379ea9ffc3a558e0006 files/digest-kmess-1.2.1 64
MD5 c383ac2a5ed132e6b2ab8a5ea59a09ba files/digest-kmess-1.3 62
+MD5 e12777ab311fc4456e711cac5452542d files/kmess-1.3-compilation-fix.patch 1673
diff --git a/net-im/kmess/files/kmess-1.3-compilation-fix.patch b/net-im/kmess/files/kmess-1.3-compilation-fix.patch
new file mode 100644
index 000000000000..41af6d63f327
--- /dev/null
+++ b/net-im/kmess/files/kmess-1.3-compilation-fix.patch
@@ -0,0 +1,46 @@
+diff -ur kmess-1.3.orig/kmess/contact/contactdrag.h kmess-1.3/kmess/contact/contactdrag.h
+--- kmess-1.3.orig/kmess/contact/contactdrag.h 2004-11-25 00:15:52.688284592 +0000
++++ kmess-1.3/kmess/contact/contactdrag.h 2004-11-25 00:18:16.556413312 +0000
+@@ -23,7 +23,7 @@
+ namespace ContactDragInfo
+ {
+ const char mimeType[] = "application/x-kmess-contact";
+-};
++}
+
+ class ContactDragObject : public QDragObject
+ {
+diff -ur kmess-1.3.orig/kmess/network/msnconnection.h kmess-1.3/kmess/network/msnconnection.h
+--- kmess-1.3.orig/kmess/network/msnconnection.h 2004-11-25 00:17:06.672037352 +0000
++++ kmess-1.3/kmess/network/msnconnection.h 2004-11-25 00:09:32.263118008 +0000
+@@ -153,7 +153,7 @@
+ // Whether or not the object was initialized
+ bool initialized_;
+ // A string handler, required for the manipulation of certain strings
+- const KStringHandler kStringHandler_;
++ KStringHandler kStringHandler_;
+ // Number of errant pings since last good one
+ int missedPings_;
+ // Whether the last ping send got a reply
+Only in kmess-1.3/kmess/network: msnconnection.h.orig
+diff -ur kmess-1.3.orig/kmess/specialgroups.h kmess-1.3/kmess/specialgroups.h
+--- kmess-1.3.orig/kmess/specialgroups.h 2004-11-25 00:15:52.698283072 +0000
++++ kmess-1.3/kmess/specialgroups.h 2004-11-25 00:17:35.416667504 +0000
+@@ -28,7 +28,7 @@
+ const int GNOMEMEETING = 3;
+ const int REMOTEDESKTOP = 4;
+ const int KDEREMOTEDESKTOP = 5;
+-};
++}
+
+ namespace SpecialGroups
+ {
+@@ -36,7 +36,7 @@
+ const QString OFFLINE = "97";
+ const QString ALLOWED = "98";
+ const QString REMOVED = "99";
+-};
++}
+
+ namespace SpecialColumns
+ {
diff --git a/net-im/kmess/kmess-1.3.ebuild b/net-im/kmess/kmess-1.3.ebuild
index 342fa0f5daf5..00cf57e25cb9 100644
--- a/net-im/kmess/kmess-1.3.ebuild
+++ b/net-im/kmess/kmess-1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/kmess/kmess-1.3.ebuild,v 1.6 2004/06/28 20:36:44 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/kmess/kmess-1.3.ebuild,v 1.7 2004/11/24 23:35:59 motaboy Exp $
inherit kde
@@ -15,4 +15,10 @@ KEYWORDS="x86 ~sparc ~ppc"
IUSE=""
DEPEND="kde-base/kdenetwork"
-need-kde 3 \ No newline at end of file
+need-kde 3
+
+src_unpack() {
+ kde_src_unpack
+
+ epatch ${FILESDIR}/${P}-compilation-fix.patch
+} \ No newline at end of file
diff --git a/net-im/kmess/metadata.xml b/net-im/kmess/metadata.xml
new file mode 100644
index 000000000000..7a70bd761f0b
--- /dev/null
+++ b/net-im/kmess/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde-themes</herd>
+</pkgmetadata>