summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2004-01-12 01:35:23 +0000
committerDon Seiler <rizzo@gentoo.org>2004-01-12 01:35:23 +0000
commit386725fec1c382b601afe7cbb4ca783767c6a17d (patch)
tree6a261a3daa1b741e93284011e2d075abc03ca939 /net-im/jud
parentInitial jud transport for jabberd checkin. (diff)
downloadhistorical-386725fec1c382b601afe7cbb4ca783767c6a17d.tar.gz
historical-386725fec1c382b601afe7cbb4ca783767c6a17d.tar.bz2
historical-386725fec1c382b601afe7cbb4ca783767c6a17d.zip
Initial jud transport for jabberd checkin.
Diffstat (limited to 'net-im/jud')
-rw-r--r--net-im/jud/Manifest3
-rw-r--r--net-im/jud/files/README.Gentoo32
-rw-r--r--net-im/jud/files/digest-jud-0.51
-rw-r--r--net-im/jud/files/jud-makefile.patch11
-rw-r--r--net-im/jud/jud-0.5.ebuild38
-rw-r--r--net-im/jud/metadata.xml11
6 files changed, 95 insertions, 1 deletions
diff --git a/net-im/jud/Manifest b/net-im/jud/Manifest
index b86ece36701b..e90510332747 100644
--- a/net-im/jud/Manifest
+++ b/net-im/jud/Manifest
@@ -1,4 +1,5 @@
-MD5 7ad6be12f7c605fddff991fb12fbc725 jud-0.5.ebuild 596
+MD5 d39f30cd8e9c0cd19e40b8a10414acea jud-0.5.ebuild 826
+MD5 ac8e339a86b2748a8a48b1c78a8a5c1c ChangeLog 440
MD5 f0b233cbf1fcb1417cbf11da9c5e928a metadata.xml 422
MD5 203506aecb2d9a773e3ac2cf57db211d files/digest-jud-0.5 57
MD5 775b51608a055bdeb7302915baaec5de files/README.Gentoo 1012
diff --git a/net-im/jud/files/README.Gentoo b/net-im/jud/files/README.Gentoo
new file mode 100644
index 000000000000..9bb248ab55c1
--- /dev/null
+++ b/net-im/jud/files/README.Gentoo
@@ -0,0 +1,32 @@
+This is a small help to get you started with the JUD (Jabber User Directory) in
+Gentoo.
+
+You must add this to multiple.xml in the services section:
+
+<service id="jud">
+ <host>jud.localhost</host>
+ <load><jud>/usr/lib/jabberd/jud.so</jud></load>
+ <jud xmlns="jabber:config:jud">
+ <vCard>
+ <FN>Local User Directory</FN>
+ <DESC>This service provides a simple user directory service.</DESC>
+ <URL>http://jud.jabberstudio.org/</URL>
+ </vCard>
+ </jud>
+</service>
+
+
+And this to the browse section:
+
+<service type="jud" jid="jud.localhost" name="Jabber User Directory">
+ <ns>jabber:iq:search</ns>
+ <ns>jabber:iq:register</ns>
+</service>
+
+(By know you know you have to change localhost for you FQDN).
+One very importante thing: even if it is the same machine the name's for the
+various services must be diferent, that means that there must be valid aliases
+for jud.FQDN.
+
+If you need help with configuration you can try the Jabber Admin Mailling list:
+http://mailman.jabber.org/listinfo/jadmin
diff --git a/net-im/jud/files/digest-jud-0.5 b/net-im/jud/files/digest-jud-0.5
new file mode 100644
index 000000000000..7ed9ca8227ee
--- /dev/null
+++ b/net-im/jud/files/digest-jud-0.5
@@ -0,0 +1 @@
+MD5 7e59e841a3e43cce647f2dbe0f1a090d jud-0.5.tar.gz 5451
diff --git a/net-im/jud/files/jud-makefile.patch b/net-im/jud/files/jud-makefile.patch
new file mode 100644
index 000000000000..e2f7a44846c8
--- /dev/null
+++ b/net-im/jud/files/jud-makefile.patch
@@ -0,0 +1,11 @@
+--- Makefile 2003-11-12 09:12:20.000000000 +0000
++++ Makefile.new 2004-01-09 19:50:00.224467512 +0000
+@@ -1,6 +1,6 @@
+-include ../platform-settings
++include /usr/lib/jabberd/platform-settings
+
+-CFLAGS=$(CCFLAGS) -I../jabberd
++CFLAGS=$(CCFLAGS) -I/usr/include/jabberd
+
+ jud_OBJECTS=jud.o jud_reg.o jud_search.o
+
diff --git a/net-im/jud/jud-0.5.ebuild b/net-im/jud/jud-0.5.ebuild
new file mode 100644
index 000000000000..f0cd86192d15
--- /dev/null
+++ b/net-im/jud/jud-0.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/jud/jud-0.5.ebuild,v 1.1 2004/01/12 01:35:05 rizzo Exp $
+
+DESCRIPTION="Open Source Jabber User Directory"
+HOMEPAGE="http://jud.jabberstudio.org/"
+SRC_URI="http://jud.jabberstudio.org/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+SLOT="0"
+
+DEPEND=">=net-im/jabberd-1.4.3"
+S=${WORKDIR}/${PN}-ansi-c
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/jud-makefile.patch
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dodir /etc/jabber /usr/lib/jabberd
+ insinto /usr/lib/jabberd
+ doins jud.so
+ insinto /etc/jabber
+ dodoc README ${FILESDIR}/README.Gentoo
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Please read /usr/share/doc/${P}/README.Gentoo"
+ einfo
+}
diff --git a/net-im/jud/metadata.xml b/net-im/jud/metadata.xml
new file mode 100644
index 000000000000..fa4290d8cdea
--- /dev/null
+++ b/net-im/jud/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-im</herd>
+<maintainer>
+ <email>rizzo@gentoo.org</email>
+ <name>Don Seiler</name>
+ <description>Holding this until Humpback (Gustavo Felisberto) graduates from Dev U.</description>
+</maintainer>
+<!-- <longdescription>Long description of the package</longdescription> -->
+</pkgmetadata>