summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-11-13 06:59:18 +0000
committerMike Frysinger <vapier@gentoo.org>2005-11-13 06:59:18 +0000
commitc006ae6cecc906179606d7060f78dbeaded45021 (patch)
tree57503f6cda744a486cdf63230374ab8899cc658d /net-ftp
parentNew version (diff)
downloadhistorical-c006ae6cecc906179606d7060f78dbeaded45021.tar.gz
historical-c006ae6cecc906179606d7060f78dbeaded45021.tar.bz2
historical-c006ae6cecc906179606d7060f78dbeaded45021.zip
initial import
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/gtkfxp/ChangeLog8
-rw-r--r--net-ftp/gtkfxp/Manifest14
-rw-r--r--net-ftp/gtkfxp/files/digest-gtkfxp-0.51
-rw-r--r--net-ftp/gtkfxp/files/gtkfxp-0.5-build.patch17
-rw-r--r--net-ftp/gtkfxp/gtkfxp-0.5.ebuild29
5 files changed, 69 insertions, 0 deletions
diff --git a/net-ftp/gtkfxp/ChangeLog b/net-ftp/gtkfxp/ChangeLog
new file mode 100644
index 000000000000..5f017d29e3e9
--- /dev/null
+++ b/net-ftp/gtkfxp/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-ftp/gtkfxp
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/gtkfxp/ChangeLog,v 1.1 2005/11/13 06:59:18 vapier Exp $
+
+*gtkfxp-0.5 (13 Nov 2005)
+
+ 13 Nov 2005; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me.
diff --git a/net-ftp/gtkfxp/Manifest b/net-ftp/gtkfxp/Manifest
new file mode 100644
index 000000000000..238ca163360f
--- /dev/null
+++ b/net-ftp/gtkfxp/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 7adcb4b5e6987e83c9b7d14294100584 ChangeLog 323
+MD5 4883f3004485dbd9944260595b0dec30 files/digest-gtkfxp-0.5 61
+MD5 3682ebd8522dc0deb868bdf100677c7f files/gtkfxp-0.5-build.patch 527
+MD5 843ae6cca460fbccdd05970217e4bdf3 gtkfxp-0.5.ebuild 658
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDduSFgIKl8Uu19MoRAnHuAJ0ad5SKtPeQxqrAdVNC7tSi38IJFACeN0m1
+GLz8cIWI62P27Sf0hVg9gH4=
+=Rx3S
+-----END PGP SIGNATURE-----
diff --git a/net-ftp/gtkfxp/files/digest-gtkfxp-0.5 b/net-ftp/gtkfxp/files/digest-gtkfxp-0.5
new file mode 100644
index 000000000000..a063493863b0
--- /dev/null
+++ b/net-ftp/gtkfxp/files/digest-gtkfxp-0.5
@@ -0,0 +1 @@
+MD5 7a1a2b9a1149544eac248bd32161df96 gtkfxp-0.5.tar.gz 26786
diff --git a/net-ftp/gtkfxp/files/gtkfxp-0.5-build.patch b/net-ftp/gtkfxp/files/gtkfxp-0.5-build.patch
new file mode 100644
index 000000000000..ba3fd5fa1611
--- /dev/null
+++ b/net-ftp/gtkfxp/files/gtkfxp-0.5-build.patch
@@ -0,0 +1,17 @@
+--- Makefile.orig 2005-11-13 01:45:34.000000000 -0500
++++ Makefile 2005-11-13 01:46:34.000000000 -0500
+@@ -1,5 +1,5 @@
+-CC = gcc
+-CFLAGS = -O2 -g `gtk-config --cflags`
++CC ?= gcc
++CFLAGS += `gtk-config --cflags`
+ LIBS = `gtk-config --libs`
+ LIBPATH = -L/usr/X11R6/lib
+ OBJECTS = ui.o net.o misc.o widgets.o configfile.o queue.o sort.o
+@@ -26,3 +26,6 @@
+ gtkfxp: $(OBJECTS)
+ $(CC) $(CFLAGS) -o gtkfxp $(OBJECTS) $(LIBS) $(LIBPATH)
+
++install:
++ install -m 0755 -d $(DESTDIR)/usr/bin
++ install -m 0755 gtkfxp $(DESTDIR)/usr/bin
diff --git a/net-ftp/gtkfxp/gtkfxp-0.5.ebuild b/net-ftp/gtkfxp/gtkfxp-0.5.ebuild
new file mode 100644
index 000000000000..be707ecd4f99
--- /dev/null
+++ b/net-ftp/gtkfxp/gtkfxp-0.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/gtkfxp/gtkfxp-0.5.ebuild,v 1.1 2005/11/13 06:59:18 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="FXP client written in GTK"
+HOMEPAGE="http://home.swipnet.se/~w-92416/gtkfxp/"
+SRC_URI="http://home.swipnet.se/~w-92416/gtkfxp/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="=x11-libs/gtk+-1*"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc BUGS ChangeLog README TODO
+}