summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-01-29 00:39:16 +0000
committerNick Hadaway <raker@gentoo.org>2003-01-29 00:39:16 +0000
commit41890bacdc6bb55b10a0d28a6e0400a041df6b24 (patch)
tree0b4782c3a5d3a7031a4707ff52bcfc360db32fa1 /net-ftp
parentVersion bump. (diff)
downloadhistorical-41890bacdc6bb55b10a0d28a6e0400a041df6b24.tar.gz
historical-41890bacdc6bb55b10a0d28a6e0400a041df6b24.tar.bz2
historical-41890bacdc6bb55b10a0d28a6e0400a041df6b24.zip
Version bump and an init script fix
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/pure-ftpd/ChangeLog9
-rw-r--r--net-ftp/pure-ftpd/files/digest-pure-ftpd-1.0.13a1
-rw-r--r--net-ftp/pure-ftpd/files/pure-ftpd.rc6-r128
-rw-r--r--net-ftp/pure-ftpd/pure-ftpd-1.0.13a.ebuild59
4 files changed, 96 insertions, 1 deletions
diff --git a/net-ftp/pure-ftpd/ChangeLog b/net-ftp/pure-ftpd/ChangeLog
index 5393ef4fa63e..2c00e927e427 100644
--- a/net-ftp/pure-ftpd/ChangeLog
+++ b/net-ftp/pure-ftpd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-ftp/pure-ftpd
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/pure-ftpd/ChangeLog,v 1.7 2002/12/13 10:59:56 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pure-ftpd/ChangeLog,v 1.8 2003/01/29 00:39:16 raker Exp $
+
+*pure-ftpd-1.0.13a (28 Jan 2003)
+
+ 28 Jan 2003; Nick Hadaway <raker@gentoo.org> pure-ftpd-1.0.13a.ebuld,
+ files/digest-pure-ftpd-1.0.13a, files/pureftpd.rc6-r1 :
+ Version bump. And changed the init script so start-stop-daemon
+ is utilized.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/net-ftp/pure-ftpd/files/digest-pure-ftpd-1.0.13a b/net-ftp/pure-ftpd/files/digest-pure-ftpd-1.0.13a
new file mode 100644
index 000000000000..66a100ff1271
--- /dev/null
+++ b/net-ftp/pure-ftpd/files/digest-pure-ftpd-1.0.13a
@@ -0,0 +1 @@
+MD5 a728e2bd77098de957ddb458385e14b9 pure-ftpd-1.0.13a.tar.bz2 412143
diff --git a/net-ftp/pure-ftpd/files/pure-ftpd.rc6-r1 b/net-ftp/pure-ftpd/files/pure-ftpd.rc6-r1
new file mode 100644
index 000000000000..6e381cafa93e
--- /dev/null
+++ b/net-ftp/pure-ftpd/files/pure-ftpd.rc6-r1
@@ -0,0 +1,28 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pure-ftpd/files/pure-ftpd.rc6-r1,v 1.1 2003/01/29 00:39:16 raker Exp $
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if [ -z "$IS_CONFIGURED" ] ; then
+ eerror "You need to setup /etc/conf.d/pure-ftpd first"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting Pure-FTPd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/pure-ftpd -- $SERVER $MAX_CONN $MAX_CONN_IP $DAEMON $DISK_FULL $USE_NAT $AUTH $LOG $TIMEOUT $MISC_OTHER
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Pure-FTPd"
+ start-stop-daemon --stop --quiet --pidfile /var/run/pure-ftpd.pid
+ eend $?
+}
diff --git a/net-ftp/pure-ftpd/pure-ftpd-1.0.13a.ebuild b/net-ftp/pure-ftpd/pure-ftpd-1.0.13a.ebuild
new file mode 100644
index 000000000000..77314981cf7d
--- /dev/null
+++ b/net-ftp/pure-ftpd/pure-ftpd-1.0.13a.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pure-ftpd/pure-ftpd-1.0.13a.ebuild,v 1.1 2003/01/29 00:39:16 raker Exp $
+
+DESCRIPTION="Pure-FTPd is a fast, production-quality, standard-conformant FTP server"
+SRC_URI="ftp://ftp.pureftpd.org/pub/pure-ftpd/releases/${P}.tar.bz2"
+HOMEPAGE="http://www.pureftpd.org/"
+DEPEND="virtual/glibc
+ pam? ( >=sys-libs/pam-0.75 )
+ mysql? ( >=dev-db/mysql-3* )
+ postgres? ( >=dev-db/postgresql-7.2.2 )
+ ldap? ( >=net-nds/openldap-2.0.25 )"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+IUSE="pam mysql postgres ldap"
+
+src_compile() {
+ use pam && myconf="${myconf} --with-pam"
+ use ldap && myconf="${myconf} --with-ldap"
+ use mysql && myconf="${myconf} --with-mysql"
+ use postgres && myconf="${myconf} --with-pgsql"
+
+ econf --with-altlog --with-extauth \
+ --with-puredb --with-cookie \
+ --with-throttling --with-ratios \
+ --with-quotas --with-ftpwho \
+ --with-uploadscript --with-virtualhosts \
+ --with-virtualchroot --with-diraliases \
+ --with-largefile \
+ --with-peruserlimits ${myconf}
+ emake || die "compile problem"
+}
+
+src_install() {
+ einstall
+
+ dodoc AUTHORS CONTACT COPYING ChangeLog FAQ HISTORY INSTALL README* NEWS
+
+ dodir /etc/{conf.d,init.d}
+ cp ${FILESDIR}/ftpusers ${D}/etc/ftpusers
+ cp ${FILESDIR}/pure-ftpd.conf_d ${D}/etc/conf.d/pure-ftpd
+
+ use pam && insinto /etc/pam.d && doins pam/{ftplockout,pure-ftpd}
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/pure-ftpd.rc6-r1 pure-ftpd
+
+ insopts -m 644
+ insinto /etc/xinetd.d
+ newins ${FILESDIR}/pure-ftpd.xinetd pure-ftpd
+}
+
+pkg_postinst() {
+ einfo "Before starting Pure-FTPd, you have to edit the /etc/conf.d/pure-ftpd file."
+ echo
+ ewarn "It's *really* important to read the README provided with Pure-FTPd."
+ ewarn "Just point your browser at http://www.pureftpd.org/README"
+}