summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-25 23:20:48 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-25 23:20:48 +0000
commitab155b8540c5e124768620383e0bd088f59b6387 (patch)
treeca436a76eb4c3bce3bc787994d884d96ee2b70a4 /net-ftp/pure-ftpd
parentDEPEND fix for #11225 (diff)
downloadhistorical-ab155b8540c5e124768620383e0bd088f59b6387.tar.gz
historical-ab155b8540c5e124768620383e0bd088f59b6387.tar.bz2
historical-ab155b8540c5e124768620383e0bd088f59b6387.zip
added lfs support #11215
Diffstat (limited to 'net-ftp/pure-ftpd')
-rw-r--r--net-ftp/pure-ftpd/ChangeLog7
-rw-r--r--net-ftp/pure-ftpd/files/digest-pure-ftpd-1.0.12-r11
-rw-r--r--net-ftp/pure-ftpd/pure-ftpd-1.0.12-r1.ebuild64
3 files changed, 71 insertions, 1 deletions
diff --git a/net-ftp/pure-ftpd/ChangeLog b/net-ftp/pure-ftpd/ChangeLog
index b8f008d575a3..709754457d37 100644
--- a/net-ftp/pure-ftpd/ChangeLog
+++ b/net-ftp/pure-ftpd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/pure-ftpd
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/pure-ftpd/ChangeLog,v 1.4 2002/10/12 14:41:42 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pure-ftpd/ChangeLog,v 1.5 2002/11/25 23:20:48 vapier Exp $
+
+*pure-ftpd-1.0.12-r1 (25 Nov 2002)
+
+ 25 Nov 2002; Mike Frysinger <vapier@gentoo.org> :
+ Added support for lfs #11215
*pure-ftpd-1.0.12 (12 Oct 2002)
diff --git a/net-ftp/pure-ftpd/files/digest-pure-ftpd-1.0.12-r1 b/net-ftp/pure-ftpd/files/digest-pure-ftpd-1.0.12-r1
new file mode 100644
index 000000000000..93616476088b
--- /dev/null
+++ b/net-ftp/pure-ftpd/files/digest-pure-ftpd-1.0.12-r1
@@ -0,0 +1 @@
+MD5 36d2a7e96569046aa9ab5314b0846f25 pure-ftpd-1.0.12.tar.bz2 395495
diff --git a/net-ftp/pure-ftpd/pure-ftpd-1.0.12-r1.ebuild b/net-ftp/pure-ftpd/pure-ftpd-1.0.12-r1.ebuild
new file mode 100644
index 000000000000..edd4735f2ca4
--- /dev/null
+++ b/net-ftp/pure-ftpd/pure-ftpd-1.0.12-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pure-ftpd/pure-ftpd-1.0.12-r1.ebuild,v 1.1 2002/11/25 23:20:48 vapier Exp $
+
+DESCRIPTION="Pure-FTPd is a fast, production-quality, standard-conformant FTP server"
+SRC_URI="mirror://sourceforge/pureftpd/${P}.tar.bz2"
+HOMEPAGE="http://www.pureftpd.org/"
+
+DEPEND="virtual/glibc
+ pam? ( >=sys-libs/pam-0.75 )
+ mysql? ( >=dev-db/mysql-3* )
+ postgres? ( >=dev-db/postgresql-7.2.2 )
+ ldap? ( >=net-nds/openldap-2.0.25 )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
+IUSE="pam mysql postgres ldap"
+
+src_compile() {
+ use pam && myconf="${myconf} --with-pam"
+ use ldap && myconf="${myconf} --with-ldap"
+ use mysql && myconf="${myconf} --with-mysql"
+ use postgres && myconf="${myconf} --with-pgsql"
+
+ econf --with-altlog --with-extauth \
+ --with-puredb --with-cookie \
+ --with-throttling --with-ratios \
+ --with-quotas --with-ftpwho \
+ --with-uploadscript --with-virtualhosts \
+ --with-virtualchroot --with-diraliases \
+ --with-largefile \
+ --with-peruserlimits ${myconf}
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ einstall
+
+ dodoc AUTHORS CONTACT COPYING ChangeLog FAQ HISTORY INSTALL README* NEWS
+
+ dodir /etc/{conf.d,init.d}
+ cp ${FILESDIR}/ftpusers ${D}/etc/ftpusers
+ cp ${FILESDIR}/pure-ftpd.conf_d ${D}/etc/conf.d/pure-ftpd
+
+ use pam && insinto /etc/pam.d && doins pam/{ftplockout,pure-ftpd}
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/pure-ftpd.rc6 pure-ftpd
+
+ # we should always install that, so commented out the "if" -- blizzy
+# if [ -x /usr/sbin/xinetd ]; then
+ insopts -m 644
+ insinto /etc/xinetd.d
+ newins ${FILESDIR}/pure-ftpd.xinetd pure-ftpd
+# fi
+}
+
+pkg_postinst() {
+ einfo "Before starting Pure-FTPd, you have to edit the /etc/conf.d/pure-ftpd file."
+ echo
+ ewarn "It's *really* important to read the README provided with Pure-FTPd."
+ ewarn "Just point your browser at http://www.pureftpd.org/README"
+}