summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorStefaan De Roeck <stefaan@gentoo.org>2008-05-03 09:52:53 +0000
committerStefaan De Roeck <stefaan@gentoo.org>2008-05-03 09:52:53 +0000
commite46fbf80012dfbac47a7e159477b580e35151a43 (patch)
tree66ccb0d8e6bd11945a18a1b2a6b11c968c251ba9 /net-fs
parentVersion bump to 1.4.7 (diff)
downloadhistorical-e46fbf80012dfbac47a7e159477b580e35151a43.tar.gz
historical-e46fbf80012dfbac47a7e159477b580e35151a43.tar.bz2
historical-e46fbf80012dfbac47a7e159477b580e35151a43.zip
Version bump to 1.4.7 + fix bug #211378
Package-Manager: portage-2.1.5_rc6
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/openafs/ChangeLog8
-rw-r--r--net-fs/openafs/files/openafs-1.4.7-uname.patch21
-rw-r--r--net-fs/openafs/openafs-1.4.7.ebuild154
3 files changed, 182 insertions, 1 deletions
diff --git a/net-fs/openafs/ChangeLog b/net-fs/openafs/ChangeLog
index 02bb2c5f577f..2952474d9218 100644
--- a/net-fs/openafs/ChangeLog
+++ b/net-fs/openafs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-fs/openafs
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/ChangeLog,v 1.146 2008/05/01 14:41:50 stefaan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/ChangeLog,v 1.147 2008/05/03 09:52:53 stefaan Exp $
+
+*openafs-1.4.7 (03 May 2008)
+
+ 03 May 2008; Stefaan De Roeck <stefaan@gentoo.org>
+ +files/openafs-1.4.7-uname.patch, +openafs-1.4.7.ebuild:
+ Version bump to 1.4.7 + fix bug #211378
*openafs-1.4.7_pre3-r1 (01 May 2008)
diff --git a/net-fs/openafs/files/openafs-1.4.7-uname.patch b/net-fs/openafs/files/openafs-1.4.7-uname.patch
new file mode 100644
index 000000000000..7cedd843d77e
--- /dev/null
+++ b/net-fs/openafs/files/openafs-1.4.7-uname.patch
@@ -0,0 +1,21 @@
+--- acinclude.m4~ 2007-10-31 22:05:57.000000000 +0200
++++ acinclude.m4 2007-10-31 22:06:30.000000000 +0200
+@@ -473,7 +473,7 @@
+ AFS_SYSNAME="ia64_linuxXX"
+ ;;
+ powerpc-*-linux*)
+- AFS_SYSNAME="`/bin/arch`_linuxXX"
++ AFS_SYSNAME="`uname -m`_linuxXX"
+ ;;
+ powerpc64-*-linux*)
+ AFS_SYSNAME="ppc64_linuxXX"
+@@ -488,7 +488,7 @@
+ AFS_SYSNAME="s390x_linuxXX"
+ ;;
+ sparc-*-linux*)
+- AFS_SYSNAME="`/bin/arch`_linuxXX"
++ AFS_SYSNAME="`uname -m`_linuxXX"
+ ;;
+ sparc64-*-linux*)
+ AFS_SYSNAME="sparc64_linuxXX"
+
diff --git a/net-fs/openafs/openafs-1.4.7.ebuild b/net-fs/openafs/openafs-1.4.7.ebuild
new file mode 100644
index 000000000000..df4121cf15a3
--- /dev/null
+++ b/net-fs/openafs/openafs-1.4.7.ebuild
@@ -0,0 +1,154 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/openafs-1.4.7.ebuild,v 1.1 2008/05/03 09:52:53 stefaan Exp $
+
+inherit flag-o-matic eutils toolchain-funcs versionator pam
+
+PATCHVER=0.14
+DESCRIPTION="The OpenAFS distributed file system"
+HOMEPAGE="http://www.openafs.org/"
+SRC_URI="http://openafs.org/dl/${PV}/${P}-src.tar.bz2
+ doc? ( http://openafs.org/dl/${PV}/${P}-doc.tar.bz2 )
+ mirror://gentoo/${PN}-gentoo-${PATCHVER}.tar.bz2"
+
+LICENSE="IBM openafs-krb5 openafs-krb5-a APSL-2 sun-rpc"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug kerberos pam doc"
+
+RDEPEND="~net-fs/openafs-kernel-${PV}
+ pam? ( sys-libs/pam )
+ kerberos? ( virtual/krb5 )"
+
+PATCHDIR=${WORKDIR}/gentoo/patches/$(get_version_component_range 1-2)
+CONFDIR=${WORKDIR}/gentoo/configs
+SCRIPTDIR=${WORKDIR}/gentoo/scripts
+
+src_unpack() {
+ unpack ${A}; cd "${S}"
+
+ # Apply patches to apply chosen compiler settings, fix the hardcoded paths
+ # to be more FHS friendly, and the fix the incorrect typecasts for va_arg
+ EPATCH_EXCLUDE="006_all_ppc64.patch" \
+ EPATCH_SUFFIX="patch" epatch ${PATCHDIR}
+
+ # enable UCONTEXT on alpha
+ epatch "${FILESDIR}"/openafs-alpha-ucontext.patch
+ # don't use mapfiles to strip symbols (bug #202489)
+ epatch "${FILESDIR}"/openafs-1.4.5-shared-libs.patch
+ # use uname i.o. arch (bug #211378)
+ epatch "${FILESDIR}"/openafs-1.4.7-uname.patch
+
+ # disable XCFLAGS override
+ sed -i 's/^[ \t]*XCFLAGS.*/:/' src/cf/osconf.m4
+ # disable compiler choice override
+ sed -i 's/^[ \t]\+\(CC\|CCOBJ\|MT_CC\)="[^ ]*\(.*\)"/\1="${CC}\2"/' src/cf/osconf.m4
+
+ # fix autoconf cludge (bug #218234)
+ sed -i 's/^AC_\(AIX\|MINIX\)$//' acinclude.m4
+
+ ./regen.sh || die "Failed: regenerating configure script"
+}
+
+src_compile() {
+ # cannot use "use_with" macro, as --without-krb5-config crashes the econf
+ local myconf=""
+ if use kerberos; then
+ myconf="--with-krb5-conf=$(type -p krb5-config)"
+ fi
+
+ # AFS_SYSKVERS: fix linux version at 2.6
+ AFS_SYSKVERS=26 \
+ XCFLAGS="${CFLAGS}" \
+ econf \
+ $(use_enable pam) \
+ $(use_enable debug) \
+ --enable-largefile-fileserver \
+ --enable-supergroups \
+ --disable-kernel-module \
+ ${myconf} || die econf
+
+ emake -j1 all_nolibafs || die "Build failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install_nolibafs || die "Installing failed"
+
+ # pam_afs and pam_afs.krb have been installed in irregular locations, fix
+ if use pam; then
+ dopammod "${D}"/usr/$(get_libdir)/pam_afs*
+ rm -f "${D}"/usr/$(get_libdir)/pam_afs*
+ fi
+
+ # compile_et collides with com_err. Remove it from this package.
+ rm "${D}"/usr/bin/compile_et
+
+ # avoid collision with mit_krb5's version of kpasswd
+ (cd "${D}"/usr/bin; mv kpasswd kpasswd_afs)
+ use doc && (cd "${D}"/usr/share/man/man1; mv kpasswd.1 kpasswd_afs.1)
+
+ # minimal documentation
+ dodoc ${CONFDIR}/README ${CONFDIR}/CellServDB
+
+ # documentation package
+ if use doc; then
+ use pam && doman src/pam/pam_afs.5
+
+ cp -pPR doc/* "${D}"/usr/share/doc/${PF}
+ fi
+
+ # Gentoo related scripts
+ newconfd ${CONFDIR}/openafs-client openafs-client
+ newconfd ${CONFDIR}/openafs-server openafs-server
+ newinitd ${SCRIPTDIR}/openafs-client openafs-client
+ newinitd ${SCRIPTDIR}/openafs-server openafs-server
+
+ # used directories: client
+ keepdir /etc/openafs
+ keepdir /var/cache/openafs
+
+ # used directories: server
+ keepdir /etc/openafs/server
+ diropts -m0700
+ keepdir /var/lib/openafs
+ keepdir /var/lib/openafs/db
+ diropts -m0755
+ keepdir /var/lib/openafs/logs
+
+ # link logfiles to /var/log
+ dosym ../lib/openafs/logs /var/log/openafs
+}
+
+pkg_preinst() {
+ ## Somewhat intelligently install default configuration files
+ ## (when they are not present)
+ # CellServDB
+ if [ ! -e "${ROOT}"etc/openafs/CellServDB ] \
+ || grep "GCO Public CellServDB" "${ROOT}"etc/openafs/CellServDB &> /dev/null
+ then
+ cp ${CONFDIR}/CellServDB "${D}"etc/openafs
+ fi
+ # cacheinfo: use a default location cache, 200 megabyte in size
+ # (should be safe for about any root partition, the user can increase
+ # the size as required)
+ if [ ! -e "${ROOT}"etc/openafs/cacheinfo ]; then
+ echo "/afs:/var/cache/openafs:200000" > "${D}"etc/openafs/cacheinfo
+ fi
+ # ThisCell: default to "openafs.org"
+ if [ ! -e "${ROOT}"etc/openafs/ThisCell ]; then
+ echo "openafs.org" > "${D}"etc/openafs/ThisCell
+ fi
+}
+
+pkg_postinst() {
+ elog
+ elog "This installation should work out of the box (at least the"
+ elog "client part doing global afs-cell browsing, unless you had"
+ elog "a previous and different configuration). If you want to"
+ elog "set up your own cell or modify the standard config,"
+ elog "please have a look at the Gentoo OpenAFS documentation"
+ elog "(warning: it is not yet up to date wrt the new file locations)"
+ elog
+ elog "The documentation can be found at:"
+ elog " http://www.gentoo.org/doc/en/openafs.xml"
+}