summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2001-09-09 09:32:13 +0000
committerDonny Davies <woodchip@gentoo.org>2001-09-09 09:32:13 +0000
commit75d256163be5fc4a93645edebb4fb0461fd6b98a (patch)
tree0a95e950fd55d98bbd649a010c041950a02bec9d /net-fs
parentadded handy checkconfig function with the ultra handy dandy pointer to the sa... (diff)
downloadhistorical-75d256163be5fc4a93645edebb4fb0461fd6b98a.tar.gz
historical-75d256163be5fc4a93645edebb4fb0461fd6b98a.tar.bz2
historical-75d256163be5fc4a93645edebb4fb0461fd6b98a.zip
just some minor cosmetic changes the the rc6 ebuilds, mostly just to make them easier to read. a small change to the initscript.. hmm i think i already commited that change.. heh
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/samba/samba-2.0.10-r6.ebuild10
-rw-r--r--net-fs/samba/samba-2.2.1a-r6.ebuild14
2 files changed, 10 insertions, 14 deletions
diff --git a/net-fs/samba/samba-2.0.10-r6.ebuild b/net-fs/samba/samba-2.0.10-r6.ebuild
index 7f0f81c901ac..cb2c50f8a3d7 100644
--- a/net-fs/samba/samba-2.0.10-r6.ebuild
+++ b/net-fs/samba/samba-2.0.10-r6.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-2.0.10-r6.ebuild,v 1.2 2001/09/02 11:21:31 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-2.0.10-r6.ebuild,v 1.3 2001/09/09 09:32:13 woodchip Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -39,8 +39,7 @@ src_install() {
make install prefix=${D}/usr BASEDIR=${D}/usr LIBDIR=${D}/etc/smb VARDIR=${D}/var/log \
PRIVATEDIR=${D}/etc/smb/private SWATDIR=${D}/usr/share/swat \
- LOCKDIR=${D}/var/lock SBINDIR=${D}/usr/sbin
- assert
+ LOCKDIR=${D}/var/lock SBINDIR=${D}/usr/sbin || die
# we specified PRIVATEDIR=/etc/smb/private
rm -rf ${D}/usr/private
@@ -49,7 +48,7 @@ src_install() {
# move smbmount from /usr/sbin to /sbin, and rename it to mount.smbfs
# which allows it to work transparently with standard 'mount' command
- diropts -m 0755 ; dodir /sbin
+ dodir /sbin
mv ${D}/usr/bin/smbmount ${D}/sbin/mount.smbfs
cd ${S}/source/script
@@ -80,7 +79,6 @@ src_install() {
docinto textdocs
dodoc textdocs/*
- # install a standard, standalone-type init script
exeinto /etc/init.d
newexe ${FILESDIR}/samba.rc6 samba
}
@@ -93,7 +91,7 @@ pkg_preinst() {
/etc/init.d/samba stop
fi
fi
- return 0
+ return # dont fail
}
diff --git a/net-fs/samba/samba-2.2.1a-r6.ebuild b/net-fs/samba/samba-2.2.1a-r6.ebuild
index 85ea43e8fd3f..02092f4f91f2 100644
--- a/net-fs/samba/samba-2.2.1a-r6.ebuild
+++ b/net-fs/samba/samba-2.2.1a-r6.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-2.2.1a-r6.ebuild,v 1.3 2001/09/02 11:21:31 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-2.2.1a-r6.ebuild,v 1.4 2001/09/09 09:32:13 woodchip Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Samba :)"
@@ -80,8 +80,7 @@ src_install() {
make install prefix=${D}/usr BASEDIR=${D}/usr PRIVATEDIR=${D}/etc/smb/private \
LIBDIR=${D}/etc/smb VARDIR=${D}/var/log SWATDIR=${D}/usr/share/swat \
- LOCKDIR=${D}/var/lock SBINDIR=${D}/usr/sbin MANDIR=${D}/usr/share/man
- assert
+ LOCKDIR=${D}/var/lock SBINDIR=${D}/usr/sbin MANDIR=${D}/usr/share/man || die
# we specified PRIVATEDIR=/etc/smb/private
rm -rf ${D}/usr/private
@@ -90,7 +89,7 @@ src_install() {
# move smbmount from /usr/sbin to /sbin, and rename it to mount.smbfs
# which allows it to work transparently with standard 'mount' command
- diropts -m 0755 ; dodir /sbin
+ dodir /sbin
mv ${D}/usr/bin/smbmount ${D}/sbin/mount.smbfs
cd ${S}/source/script
@@ -100,7 +99,7 @@ src_install() {
# docs. samba has some really good ones.
cd ${S}
cp -a examples ${D}/usr/doc/${PF}
- insinto /etc/smb ; insopts -m 0644 ; newins examples/smb.conf.default smb.conf.eg
+ insinto /etc/smb ; newins examples/smb.conf.default smb.conf.example
insinto /usr/share/sgml/docbook/dbsgml ; doins docs/docbook/dbsgml/*
insinto /usr/share/sgml/docbook/dbsgml/ent ; doins docs/docbook/dbsgml/ent/*
dodoc COPYING Manifest README Roadmap WHATSNEW.txt
@@ -120,8 +119,7 @@ src_install() {
docinto sgml/docbook/manpages ; dodoc docbook/manpages/*.sgml
docinto sgml/docbook/projdoc ; dodoc docbook/projdoc/*.sgml
- # install a standard, standalone-type init script
- exeinto /etc/init.d ; exeopts -m 0755
+ exeinto /etc/init.d
newexe ${FILESDIR}/samba.rc6 samba
}
@@ -133,7 +131,7 @@ pkg_preinst() {
/etc/init.d/samba stop
fi
fi
- return 0
+ return # dont fail
}