summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorChristian Andreetta <satya@gentoo.org>2004-07-24 09:33:08 +0000
committerChristian Andreetta <satya@gentoo.org>2004-07-24 09:33:08 +0000
commit5d7bc25c10ad67ec0b6c6755d800e5ebbe7cbb01 (patch)
tree1fa2e2b5381ca6ff82ce06f0785f0c15e6b65bbb /net-fs
parentInitial import. (diff)
downloadhistorical-5d7bc25c10ad67ec0b6c6755d800e5ebbe7cbb01.tar.gz
historical-5d7bc25c10ad67ec0b6c6755d800e5ebbe7cbb01.tar.bz2
historical-5d7bc25c10ad67ec0b6c6755d800e5ebbe7cbb01.zip
cosmetical minor ebuild script checks reorganization
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/samba/ChangeLog5
-rw-r--r--net-fs/samba/Manifest4
-rw-r--r--net-fs/samba/samba-3.0.5-r1.ebuild52
3 files changed, 22 insertions, 39 deletions
diff --git a/net-fs/samba/ChangeLog b/net-fs/samba/ChangeLog
index 41b8f8e223b0..23fd524c7e7d 100644
--- a/net-fs/samba/ChangeLog
+++ b/net-fs/samba/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-fs/samba
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.91 2004/07/23 17:53:14 satya Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.92 2004/07/24 09:33:08 satya Exp $
+
+ 24 Jul 2004; Christian Andreetta <satya@gentoo.org> samba-3.0.5-r1.ebuild:
+ cosmetical minor changes in ebuild internal checks
*samba-3.0.5-r1 (23 Jul 2004)
diff --git a/net-fs/samba/Manifest b/net-fs/samba/Manifest
index ddb6acf4cdce..fc7f54334993 100644
--- a/net-fs/samba/Manifest
+++ b/net-fs/samba/Manifest
@@ -1,8 +1,8 @@
MD5 7d7c900829bc2bdf39895d5890a0d20d samba-3.0.4-r1.ebuild 11146
-MD5 d01a684f8594579cef050f9f646c3654 samba-3.0.5-r1.ebuild 14128
+MD5 ddc3a6e52ce455acf84e655d971d4126 samba-3.0.5-r1.ebuild 13401
MD5 633511d04d7a7d7702c17089c85ba697 samba-3.0.1-r1.ebuild 11333
MD5 df4f73693b725799675e37ba3f90643f samba-3.0.2a-r2.ebuild 12249
-MD5 e7d852e970baa7b5bcb441a7ae1821c9 ChangeLog 17957
+MD5 1f6759e6bd5dd097b18845fa5b267f43 ChangeLog 18088
MD5 41299f246433a1a55c8fccc77ccd709e metadata.xml 491
MD5 4d7587136bbd68c1ccd4df12e4325492 samba-3.0.5.ebuild 11141
MD5 ccc96fcdc7493be42da52364061c6c17 files/winbind-init 484
diff --git a/net-fs/samba/samba-3.0.5-r1.ebuild b/net-fs/samba/samba-3.0.5-r1.ebuild
index 0eccc230a7d0..5cb4b9bae552 100644
--- a/net-fs/samba/samba-3.0.5-r1.ebuild
+++ b/net-fs/samba/samba-3.0.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.0.5-r1.ebuild,v 1.1 2004/07/23 17:53:14 satya Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.0.5-r1.ebuild,v 1.2 2004/07/24 09:33:08 satya Exp $
inherit eutils flag-o-matic
@@ -63,20 +63,13 @@ src_unpack() {
#Next one is from eger@cc.gatech.edu
epatch ${FILESDIR}/samba-3.0.x-python-setup.patch || die
#bug #44743 ------------------------------------------------------------
- for tmp_arch in "ppc" "ppc64" "~ppc" "~ppc64"; do
- if [ "${ARCH}" = "${tmp_arch}" ]; then
- cd ${S} && epatch ${FILESDIR}/samba-3.0.x-smbumount-uid32.patch
- break
- fi
- done
+ if [ ${ARCH} = "ppc" -o ${ARCH} = "ppc64" ]; then
+ cd ${S} && epatch ${FILESDIR}/samba-3.0.x-smbumount-uid32.patch
+ fi
#Fix for bug #27858 ----------------------------------------------------
- for tmp_arch in "sparc" "~sparc" "ppc" "ppc64" "~ppc" "~ppc64"; do
- if [ "${ARCH}" = "${tmp_arch}" ]; then
- cd ${S}/source/include
- epatch ${FILESDIR}/samba-2.2.8-statfs.patch
- break
- fi
- done
+ if [ ${ARCH} = "sparc" -o ${ARCH} = "ppc" -o ${ARCH} = "ppc64" ]; then
+ cd ${S}/source/include && epatch ${FILESDIR}/samba-2.2.8-statfs.patch
+ fi
#Bug #36200; sys-kernel/linux-headers dependent ------------------------
sed -i -e 's:#define LINUX_QUOTAS_2:#define LINUX_QUOTAS_1:' \
-e 's:<linux/quota.h>:<sys/quota.h>:' \
@@ -124,14 +117,14 @@ src_compile() {
&& myconf="${myconf} --with-readline" \
|| myconf="${myconf} --without-readline"
#Fix #57063 ------------------------------------------------------------
+ # too cautious for some archs: maybe -O2 is sufficient on some of them
strip-flags
- replace-flags -O? -O1
- for tmp_arch in "ppc" "ppc64" "~ppc" "~ppc64"; do
- if [ "${ARCH}" = "${tmp_arch}" ]; then
- replace-flags -O? -O1
- break
- fi
- done
+ if [ "${ARCH}" = "ppc" -o "${ARCH}" = "ppc64" ]; then
+ replace-flags -O? -O1
+ else
+ replace-flags -O? -O1
+ fi
+ #-----------------------------------------------------------------------
if [ "${ARCH}" != "amd64" ]; then
use kerberos && use ldap \
&& myconf="${myconf} --with-ads" \
@@ -204,7 +197,7 @@ src_compile() {
emake #${VSCAN_MODS}
fi
# Build mkntpasswd from the smbldap-tools ------------------------------
- # Attention: use of dev-perl/Crypt-SmbHash for smbldap-tool > 0.8.5
+ # Attention: usage of dev-perl/Crypt-SmbHash for smbldap-tool > 0.8.5
if use ldap; then
cd ${WORKDIR}/smbldap-tools-${SMBLDAP_TOOLS_VER}
if [ -f mkntpwd.tar.gz]; then
@@ -338,9 +331,6 @@ src_install() {
chown -R root:root ${D}/usr/share/doc/${PF}
# moving manpages ------------------------------------------------------
mv ${D}/usr/man ${D}/usr/share/man
- # moving libs ----------------------------------------------------------
- #dodir ${D}/usr/lib/samba
- #mv ${D}/usr/lib/vfs ${D}/usr/lib/samba
}
pkg_postinst() {
@@ -348,17 +338,6 @@ pkg_postinst() {
# to mount smb shares don't get annoying warnings all the time..
#[ ! -e ${ROOT}/etc/samba/smb.conf ] && touch ${ROOT}/etc/samba/smb.conf
- ### empty dirs..
- ##install -m0700 -o root -g root -d ${ROOT}/etc/samba/private
- ##install -m1777 -o root -g root -d ${ROOT}/var/spool/samba
- ##install -m0755 -o root -g root -d ${ROOT}/var/log/samba
- ##install -m0755 -o root -g root -d ${ROOT}/var/log/samba3
- ##install -m0755 -o root -g root -d ${ROOT}/var/run/samba
- ##install -m0755 -o root -g root -d ${ROOT}/var/cache/samba
- ##install -m0755 -o root -g root -d ${ROOT}/var/lib/samba/{netlogon,profiles}
- ##install -m0755 -o root -g root -d \
- ## ${ROOT}/var/lib/samba/printers/{W32X86,WIN40,W32ALPHA,W32MIPS,W32PPC}
-
ewarn ""
ewarn "If you are upgrading from a Samba version prior to 3.0.2, and you"
ewarn "use Samba's password database, you must run the following command:"
@@ -379,3 +358,4 @@ pkg_postinst() {
einfo ""
fi
}
+