summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-03-06 09:18:46 +0000
committerMike Frysinger <vapier@gentoo.org>2009-03-06 09:18:46 +0000
commit0327be87caefd7173e3ef3a86cafa33c27dfe327 (patch)
tree96f32c84f9feb55b039d93f2d36f335b1203895c /net-fs
parentDisambiguate the parameters to call only parts of src_* functions (diff)
downloadhistorical-0327be87caefd7173e3ef3a86cafa33c27dfe327.tar.gz
historical-0327be87caefd7173e3ef3a86cafa33c27dfe327.tar.bz2
historical-0327be87caefd7173e3ef3a86cafa33c27dfe327.zip
old
Diffstat (limited to 'net-fs')
-rwxr-xr-xnet-fs/nfs-utils/files/nfs266
-rw-r--r--net-fs/nfs-utils/files/nfs-utils-1.0.12-mountd-memleak.patch22
-rw-r--r--net-fs/nfs-utils/files/nfs.confd.old27
-rw-r--r--net-fs/nfs-utils/files/nfsmount42
-rw-r--r--net-fs/nfs-utils/nfs-utils-1.0.12-r1.ebuild104
-rw-r--r--net-fs/nfs-utils/nfs-utils-1.0.12-r5.ebuild109
-rw-r--r--net-fs/nfs-utils/nfs-utils-1.1.0-r1.ebuild111
-rw-r--r--net-fs/nfs-utils/nfs-utils-1.1.1-r1.ebuild114
-rw-r--r--net-fs/nfs-utils/nfs-utils-1.1.1.ebuild114
9 files changed, 0 insertions, 909 deletions
diff --git a/net-fs/nfs-utils/files/nfs b/net-fs/nfs-utils/files/nfs
deleted file mode 100755
index 1c37706bf7bc..000000000000
--- a/net-fs/nfs-utils/files/nfs
+++ /dev/null
@@ -1,266 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/files/nfs,v 1.14 2007/03/24 10:14:43 vapier Exp $
-
-#---------------------------------------------------------------------------
-# This script starts/stops the following
-# rpc.statd if necessary (also checked by init.d/nfsmount)
-# rpc.rquotad if exists (from quota package)
-# rpc.nfsd
-# rpc.mountd
-#---------------------------------------------------------------------------
-
-# NB: Config is in /etc/conf.d/nfs
-
-opts="reload"
-
-# This variable is used for controlling whether or not to run exportfs -ua;
-# see stop() for more information
-restarting=no
-
-# The binary locations
-exportfs=/usr/sbin/exportfs
- gssd=/usr/sbin/rpc.gssd
- idmapd=/usr/sbin/rpc.idmapd
- mountd=/usr/sbin/rpc.mountd
- nfsd=/usr/sbin/rpc.nfsd
- rquotad=/usr/sbin/rpc.rquotad
- statd=/sbin/rpc.statd
- svcgssd=/usr/sbin/rpc.svcgssd
-
-depend() {
- use ypbind net
- need portmap
- after quota
-}
-
-mkdir_nfsdirs() {
- local d
- for d in /var/lib/nfs/{rpc_pipefs,v4recovery,v4root} ; do
- [[ ! -d ${d} ]] && mkdir -p "${d}"
- done
-}
-
-mount_pipefs() {
- if grep -q rpc_pipefs /proc/filesystems ; then
- if ! grep -q "rpc_pipefs /var/lib/nfs/rpc_pipefs" /proc/mounts ; then
- ebegin "Mounting RPC pipefs"
- mount -t rpc_pipefs rpc_pipefs /var/lib/nfs/rpc_pipefs
- eend $?
- fi
- fi
-}
-
-umount_pipefs() {
- if [[ ${restarting} == "no" ]] ; then
- if grep -q "rpc_pipefs /var/lib/nfs/rpc_pipefs" /proc/mounts ; then
- ebegin "Unmounting RPC pipefs"
- umount /var/lib/nfs/rpc_pipefs
- eend $?
- fi
- fi
-}
-
-start_gssd() {
- [[ ! -x ${gssd} || ! -x ${svcgssd} ]] && return 0
- local ret1 ret2
-
- ebegin "Starting gssd"
- ${gssd} ${RPCGSSDDOPTS}
- ret1=$?
- eend ${ret1}
-
- ebegin "Starting svcgssd"
- ${svcgssd} ${RPCSVCGSSDDOPTS}
- ret2=$?
- eend ${ret2}
-
- return $((${ret1} + ${ret2}))
-}
-
-stop_gssd() {
- [[ ! -x ${gssd} || ! -x ${svcgssd} ]] && return 0
- local ret
-
- ebegin "Stopping gssd"
- start-stop-daemon --stop --quiet --exec ${gssd}
- ret1=$?
- eend ${ret1}
-
- ebegin "Stopping svcgssd"
- start-stop-daemon --stop --quiet --exec ${svcgssd}
- ret2=$?
- eend ${ret2}
-
- return $((${ret1} + ${ret2}))
-}
-
-start_idmapd() {
- [[ ! -x ${idmapd} ]] && return 0
-
- ebegin "Starting idmapd"
- ${idmapd} ${RPCIDMAPDOPTS}
- eend $?
-}
-
-stop_idmapd() {
- [[ ! -x ${idmapd} ]] && return 0
- local ret
-
- ebegin "Stopping idmapd"
- start-stop-daemon --stop --quiet --exec ${idmapd}
- ret=$?
- eend ${ret}
-
- umount_pipefs
-
- return ${ret}
-}
-
-start_statd() {
- # Don't start rpc.statd if already started by init.d/nfsmount
- killall -0 rpc.statd &>/dev/null && return 0
- ebegin "Starting NFS statd"
- start-stop-daemon --start --quiet --exec \
- $statd -- $RPCSTATDOPTS 1>&2
- eend $? "Error starting NFS statd"
-}
-
-stop_statd() {
- # Don't stop rpc.statd if it's in use by init.d/nfsmount.
- mount -t nfs | grep -q . && return 0
- # Make sure it's actually running
- killall -0 rpc.statd &>/dev/null || return 0
- # Okay, all tests passed, stop rpc.statd
- ebegin "Stopping NFS statd"
- start-stop-daemon --stop --quiet --exec $statd 1>&2
- eend $? "Error stopping NFS statd"
-}
-
-waitfor_exportfs() {
- local pid=$1
- ( sleep ${EXPORTFSTIMEOUT:-30}; kill -9 $pid &>/dev/null ) &
- wait $1
-}
-
-start() {
- # Make sure nfs support is loaded in the kernel #64709
- if [[ -e /proc/modules ]] && ! grep -qs nfsd /proc/filesystems ; then
- modprobe nfsd &> /dev/null
- fi
-
- # This is the new "kernel 2.6 way" to handle the exports file
- if grep -qs nfsd /proc/filesystems ; then
- if ! grep -qs "^nfsd[[:space:]]/proc/fs/nfsd[[:space:]]" /proc/mounts ; then
- ebegin "Mounting nfsd filesystem in /proc"
- mount -t nfsd nfsd /proc/fs/nfsd
- eend $? "Error mounting nfsd filesystem in /proc"
- fi
- fi
- # now that nfsd is mounted inside /proc, we can safely start mountd later
-
- mkdir_nfsdirs
-
- mount_pipefs
- start_idmapd
- start_gssd
- start_statd
-
- # Exportfs likes to hang if networking isn't working.
- # If that's the case, then try to kill it so the
- # bootup process can continue.
- if grep -q '^/' /etc/exports &>/dev/null; then
- ebegin "Exporting NFS directories"
- $exportfs -r 1>&2 &
- waitfor_exportfs $!
- eend $? "Error exporting NFS directories"
- fi
-
- if [ -x $rquotad ]; then
- ebegin "Starting NFS rquotad"
- start-stop-daemon --start --quiet --exec \
- $rquotad -- $RPCRQUOTADOPTS 1>&2
- eend $? "Error starting NFS rquotad"
- fi
-
- ebegin "Starting NFS daemon"
- start-stop-daemon --start --quiet --exec \
- $nfsd --name nfsd -- $RPCNFSDCOUNT 1>&2
- eend $? "Error starting NFS daemon"
-
- # Start mountd
- ebegin "Starting NFS mountd"
- start-stop-daemon --start --quiet --exec \
- $mountd -- $RPCMOUNTDOPTS 1>&2
- eend $? "Error starting NFS mountd"
-}
-
-stop() {
- # Don't check NFSSERVER variable since it might have changed,
- # instead use --oknodo to smooth things over
- ebegin "Stopping NFS mountd"
- start-stop-daemon --stop --quiet --oknodo \
- --exec $mountd 1>&2
- eend $? "Error stopping NFS mountd"
-
- # nfsd sets its process name to [nfsd] so don't look for $nfsd
- ebegin "Stopping NFS daemon"
- start-stop-daemon --stop --quiet --oknodo \
- --name nfsd --user root --signal 2 1>&2
- eend $? "Error stopping NFS daemon"
-
- if [ -x $rquotad ]; then
- ebegin "Stopping NFS rquotad"
- start-stop-daemon --stop --quiet --oknodo \
- --exec $rquotad 1>&2
- eend $? "Error stopping NFS rquotad"
- fi
-
- # When restarting the NFS server, running "exportfs -ua" probably
- # isn't what the user wants. Running it causes all entries listed
- # in xtab to be removed from the kernel export tables, and the
- # xtab file is cleared. This effectively shuts down all NFS
- # activity, leaving all clients holding stale NFS filehandles,
- # *even* when the NFS server has restarted.
- #
- # That's what you would want if you were shutting down the NFS
- # server for good, or for a long period of time, but not when the
- # NFS server will be running again in short order. In this case,
- # then "exportfs -r" will reread the xtab, and all the current
- # clients will be able to resume NFS activity, *without* needing
- # to umount/(re)mount the filesystem.
- if [ "$restarting" = no ]; then
- ebegin "Unexporting NFS directories"
- # Exportfs likes to hang if networking isn't working.
- # If that's the case, then try to kill it so the
- # shutdown process can continue.
- $exportfs -ua 1>&2 &
- waitfor_exportfs $!
- eend $? "Error unexporting NFS directories"
- fi
-
- stop_statd
- stop_gssd
- stop_idmapd
- umount_pipefs
-
- return 0
-}
-
-reload() {
- # Exportfs likes to hang if networking isn't working.
- # If that's the case, then try to kill it so the
- # bootup process can continue.
- ebegin "Reloading /etc/exports"
- $exportfs -r 1>&2 &
- waitfor_exportfs $!
- eend $? "Error exporting NFS directories"
-}
-
-restart() {
- # See long comment in stop() regarding "restarting" and exportfs -ua
- restarting=yes
- svc_stop
- svc_start
-}
diff --git a/net-fs/nfs-utils/files/nfs-utils-1.0.12-mountd-memleak.patch b/net-fs/nfs-utils/files/nfs-utils-1.0.12-mountd-memleak.patch
deleted file mode 100644
index 5a750a893ac0..000000000000
--- a/net-fs/nfs-utils/files/nfs-utils-1.0.12-mountd-memleak.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-http://bugs.gentoo.org/172014
-
-From: Steinar H. Gunderson <sgunderson@bigfoot.com>
-Date: Fri, 16 Mar 2007 00:26:35 +0000 (+1100)
-Subject: Fix memory leak in mountd.
-X-Git-Url: http://linux-nfs.org/cgi-bin/gitweb.cgi?p=nfs-utils;a=commitdiff;h=08964495c2a65f6228426e4565a50dae5b75834d
-
-Fix memory leak in mountd.
-
-Signed-off-by: Neil Brown <neilb@suse.de>
----
-
---- a/support/export/client.c
-+++ b/support/export/client.c
-@@ -329,6 +329,7 @@ add_name(char *old, char *add)
- strcat(new, ",");
- strcat(new, cp);
- }
-+ free(old);
- return new;
- }
-
diff --git a/net-fs/nfs-utils/files/nfs.confd.old b/net-fs/nfs-utils/files/nfs.confd.old
deleted file mode 100644
index 2d26adc46f94..000000000000
--- a/net-fs/nfs-utils/files/nfs.confd.old
+++ /dev/null
@@ -1,27 +0,0 @@
-# /etc/conf.d/nfs
-
-# If you wish to set the port numbers for lockd,
-# please see /etc/sysctl.conf
-
-# Number of servers to be started up by default
-RPCNFSDCOUNT=8
-
-# Options to pass to rpc.mountd
-# ex. RPCMOUNTDOPTS="-p 32767
-RPCMOUNTDOPTS=""
-
-# Options to pass to rpc.statd
-# ex. RPCSTATDOPTS="-p 32765 -o 32766"
-RPCSTATDOPTS=""
-
-# Options to pass to rpc.idmapd
-RPCIDMAPDOPTS=""
-
-# Options to pass to rpc.gssd
-RPCGSSDOPTS=""
-
-# Options to pass to rpc.svcgssd
-RPCSVCGSSDOPTS=""
-
-# Timeout (in seconds) for exportfs
-EXPORTFSTIMEOUT=30
diff --git a/net-fs/nfs-utils/files/nfsmount b/net-fs/nfs-utils/files/nfsmount
deleted file mode 100644
index fe039528e01e..000000000000
--- a/net-fs/nfs-utils/files/nfsmount
+++ /dev/null
@@ -1,42 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/files/nfsmount,v 1.7 2006/06/28 03:28:58 vapier Exp $
-
-depend() {
- need net portmap
- use ypbind
-}
-
-start_statd() {
- # Don't start rpc.statd if already started by init.d/nfs
- killall -0 rpc.statd &>/dev/null && return 0
- ebegin "Starting NFS statd"
- start-stop-daemon --start --quiet --exec /sbin/rpc.statd 1>&2
- eend $? "Error starting NFS statd"
-}
-
-stop_statd() {
- # Don't stop rpc.statd if it's in use by init.d/nfs
- killall -0 nfsd &>/dev/null && return 0
- # Make sure it's actually running
- killall -0 rpc.statd &>/dev/null || return 0
- # Okay, all tests passed, stop rpc.statd
- ebegin "Stopping NFS statd"
- start-stop-daemon --stop --quiet --exec /sbin/rpc.statd 1>&2
- eend $? "Error stopping NFS statd"
-}
-
-start() {
- start_statd
- ebegin "Mounting NFS filesystems"
- mount -a -t nfs
- eend $? "Error mounting NFS filesystems"
-}
-
-stop() {
- ebegin "Unmounting NFS filesystems"
- umount -a -t nfs
- eend $? "Error unmounting NFS filesystems"
- stop_statd
-}
diff --git a/net-fs/nfs-utils/nfs-utils-1.0.12-r1.ebuild b/net-fs/nfs-utils/nfs-utils-1.0.12-r1.ebuild
deleted file mode 100644
index b784463a0443..000000000000
--- a/net-fs/nfs-utils/nfs-utils-1.0.12-r1.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-1.0.12-r1.ebuild,v 1.6 2007/09/15 02:12:59 vapier Exp $
-
-inherit eutils flag-o-matic multilib
-
-DESCRIPTION="NFS client and server daemons"
-HOMEPAGE="http://nfs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/nfs/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
-IUSE="nonfsv4 tcpd kerberos"
-
-# kth-krb doesn't provide the right include
-# files, and nfs-utils doesn't build against heimdal either,
-# so don't depend on virtual/krb.
-# (04 Feb 2005 agriffis)
-RDEPEND="tcpd? ( sys-apps/tcp-wrappers )
- >=net-nds/portmap-5b-r6
- !nonfsv4? (
- >=dev-libs/libevent-1.0b
- >=net-libs/libnfsidmap-0.16
- )
- kerberos? (
- net-libs/librpcsecgss
- net-libs/libgssglue
- app-crypt/mit-krb5
- )"
-DEPEND="${RDEPEND}"
-
-src_unpack() {
- unpack ${P}.tar.gz
- cd "${S}"
- sed -i \
- -e 's:libgssapi >= 0\.9:libgssglue >= 0.1:' \
- -e 's:-lgssapi:-lgssglue:' \
- configure #191746
- #epatch "${DISTDIR}"/nfs-utils-${PV}-CITI_NFS4_ALL-1.dif
-}
-
-src_compile() {
- econf \
- --mandir=/usr/share/man \
- --with-statedir=/var/lib/nfs \
- --disable-rquotad \
- --enable-nfsv3 \
- --enable-secure-statd \
- $(use_with tcpd tcp-wrappers) \
- $(use_enable !nonfsv4 nfsv4) \
- $(use_enable kerberos gss) \
- || die "Configure failed"
-
- emake || die "Failed to compile"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- # Don't overwrite existing xtab/etab, install the original
- # versions somewhere safe... more info in pkg_postinst
- dodir /usr/lib/nfs
- keepdir /var/lib/nfs/{sm,sm.bak}
- mv "${D}"/var/lib/nfs/* "${D}"/usr/lib/nfs
- keepdir /var/lib/nfs
-
- # Install some client-side binaries in /sbin
- dodir /sbin
- mv "${D}"/usr/sbin/rpc.{lockd,statd} "${D}"/sbin/
-
- dodoc ChangeLog README
- docinto linux-nfs ; dodoc linux-nfs/*
-
- insinto /etc
- doins "${FILESDIR}"/exports
- use !nonfsv4 && doins utils/idmapd/idmapd.conf
-
- doinitd "${FILESDIR}"/nfs "${FILESDIR}"/nfsmount
- newconfd "${FILESDIR}"/nfs.confd.old nfs
-
- # uClibc doesn't provide rpcgen like glibc, so lets steal it from nfs-utils
- if ! use elibc_glibc ; then
- dobin tools/rpcgen/rpcgen || die "rpcgen"
- newdoc tools/rpcgen/README README.rpcgen
- fi
-}
-
-pkg_preinst() {
- [[ -s ${ROOT}/etc/exports ]] && rm -f "${D}"/etc/exports
-}
-
-pkg_postinst() {
- # Install default xtab and friends if there's none existing.
- # In src_install we put them in /usr/lib/nfs for safe-keeping, but
- # the daemons actually use the files in /var/lib/nfs. This fixes
- # bug 30486
- local f
- for f in "${ROOT}"/usr/$(get_libdir)/nfs/*; do
- [[ -e ${ROOT}/var/lib/nfs/${f##*/} ]] && continue
- einfo "Copying default ${f##*/} from /usr/$(get_libdir)/nfs to /var/lib/nfs"
- cp -pPR "${f}" "${ROOT}"/var/lib/nfs/
- done
-}
diff --git a/net-fs/nfs-utils/nfs-utils-1.0.12-r5.ebuild b/net-fs/nfs-utils/nfs-utils-1.0.12-r5.ebuild
deleted file mode 100644
index f955e864771b..000000000000
--- a/net-fs/nfs-utils/nfs-utils-1.0.12-r5.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-1.0.12-r5.ebuild,v 1.3 2008/10/26 09:02:47 vapier Exp $
-
-inherit eutils flag-o-matic multilib
-
-DESCRIPTION="NFS client and server daemons"
-HOMEPAGE="http://nfs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/nfs/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="nonfsv4 tcpd kerberos"
-
-# kth-krb doesn't provide the right include
-# files, and nfs-utils doesn't build against heimdal either,
-# so don't depend on virtual/krb.
-# (04 Feb 2005 agriffis)
-DEPEND="tcpd? ( sys-apps/tcp-wrappers )
- >=net-nds/portmap-5b-r6
- !nonfsv4? (
- >=dev-libs/libevent-1.0b
- >=net-libs/libnfsidmap-0.16
- )
- kerberos? (
- net-libs/librpcsecgss
- net-libs/libgssglue
- app-crypt/mit-krb5
- )"
-
-src_unpack() {
- unpack ${P}.tar.gz
- cd "${S}"
- epatch "${FILESDIR}"/${P}-mountd-memleak.patch #172014
- sed -i \
- -e 's:libgssapi >= 0\.9:libgssglue >= 0.1:' \
- -e 's:-lgssapi:-lgssglue:' \
- configure #191746
- #epatch "${DISTDIR}"/nfs-utils-${PV}-CITI_NFS4_ALL-1.dif
-}
-
-src_compile() {
- econf \
- --mandir=/usr/share/man \
- --with-statedir=/var/lib/nfs \
- --disable-rquotad \
- --enable-nfsv3 \
- --enable-secure-statd \
- $(use_with tcpd tcp-wrappers) \
- $(use_enable !nonfsv4 nfsv4) \
- $(use_enable kerberos gss) \
- || die "Configure failed"
-
- emake || die "Failed to compile"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- # Don't overwrite existing xtab/etab, install the original
- # versions somewhere safe... more info in pkg_postinst
- dodir /usr/lib/nfs
- keepdir /var/lib/nfs/{sm,sm.bak}
- mv "${D}"/var/lib/nfs/* "${D}"/usr/lib/nfs
- keepdir /var/lib/nfs
-
- # Install some client-side binaries in /sbin
- dodir /sbin
- mv "${D}"/usr/sbin/rpc.{lockd,statd} "${D}"/sbin/ || die
-
- dodoc ChangeLog README
- docinto linux-nfs ; dodoc linux-nfs/*
-
- insinto /etc
- doins "${FILESDIR}"/exports
-
- local f list=""
- use !nonfsv4 && list="${list} rpc.idmapd rpc.pipefs"
- use kerberos && list="${list} rpc.gssd rpc.svcgssd"
- for f in nfs nfsmount rpc.statd ${list} ; do
- newinitd "${FILESDIR}"/${f}.initd ${f} || die "doinitd ${f}"
- done
- newconfd "${FILESDIR}"/nfs.confd nfs
- use !nonfsv4 && doins utils/idmapd/idmapd.conf
-
- # uClibc doesn't provide rpcgen like glibc, so lets steal it from nfs-utils
- if ! use elibc_glibc ; then
- dobin tools/rpcgen/rpcgen || die "rpcgen"
- newdoc tools/rpcgen/README README.rpcgen
- fi
-}
-
-pkg_preinst() {
- [[ -s ${ROOT}/etc/exports ]] && rm -f "${D}"/etc/exports
-}
-
-pkg_postinst() {
- # Install default xtab and friends if there's none existing.
- # In src_install we put them in /usr/lib/nfs for safe-keeping, but
- # the daemons actually use the files in /var/lib/nfs. This fixes
- # bug 30486
- local f
- for f in "${ROOT}"/usr/$(get_libdir)/nfs/*; do
- [[ -e ${ROOT}/var/lib/nfs/${f##*/} ]] && continue
- einfo "Copying default ${f##*/} from /usr/$(get_libdir)/nfs to /var/lib/nfs"
- cp -pPR "${f}" "${ROOT}"/var/lib/nfs/
- done
-}
diff --git a/net-fs/nfs-utils/nfs-utils-1.1.0-r1.ebuild b/net-fs/nfs-utils/nfs-utils-1.1.0-r1.ebuild
deleted file mode 100644
index 619a00aa8d08..000000000000
--- a/net-fs/nfs-utils/nfs-utils-1.1.0-r1.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-1.1.0-r1.ebuild,v 1.10 2008/10/26 09:02:47 vapier Exp $
-
-inherit eutils flag-o-matic multilib
-
-DESCRIPTION="NFS client and server daemons"
-HOMEPAGE="http://nfs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/nfs/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="nonfsv4 tcpd kerberos"
-
-# kth-krb doesn't provide the right include
-# files, and nfs-utils doesn't build against heimdal either,
-# so don't depend on virtual/krb.
-# (04 Feb 2005 agriffis)
-RDEPEND="tcpd? ( sys-apps/tcp-wrappers )
- >=net-nds/portmap-5b-r6
- !nonfsv4? (
- >=dev-libs/libevent-1.0b
- >=net-libs/libnfsidmap-0.16
- )
- kerberos? (
- net-libs/librpcsecgss
- net-libs/libgssglue
- app-crypt/mit-krb5
- )"
-# util-linux dep is to prevent man-page collision
-DEPEND="${RDEPEND}
- >=sys-apps/util-linux-2.12r-r7"
-
-src_unpack() {
- unpack ${P}.tar.gz
- cd "${S}"
- sed -i \
- -e 's:libgssapi >= 0\.11:libgssglue >= 0.1:' \
- -e 's:-lgssapi:-lgssglue:' \
- configure #191746
- #epatch "${DISTDIR}"/nfs-utils-${PV}-CITI_NFS4_ALL-1.dif
-}
-
-src_compile() {
- econf \
- --mandir=/usr/share/man \
- --with-statedir=/var/lib/nfs \
- --disable-rquotad \
- --enable-nfsv3 \
- --enable-secure-statd \
- $(use_with tcpd tcp-wrappers) \
- $(use_enable !nonfsv4 nfsv4) \
- $(use_enable kerberos gss) \
- || die "Configure failed"
-
- emake || die "Failed to compile"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- # Don't overwrite existing xtab/etab, install the original
- # versions somewhere safe... more info in pkg_postinst
- dodir /usr/lib/nfs
- keepdir /var/lib/nfs/{sm,sm.bak}
- mv "${D}"/var/lib/nfs/* "${D}"/usr/lib/nfs
- keepdir /var/lib/nfs
-
- # Install some client-side binaries in /sbin
- dodir /sbin
- mv "${D}"/usr/sbin/rpc.statd "${D}"/sbin/ || die
-
- dodoc ChangeLog README
- docinto linux-nfs ; dodoc linux-nfs/*
-
- insinto /etc
- doins "${FILESDIR}"/exports
-
- local f list=""
- use !nonfsv4 && list="${list} rpc.idmapd rpc.pipefs"
- use kerberos && list="${list} rpc.gssd rpc.svcgssd"
- for f in nfs nfsmount rpc.statd ${list} ; do
- newinitd "${FILESDIR}"/${f}.initd ${f} || die "doinitd ${f}"
- done
- newconfd "${FILESDIR}"/nfs.confd nfs
- use !nonfsv4 && doins utils/idmapd/idmapd.conf
-
- # uClibc doesn't provide rpcgen like glibc, so lets steal it from nfs-utils
- if ! use elibc_glibc ; then
- dobin tools/rpcgen/rpcgen || die "rpcgen"
- newdoc tools/rpcgen/README README.rpcgen
- fi
-}
-
-pkg_preinst() {
- [[ -s ${ROOT}/etc/exports ]] && rm -f "${D}"/etc/exports
-}
-
-pkg_postinst() {
- # Install default xtab and friends if there's none existing.
- # In src_install we put them in /usr/lib/nfs for safe-keeping, but
- # the daemons actually use the files in /var/lib/nfs. This fixes
- # bug 30486
- local f
- for f in "${ROOT}"/usr/$(get_libdir)/nfs/*; do
- [[ -e ${ROOT}/var/lib/nfs/${f##*/} ]] && continue
- einfo "Copying default ${f##*/} from /usr/$(get_libdir)/nfs to /var/lib/nfs"
- cp -pPR "${f}" "${ROOT}"/var/lib/nfs/
- done
-}
diff --git a/net-fs/nfs-utils/nfs-utils-1.1.1-r1.ebuild b/net-fs/nfs-utils/nfs-utils-1.1.1-r1.ebuild
deleted file mode 100644
index f73114c5d96a..000000000000
--- a/net-fs/nfs-utils/nfs-utils-1.1.1-r1.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-1.1.1-r1.ebuild,v 1.2 2008/10/26 09:02:47 vapier Exp $
-
-inherit eutils flag-o-matic multilib
-
-DESCRIPTION="NFS client and server daemons"
-HOMEPAGE="http://nfs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/nfs/${P}.tar.gz
- http://www.citi.umich.edu/projects/nfsv4/linux/nfs-utils-patches/1.1.1-1/nfs-utils-1.1.1-001-xlog_segfault_fix.dif
- http://www.citi.umich.edu/projects/nfsv4/linux/nfs-utils-patches/1.1.1-1/nfs-utils-1.1.1-002-svcgssd_pass_down_principal_name.dif"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="nonfsv4 tcpd kerberos"
-
-# kth-krb doesn't provide the right include
-# files, and nfs-utils doesn't build against heimdal either,
-# so don't depend on virtual/krb.
-# (04 Feb 2005 agriffis)
-RDEPEND="tcpd? ( sys-apps/tcp-wrappers )
- >=net-nds/portmap-5b-r6
- !nonfsv4? (
- >=dev-libs/libevent-1.0b
- >=net-libs/libnfsidmap-0.16
- kerberos? (
- net-libs/librpcsecgss
- net-libs/libgssglue
- app-crypt/mit-krb5
- )
- )"
-# util-linux dep is to prevent man-page collision
-DEPEND="${RDEPEND}
- >=sys-apps/util-linux-2.12r-r7"
-
-src_unpack() {
- unpack ${P}.tar.gz
- cd "${S}"
- epatch "${DISTDIR}"/nfs-utils-1.1.1-001-xlog_segfault_fix.dif "${DISTDIR}"/nfs-utils-1.1.1-002-svcgssd_pass_down_principal_name.dif
- sed -i \
- -e 's:libgssapi >= 0\.11:libgssglue >= 0.1:' \
- -e 's:-lgssapi:-lgssglue:' \
- configure #191746
-}
-
-src_compile() {
- econf \
- --mandir=/usr/share/man \
- --with-statedir=/var/lib/nfs \
- --disable-rquotad \
- --enable-nfsv3 \
- --enable-secure-statd \
- $(use_with tcpd tcp-wrappers) \
- $(use_enable !nonfsv4 nfsv4) \
- $(use !nonfsv4 && use_enable kerberos gss) \
- || die "Configure failed"
- emake || die "Failed to compile"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- # Don't overwrite existing xtab/etab, install the original
- # versions somewhere safe... more info in pkg_postinst
- dodir /usr/lib/nfs
- keepdir /var/lib/nfs/{sm,sm.bak}
- mv "${D}"/var/lib/nfs/* "${D}"/usr/lib/nfs
- keepdir /var/lib/nfs
-
- # Install some client-side binaries in /sbin
- dodir /sbin
- mv "${D}"/usr/sbin/rpc.statd "${D}"/sbin/ || die
-
- dodoc ChangeLog README
- docinto linux-nfs ; dodoc linux-nfs/*
-
- insinto /etc
- doins "${FILESDIR}"/exports
-
- local f list=""
- if use !nonfsv4 ; then
- list="${list} rpc.idmapd rpc.pipefs"
- use kerberos && list="${list} rpc.gssd rpc.svcgssd"
- fi
- for f in nfs nfsmount rpc.statd ${list} ; do
- newinitd "${FILESDIR}"/${f}.initd ${f} || die "doinitd ${f}"
- done
- newconfd "${FILESDIR}"/nfs.confd nfs
- use !nonfsv4 && doins utils/idmapd/idmapd.conf
-
- # uClibc doesn't provide rpcgen like glibc, so lets steal it from nfs-utils
- if ! use elibc_glibc ; then
- dobin tools/rpcgen/rpcgen || die "rpcgen"
- newdoc tools/rpcgen/README README.rpcgen
- fi
-}
-
-pkg_preinst() {
- [[ -s ${ROOT}/etc/exports ]] && rm -f "${D}"/etc/exports
-}
-
-pkg_postinst() {
- # Install default xtab and friends if there's none existing.
- # In src_install we put them in /usr/lib/nfs for safe-keeping, but
- # the daemons actually use the files in /var/lib/nfs. This fixes
- # bug 30486
- local f
- for f in "${ROOT}"/usr/$(get_libdir)/nfs/*; do
- [[ -e ${ROOT}/var/lib/nfs/${f##*/} ]] && continue
- einfo "Copying default ${f##*/} from /usr/$(get_libdir)/nfs to /var/lib/nfs"
- cp -pPR "${f}" "${ROOT}"/var/lib/nfs/
- done
-}
diff --git a/net-fs/nfs-utils/nfs-utils-1.1.1.ebuild b/net-fs/nfs-utils/nfs-utils-1.1.1.ebuild
deleted file mode 100644
index 92c536ec487d..000000000000
--- a/net-fs/nfs-utils/nfs-utils-1.1.1.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-1.1.1.ebuild,v 1.4 2008/10/26 09:02:47 vapier Exp $
-
-inherit eutils flag-o-matic multilib
-
-DESCRIPTION="NFS client and server daemons"
-HOMEPAGE="http://nfs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/nfs/${P}.tar.gz
- http://www.citi.umich.edu/projects/nfsv4/linux/nfs-utils-patches/1.1.1-1/nfs-utils-1.1.1-001-xlog_segfault_fix.dif
- http://www.citi.umich.edu/projects/nfsv4/linux/nfs-utils-patches/1.1.1-1/nfs-utils-1.1.1-002-svcgssd_pass_down_principal_name.dif"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="nonfsv4 tcpd kerberos"
-
-# kth-krb doesn't provide the right include
-# files, and nfs-utils doesn't build against heimdal either,
-# so don't depend on virtual/krb.
-# (04 Feb 2005 agriffis)
-RDEPEND="tcpd? ( sys-apps/tcp-wrappers )
- >=net-nds/portmap-5b-r6
- !nonfsv4? (
- >=dev-libs/libevent-1.0b
- >=net-libs/libnfsidmap-0.16
- kerberos? (
- net-libs/librpcsecgss
- net-libs/libgssglue
- app-crypt/mit-krb5
- )
- )"
-# util-linux dep is to prevent man-page collision
-DEPEND="${RDEPEND}
- >=sys-apps/util-linux-2.12r-r7"
-
-src_unpack() {
- unpack ${P}.tar.gz
- cd "${S}"
- epatch "${DISTDIR}"/nfs-utils-1.1.1-001-xlog_segfault_fix.dif "${DISTDIR}"/nfs-utils-1.1.1-002-svcgssd_pass_down_principal_name.dif
- sed -i \
- -e 's:libgssapi >= 0\.11:libgssglue >= 0.1:' \
- -e 's:-lgssapi:-lgssglue:' \
- configure #191746
-}
-
-src_compile() {
- econf \
- --mandir=/usr/share/man \
- --with-statedir=/var/lib/nfs \
- --disable-rquotad \
- --enable-nfsv3 \
- --enable-secure-statd \
- $(use_with tcpd tcp-wrappers) \
- $(use_enable !nonfsv4 nfsv4) \
- $(use !nonfsv4 && use_enable kerberos gss) \
- || die "Configure failed"
- emake || die "Failed to compile"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- # Don't overwrite existing xtab/etab, install the original
- # versions somewhere safe... more info in pkg_postinst
- dodir /usr/lib/nfs
- keepdir /var/lib/nfs/{sm,sm.bak}
- mv "${D}"/var/lib/nfs/* "${D}"/usr/lib/nfs
- keepdir /var/lib/nfs
-
- # Install some client-side binaries in /sbin
- dodir /sbin
- mv "${D}"/usr/sbin/rpc.statd "${D}"/sbin/ || die
-
- dodoc ChangeLog README
- docinto linux-nfs ; dodoc linux-nfs/*
-
- insinto /etc
- doins "${FILESDIR}"/exports
-
- local f list=""
- if use !nonfsv4 ; then
- list="${list} rpc.idmapd rpc.pipefs"
- use kerberos && list="${list} rpc.gssd rpc.svcgssd"
- fi
- for f in nfs nfsmount rpc.statd ${list} ; do
- newinitd "${FILESDIR}"/${f}.initd ${f} || die "doinitd ${f}"
- done
- newconfd "${FILESDIR}"/nfs.confd nfs
- use !nonfsv4 && doins utils/idmapd/idmapd.conf
-
- # uClibc doesn't provide rpcgen like glibc, so lets steal it from nfs-utils
- if ! use elibc_glibc ; then
- dobin tools/rpcgen/rpcgen || die "rpcgen"
- newdoc tools/rpcgen/README README.rpcgen
- fi
-}
-
-pkg_preinst() {
- [[ -s ${ROOT}/etc/exports ]] && rm -f "${D}"/etc/exports
-}
-
-pkg_postinst() {
- # Install default xtab and friends if there's none existing.
- # In src_install we put them in /usr/lib/nfs for safe-keeping, but
- # the daemons actually use the files in /var/lib/nfs. This fixes
- # bug 30486
- local f
- for f in "${ROOT}"/usr/$(get_libdir)/nfs/*; do
- [[ -e ${ROOT}/var/lib/nfs/${f##*/} ]] && continue
- einfo "Copying default ${f##*/} from /usr/$(get_libdir)/nfs to /var/lib/nfs"
- cp -pPR "${f}" "${ROOT}"/var/lib/nfs/
- done
-}