summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-01-08 02:07:12 +0000
committerMike Frysinger <vapier@gentoo.org>2011-01-08 02:07:12 +0000
commit70a86cfb57620343047ede46f7cfd5816c9ff894 (patch)
tree768c519105bdc9a30403ef0bd712a5a9111f537f /net-fs/openafs
parentMarking pslib-0.4.1-r2 ppc for bug 349659 (diff)
downloadhistorical-70a86cfb57620343047ede46f7cfd5816c9ff894.tar.gz
historical-70a86cfb57620343047ede46f7cfd5816c9ff894.tar.bz2
historical-70a86cfb57620343047ede46f7cfd5816c9ff894.zip
old
Diffstat (limited to 'net-fs/openafs')
-rw-r--r--net-fs/openafs/files/openafs-dprintf.patch132
-rw-r--r--net-fs/openafs/openafs-1.4.10.ebuild151
-rw-r--r--net-fs/openafs/openafs-1.4.11.ebuild149
-rw-r--r--net-fs/openafs/openafs-1.4.12.1-r1.ebuild140
-rw-r--r--net-fs/openafs/openafs-1.4.12.1.ebuild140
5 files changed, 0 insertions, 712 deletions
diff --git a/net-fs/openafs/files/openafs-dprintf.patch b/net-fs/openafs/files/openafs-dprintf.patch
deleted file mode 100644
index eed241cb5119..000000000000
--- a/net-fs/openafs/files/openafs-dprintf.patch
+++ /dev/null
@@ -1,132 +0,0 @@
-pple-Mail-1--66779474
-Content-Transfer-Encoding: 7bit
-Content-Type: text/plain;
- charset=US-ASCII;
- delsp=yes;
- format=flowed
-
-
-On 20 Apr 2009, at 12:12, Axel Thimm wrote:
-
-> Hi,
->
-> current Fedora rawhide (to become F11) has the following components:
->
-> glibc-2.9.90-19
-> gcc-4.4.0-0.34
-> kernel-2.6.29.1-100.fc11
->
-> The build (1.4.10 and 1.4.8) fails with
->
-> gcc -pipe -O2 -I/builddir/openafs-1.4.10/src/config -I. -I. -I/
-> builddir/openafs-1.4.10/include -I/builddir/openafs-1.4.10/include/
-> afs -I/builddir/openafs-1.4.10/include/rx -I/builddir/
-> openafs-1.4.10 -I/builddir/openafs-1.4.10/src -I/builddir/
-> openafs-1.4.10/src -g -O2 -D_LARGEFILE64_SOURCE -c admin_tools.c
-> In file included from admin_tools.c:30:
-> /usr/include/stdio.h:399:66: error: macro "dprintf" passed 3
-> arguments, but takes just 2
-> admin_tools.c: In function 'MyBeforeProc':
-> admin_tools.c:1470: warning: passing argument 2 of 'ktc_GetToken'
-> from incompatible pointer type
-> /builddir/openafs-1.4.10/include/afs/auth.h:36: note: expected
-> 'struct ktc_token *' but argument is of type 'struct ktc_principal *'
-
-Could you try the attached (untested) patch...
-
-In future, Bcc-ing openafs-bugs (I've just done so) with these kinds
-of reports helps us track them, and their patches, better.
-
-Thanks,
-
-Simon.
-
---Apple-Mail-1--66779474
-Content-Transfer-Encoding: 7bit
-Content-Type: application/octet-stream;
- x-unix-mode=0644;
- name=afs_dprintf
-Content-Disposition: attachment;
- filename=afs_dprintf
-
-Index: stable/openafs/src/bucoord/bc.p.h
-===================================================================
---- stable.orig/openafs/src/bucoord/bc.p.h 2009-03-23 12:39:24.000000000 +0000
-+++ stable/openafs/src/bucoord/bc.p.h 2009-04-20 13:55:19.000000000 +0100
-@@ -144,4 +144,4 @@
- #define BC_MAXSIMDUMPS 64
- #define BC_MAXPORTS 128 /* max number of port offsets for volrestore */
- /* debugging support */
--#define dprintf(x)
-+#define afs_dprintf(x)
-Index: stable/openafs/src/bucoord/ubik_db_if.c
-===================================================================
---- stable.orig/openafs/src/bucoord/ubik_db_if.c 2009-03-23 12:49:14.000000000 +0000
-+++ stable/openafs/src/bucoord/ubik_db_if.c 2009-04-20 13:55:43.000000000 +0100
-@@ -601,7 +601,7 @@
-
- fileSize = (afs_int32) filesize(ctPtr->textStream);
-
-- dprintf(("filesize is %d\n", fileSize));
-+ afs_dprintf(("filesize is %d\n", fileSize));
-
- rewind(ctPtr->textStream);
-
-@@ -1390,7 +1390,7 @@
- ERROR(errno);
- #endif
-
-- dprintf(("file is %s\n", tmpFileName));
-+ afs_dprintf(("file is %s\n", tmpFileName));
-
- normal_exit:
- return code;
-Index: stable/openafs/src/config/debug.h
-===================================================================
---- stable.orig/openafs/src/config/debug.h 2003-07-16 00:14:55.000000000 +0100
-+++ stable/openafs/src/config/debug.h 2009-04-20 13:56:31.000000000 +0100
-@@ -112,21 +112,21 @@
-
- #if defined(AFS_DEBUG)
- #if defined(lint)
--#define dprintf(flag, str) printf str
-+#define afs_dprintf(flag, str) printf str
- #define dlprintf(flag, level, str) printf str
- #define dmprintf(flag, bit, str) printf str
- #else /* lint */
--#define dprintf(flag, str) \
-+#define afs_dprintf(flag, str) \
- (void)((flag) ? \
- ( osi_dp str, osi_dp("\t%s, %d\n", __FILE__, __LINE__)):0)
--#define dlprintf(flag, level, str) dprintf(((flag) >= (level)), str)
--#define dmprintf(flag, bit, str) dprintf(((flag)&(1<<((bit)-1))), str)
-+#define dlprintf(flag, level, str) afs_dprintf(((flag) >= (level)), str)
-+#define dmprintf(flag, bit, str) afs_dprintf(((flag)&(1<<((bit)-1))), str)
-
- #endif /* lint */
-
- #else /* AFS_DEBUG */
-
--#define dprintf(flag, str)
-+#define afs_dprintf(flag, str)
- #define dlprintf(flag, level,str)
- #define dmprintf(flag, bit, str)
-
-Index: stable/openafs/src/sgistuff/rcmd.c
-===================================================================
---- stable.orig/openafs/src/sgistuff/rcmd.c 2005-08-16 19:00:44.000000000 +0100
-+++ stable/openafs/src/sgistuff/rcmd.c 2009-04-20 13:57:54.000000000 +0100
-@@ -55,8 +55,8 @@
- #endif /* defined(AFS_HPUX_ENV) */
- #ifdef TCP_DEBUG
- #include <sys/syslog.h>
--# define DPRINTF(args) dprintf args
--dprintf(args)
-+# define DPRINTF(args) afs_dprintf args
-+afs_dprintf(args)
- char *args;
- {
- char **argv;
-
---Apple-Mail-1--66779474--
-
diff --git a/net-fs/openafs/openafs-1.4.10.ebuild b/net-fs/openafs/openafs-1.4.10.ebuild
deleted file mode 100644
index 19898606aefb..000000000000
--- a/net-fs/openafs/openafs-1.4.10.ebuild
+++ /dev/null
@@ -1,151 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/openafs-1.4.10.ebuild,v 1.3 2010/06/23 18:22:05 halcy0n Exp $
-
-inherit flag-o-matic eutils toolchain-funcs versionator pam
-
-PATCHVER=0.15
-DESCRIPTION="The OpenAFS distributed file system"
-HOMEPAGE="http://www.openafs.org/"
-SRC_URI="http://openafs.org/dl/${PV}/${P}-src.tar.bz2
- doc? ( http://openafs.org/dl/${PV}/${P}-doc.tar.bz2 )
- mirror://gentoo/${PN}-gentoo-${PATCHVER}.tar.bz2"
-
-LICENSE="IBM BSD openafs-krb5-a APSL-2 sun-rpc"
-SLOT="0"
-KEYWORDS="~amd64 ~sparc ~x86"
-IUSE="debug kerberos pam doc"
-
-RDEPEND="~net-fs/openafs-kernel-${PV}
- pam? ( sys-libs/pam )
- kerberos? ( virtual/krb5 )"
-
-PATCHDIR=${WORKDIR}/gentoo/patches/$(get_version_component_range 1-2)
-CONFDIR=${WORKDIR}/gentoo/configs
-SCRIPTDIR=${WORKDIR}/gentoo/scripts
-
-src_unpack() {
- unpack ${A}; cd "${S}"
-
- # Apply patches to apply chosen compiler settings, fix the hardcoded paths
- # to be more FHS friendly, and the fix the incorrect typecasts for va_arg
- EPATCH_SUFFIX="patch" \
- EPATCH_EXCLUDE="012_all_kbuild.patch" \
- epatch ${PATCHDIR}
-
- epatch "${FILESDIR}"/openafs-dprintf.patch
-
- # disable XCFLAGS override
- sed -i 's/^[ \t]*XCFLAGS.*/:/' src/cf/osconf.m4
- # disable compiler choice override
- sed -i 's/^[ \t]\+\(CC\|CCOBJ\|MT_CC\)="[^ ]*\(.*\)"/\1="${CC}\2"/' src/cf/osconf.m4
-
- # fix autoconf cludge (bug #218234)
- sed -i 's/^AC_\(AIX\|MINIX\)$//' acinclude.m4
-
- ./regen.sh || die "Failed: regenerating configure script"
-}
-
-src_compile() {
- # cannot use "use_with" macro, as --without-krb5-config crashes the econf
- local myconf=""
- if use kerberos; then
- myconf="--with-krb5-conf=$(type -p krb5-config)"
- fi
-
- # AFS_SYSKVERS: fix linux version at 2.6
- AFS_SYSKVERS=26 \
- XCFLAGS="${CFLAGS}" \
- econf \
- $(use_enable pam) \
- $(use_enable debug) \
- --enable-largefile-fileserver \
- --enable-supergroups \
- --disable-kernel-module \
- --disable-strip-binaries \
- ${myconf} || die econf
-
- emake -j1 all_nolibafs || die "Build failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install_nolibafs || die "Installing failed"
-
- # pam_afs and pam_afs.krb have been installed in irregular locations, fix
- if use pam; then
- dopammod "${D}"/usr/$(get_libdir)/pam_afs*
- rm -f "${D}"/usr/$(get_libdir)/pam_afs*
- fi
-
- # compile_et collides with com_err. Remove it from this package.
- rm "${D}"/usr/bin/compile_et
-
- # avoid collision with mit_krb5's version of kpasswd
- (cd "${D}"/usr/bin; mv kpasswd kpasswd_afs)
- use doc && (cd "${D}"/usr/share/man/man1; mv kpasswd.1 kpasswd_afs.1)
-
- # minimal documentation
- dodoc ${CONFDIR}/README ${CONFDIR}/CellServDB
-
- # documentation package
- if use doc; then
- use pam && doman src/pam/pam_afs.5
-
- cp -pPR doc/* "${D}"/usr/share/doc/${PF}
- fi
-
- # Gentoo related scripts
- newconfd ${CONFDIR}/openafs-client openafs-client
- newconfd ${CONFDIR}/openafs-server openafs-server
- newinitd ${SCRIPTDIR}/openafs-client openafs-client
- newinitd ${SCRIPTDIR}/openafs-server openafs-server
-
- # used directories: client
- keepdir /etc/openafs
- keepdir /var/cache/openafs
-
- # used directories: server
- keepdir /etc/openafs/server
- diropts -m0700
- keepdir /var/lib/openafs
- keepdir /var/lib/openafs/db
- diropts -m0755
- keepdir /var/lib/openafs/logs
-
- # link logfiles to /var/log
- dosym ../lib/openafs/logs /var/log/openafs
-}
-
-pkg_preinst() {
- ## Somewhat intelligently install default configuration files
- ## (when they are not present)
- # CellServDB
- if [ ! -e "${ROOT}"etc/openafs/CellServDB ] \
- || grep "GCO Public CellServDB" "${ROOT}"etc/openafs/CellServDB &> /dev/null
- then
- cp ${CONFDIR}/CellServDB "${D}"etc/openafs
- fi
- # cacheinfo: use a default location cache, 200 megabyte in size
- # (should be safe for about any root partition, the user can increase
- # the size as required)
- if [ ! -e "${ROOT}"etc/openafs/cacheinfo ]; then
- echo "/afs:/var/cache/openafs:200000" > "${D}"etc/openafs/cacheinfo
- fi
- # ThisCell: default to "openafs.org"
- if [ ! -e "${ROOT}"etc/openafs/ThisCell ]; then
- echo "openafs.org" > "${D}"etc/openafs/ThisCell
- fi
-}
-
-pkg_postinst() {
- elog
- elog "This installation should work out of the box (at least the"
- elog "client part doing global afs-cell browsing, unless you had"
- elog "a previous and different configuration). If you want to"
- elog "set up your own cell or modify the standard config,"
- elog "please have a look at the Gentoo OpenAFS documentation"
- elog "(warning: it is not yet up to date wrt the new file locations)"
- elog
- elog "The documentation can be found at:"
- elog " http://www.gentoo.org/doc/en/openafs.xml"
-}
diff --git a/net-fs/openafs/openafs-1.4.11.ebuild b/net-fs/openafs/openafs-1.4.11.ebuild
deleted file mode 100644
index 74a25c2767f9..000000000000
--- a/net-fs/openafs/openafs-1.4.11.ebuild
+++ /dev/null
@@ -1,149 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/openafs-1.4.11.ebuild,v 1.3 2010/06/23 18:22:05 halcy0n Exp $
-
-inherit flag-o-matic eutils toolchain-funcs versionator pam
-
-PATCHVER=0.15
-DESCRIPTION="The OpenAFS distributed file system"
-HOMEPAGE="http://www.openafs.org/"
-SRC_URI="http://openafs.org/dl/${PV}/${P}-src.tar.bz2
- doc? ( http://openafs.org/dl/${PV}/${P}-doc.tar.bz2 )
- mirror://gentoo/${PN}-gentoo-${PATCHVER}.tar.bz2"
-
-LICENSE="IBM BSD openafs-krb5-a APSL-2 sun-rpc"
-SLOT="0"
-KEYWORDS="~amd64 ~sparc ~x86"
-IUSE="debug kerberos pam doc"
-
-RDEPEND="~net-fs/openafs-kernel-${PV}
- pam? ( sys-libs/pam )
- kerberos? ( virtual/krb5 )"
-
-PATCHDIR=${WORKDIR}/gentoo/patches/$(get_version_component_range 1-2)
-CONFDIR=${WORKDIR}/gentoo/configs
-SCRIPTDIR=${WORKDIR}/gentoo/scripts
-
-src_unpack() {
- unpack ${A}; cd "${S}"
-
- # Apply patches to apply chosen compiler settings, fix the hardcoded paths
- # to be more FHS friendly, and the fix the incorrect typecasts for va_arg
- EPATCH_SUFFIX="patch" \
- EPATCH_EXCLUDE="012_all_kbuild.patch" \
- epatch ${PATCHDIR}
-
- # disable XCFLAGS override
- sed -i 's/^[ \t]*XCFLAGS.*/:/' src/cf/osconf.m4
- # disable compiler choice override
- sed -i 's/^[ \t]\+\(CC\|CCOBJ\|MT_CC\)="[^ ]*\(.*\)"/\1="${CC}\2"/' src/cf/osconf.m4
-
- # fix autoconf cludge (bug #218234)
- sed -i 's/^AC_\(AIX\|MINIX\)$//' acinclude.m4
-
- ./regen.sh || die "Failed: regenerating configure script"
-}
-
-src_compile() {
- # cannot use "use_with" macro, as --without-krb5-config crashes the econf
- local myconf=""
- if use kerberos; then
- myconf="--with-krb5-conf=$(type -p krb5-config)"
- fi
-
- # AFS_SYSKVERS: fix linux version at 2.6
- AFS_SYSKVERS=26 \
- XCFLAGS="${CFLAGS}" \
- econf \
- $(use_enable pam) \
- $(use_enable debug) \
- --enable-largefile-fileserver \
- --enable-supergroups \
- --disable-kernel-module \
- --disable-strip-binaries \
- ${myconf} || die econf
-
- emake -j1 all_nolibafs || die "Build failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install_nolibafs || die "Installing failed"
-
- # pam_afs and pam_afs.krb have been installed in irregular locations, fix
- if use pam; then
- dopammod "${D}"/usr/$(get_libdir)/pam_afs*
- rm -f "${D}"/usr/$(get_libdir)/pam_afs*
- fi
-
- # compile_et collides with com_err. Remove it from this package.
- rm "${D}"/usr/bin/compile_et
-
- # avoid collision with mit_krb5's version of kpasswd
- (cd "${D}"/usr/bin; mv kpasswd kpasswd_afs)
- use doc && (cd "${D}"/usr/share/man/man1; mv kpasswd.1 kpasswd_afs.1)
-
- # minimal documentation
- dodoc ${CONFDIR}/README ${CONFDIR}/CellServDB
-
- # documentation package
- if use doc; then
- use pam && doman src/pam/pam_afs.5
-
- cp -pPR doc/* "${D}"/usr/share/doc/${PF}
- fi
-
- # Gentoo related scripts
- newconfd ${CONFDIR}/openafs-client openafs-client
- newconfd ${CONFDIR}/openafs-server openafs-server
- newinitd ${SCRIPTDIR}/openafs-client openafs-client
- newinitd ${SCRIPTDIR}/openafs-server openafs-server
-
- # used directories: client
- keepdir /etc/openafs
- keepdir /var/cache/openafs
-
- # used directories: server
- keepdir /etc/openafs/server
- diropts -m0700
- keepdir /var/lib/openafs
- keepdir /var/lib/openafs/db
- diropts -m0755
- keepdir /var/lib/openafs/logs
-
- # link logfiles to /var/log
- dosym ../lib/openafs/logs /var/log/openafs
-}
-
-pkg_preinst() {
- ## Somewhat intelligently install default configuration files
- ## (when they are not present)
- # CellServDB
- if [ ! -e "${ROOT}"etc/openafs/CellServDB ] \
- || grep "GCO Public CellServDB" "${ROOT}"etc/openafs/CellServDB &> /dev/null
- then
- cp ${CONFDIR}/CellServDB "${D}"etc/openafs
- fi
- # cacheinfo: use a default location cache, 200 megabyte in size
- # (should be safe for about any root partition, the user can increase
- # the size as required)
- if [ ! -e "${ROOT}"etc/openafs/cacheinfo ]; then
- echo "/afs:/var/cache/openafs:200000" > "${D}"etc/openafs/cacheinfo
- fi
- # ThisCell: default to "openafs.org"
- if [ ! -e "${ROOT}"etc/openafs/ThisCell ]; then
- echo "openafs.org" > "${D}"etc/openafs/ThisCell
- fi
-}
-
-pkg_postinst() {
- elog
- elog "This installation should work out of the box (at least the"
- elog "client part doing global afs-cell browsing, unless you had"
- elog "a previous and different configuration). If you want to"
- elog "set up your own cell or modify the standard config,"
- elog "please have a look at the Gentoo OpenAFS documentation"
- elog "(warning: it is not yet up to date wrt the new file locations)"
- elog
- elog "The documentation can be found at:"
- elog " http://www.gentoo.org/doc/en/openafs.xml"
-}
diff --git a/net-fs/openafs/openafs-1.4.12.1-r1.ebuild b/net-fs/openafs/openafs-1.4.12.1-r1.ebuild
deleted file mode 100644
index 6ba5f83574cc..000000000000
--- a/net-fs/openafs/openafs-1.4.12.1-r1.ebuild
+++ /dev/null
@@ -1,140 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/openafs-1.4.12.1-r1.ebuild,v 1.1 2010/08/21 22:10:34 vapier Exp $
-
-EAPI="2"
-
-inherit flag-o-matic eutils autotools toolchain-funcs versionator pam
-
-MY_PV=$(get_version_component_range 1-3)
-PVER="2"
-DESCRIPTION="The OpenAFS distributed file system"
-HOMEPAGE="http://www.openafs.org/"
-# We always d/l the doc tarball as man pages are not USE=doc material
-SRC_URI="http://openafs.org/dl/${MY_PV}/${P}-src.tar.bz2
- http://openafs.org/dl/${MY_PV}/${P}-doc.tar.bz2
- mirror://gentoo/${P}-patches-${PVER}.tar.bz2"
-
-LICENSE="IBM BSD openafs-krb5-a APSL-2 sun-rpc"
-SLOT="0"
-KEYWORDS="~amd64 ~sparc ~x86"
-IUSE="doc kerberos pam"
-
-RDEPEND="~net-fs/openafs-kernel-${PV}
- pam? ( sys-libs/pam )
- kerberos? ( virtual/krb5 )"
-
-src_prepare() {
- EPATCH_EXCLUDE="012_all_kbuild.patch" \
- EPATCH_SUFFIX="patch" \
- epatch "${WORKDIR}"/gentoo/patches
-
- # packaging is f-ed up, so we can't run automake (i.e. eautoreconf)
- sed -i '/^a/s:^:e:' regen.sh
- skipman=1
- . regen.sh
-
- # don't install local copy of lwp #200674
- sed -i '/^install:/s|:.*|:|' src/lwp/Makefile.in
-}
-
-src_configure() {
- # cannot use "use_with" macro, as --without-krb5-config crashes the econf
- local myconf=""
- if use kerberos; then
- myconf="--with-krb5-conf=$(type -p krb5-config)"
- fi
-
- AFS_SYSKVERS=26 \
- XCFLAGS="${CFLAGS}" \
- econf \
- $(use_enable pam) \
- --enable-largefile-fileserver \
- --enable-supergroups \
- --disable-kernel-module \
- --disable-strip-binaries \
- ${myconf}
-}
-
-src_compile() {
- emake -j1 all_nolibafs || die
-}
-
-src_install() {
- local CONFDIR=${WORKDIR}/gentoo/configs
- local SCRIPTDIR=${WORKDIR}/gentoo/scripts
-
- emake -j1 DESTDIR="${D}" install_nolibafs || die
-
- insinto /etc/openafs
- doins src/afsd/CellServDB || die
- echo "/afs:/var/cache/openafs:200000" > "${D}"/etc/openafs/cacheinfo
- echo "openafs.org" > "${D}"/etc/openafs/ThisCell
-
- # pam_afs and pam_afs.krb have been installed in irregular locations, fix
- if use pam ; then
- dopammod "${D}"/usr/$(get_libdir)/pam_afs* || die
- fi
- rm -f "${D}"/usr/$(get_libdir)/pam_afs* || die
-
- # remove kdump stuff provided by kexec-tools #222455
- rm -rf "${D}"/usr/sbin/kdump*
-
- # avoid collision with mit_krb5's version of kpasswd
- mv "${D}"/usr/bin/kpasswd{,_afs} || die
- mv "${D}"/usr/share/man/man1/kpasswd{,_afs}.1 || die
-
- # minimal documentation
- use pam && doman src/pam/pam_afs.5
- dodoc "${CONFDIR}"/README src/afsd/CellServDB
-
- # documentation package
- if use doc ; then
- dodoc doc/{arch,examples,pdf,protocol,txt}/*
- dohtml -A xml -r doc/{html,xml}/*
- fi
-
- # Gentoo related scripts
- newinitd "${SCRIPTDIR}"/openafs-client openafs-client || die
- newconfd "${CONFDIR}"/openafs-client openafs-client || die
- newinitd "${SCRIPTDIR}"/openafs-server openafs-server || die
- newconfd "${CONFDIR}"/openafs-server openafs-server || die
-
- # used directories: client
- keepdir /etc/openafs
- keepdir /var/cache/openafs
-
- # used directories: server
- keepdir /etc/openafs/server
- diropts -m0700
- keepdir /var/lib/openafs
- keepdir /var/lib/openafs/db
- diropts -m0755
- keepdir /var/lib/openafs/logs
-
- # link logfiles to /var/log
- dosym ../lib/openafs/logs /var/log/openafs
-}
-
-pkg_preinst() {
- ## Somewhat intelligently install default configuration files
- ## (when they are not present)
- local x
- for x in cacheinfo CellServDB ThisCell ; do
- if [ -e "${ROOT}"/etc/openafs/${x} ] ; then
- cp "${ROOT}"/etc/openafs/${x} "${D}"/etc/openafs/
- fi
- done
-}
-
-pkg_postinst() {
- elog "This installation should work out of the box (at least the"
- elog "client part doing global afs-cell browsing, unless you had"
- elog "a previous and different configuration). If you want to"
- elog "set up your own cell or modify the standard config,"
- elog "please have a look at the Gentoo OpenAFS documentation"
- elog "(warning: it is not yet up to date wrt the new file locations)"
- elog
- elog "The documentation can be found at:"
- elog " http://www.gentoo.org/doc/en/openafs.xml"
-}
diff --git a/net-fs/openafs/openafs-1.4.12.1.ebuild b/net-fs/openafs/openafs-1.4.12.1.ebuild
deleted file mode 100644
index 9d3a74fe5c42..000000000000
--- a/net-fs/openafs/openafs-1.4.12.1.ebuild
+++ /dev/null
@@ -1,140 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/openafs-1.4.12.1.ebuild,v 1.2 2010/06/23 18:22:05 halcy0n Exp $
-
-EAPI="2"
-
-inherit flag-o-matic eutils autotools toolchain-funcs versionator pam
-
-MY_PV=$(get_version_component_range 1-3)
-PVER="1"
-DESCRIPTION="The OpenAFS distributed file system"
-HOMEPAGE="http://www.openafs.org/"
-# We always d/l the doc tarball as man pages are not USE=doc material
-SRC_URI="http://openafs.org/dl/${MY_PV}/${P}-src.tar.bz2
- http://openafs.org/dl/${MY_PV}/${P}-doc.tar.bz2
- mirror://gentoo/${P}-patches-${PVER}.tar.bz2"
-
-LICENSE="IBM BSD openafs-krb5-a APSL-2 sun-rpc"
-SLOT="0"
-KEYWORDS="~amd64 ~sparc ~x86"
-IUSE="doc kerberos pam"
-
-RDEPEND="~net-fs/openafs-kernel-${PV}
- pam? ( sys-libs/pam )
- kerberos? ( virtual/krb5 )"
-
-src_prepare() {
- EPATCH_EXCLUDE="012_all_kbuild.patch" \
- EPATCH_SUFFIX="patch" \
- epatch "${WORKDIR}"/gentoo/patches
-
- # packaging is f-ed up, so we can't run automake (i.e. eautoreconf)
- sed -i '/^a/s:^:e:' regen.sh
- skipman=1
- . regen.sh
-
- # don't install local copy of lwp #200674
- sed -i '/^install:/s|:.*|:|' src/lwp/Makefile.in
-}
-
-src_configure() {
- # cannot use "use_with" macro, as --without-krb5-config crashes the econf
- local myconf=""
- if use kerberos; then
- myconf="--with-krb5-conf=$(type -p krb5-config)"
- fi
-
- AFS_SYSKVERS=26 \
- XCFLAGS="${CFLAGS}" \
- econf \
- $(use_enable pam) \
- --enable-largefile-fileserver \
- --enable-supergroups \
- --disable-kernel-module \
- --disable-strip-binaries \
- ${myconf}
-}
-
-src_compile() {
- emake -j1 all_nolibafs || die
-}
-
-src_install() {
- local CONFDIR=${WORKDIR}/gentoo/configs
- local SCRIPTDIR=${WORKDIR}/gentoo/scripts
-
- emake -j1 DESTDIR="${D}" install_nolibafs || die
-
- insinto /etc/openafs
- doins src/afsd/CellServDB || die
- echo "/afs:/var/cache/openafs:200000" > "${D}"/etc/openafs/cacheinfo
- echo "openafs.org" > "${D}"/etc/openafs/ThisCell
-
- # pam_afs and pam_afs.krb have been installed in irregular locations, fix
- if use pam ; then
- dopammod "${D}"/usr/$(get_libdir)/pam_afs* || die
- fi
- rm -f "${D}"/usr/$(get_libdir)/pam_afs* || die
-
- # remove kdump stuff provided by kexec-tools #222455
- rm -rf "${D}"/usr/sbin/kdump*
-
- # avoid collision with mit_krb5's version of kpasswd
- mv "${D}"/usr/bin/kpasswd{,_afs} || die
- mv "${D}"/usr/share/man/man1/kpasswd{,_afs}.1 || die
-
- # minimal documentation
- use pam && doman src/pam/pam_afs.5
- dodoc "${CONFDIR}"/README src/afsd/CellServDB
-
- # documentation package
- if use doc ; then
- dodoc doc/{arch,examples,pdf,protocol,txt}/*
- dohtml -A xml -r doc/{html,xml}/*
- fi
-
- # Gentoo related scripts
- newinitd "${SCRIPTDIR}"/openafs-client openafs-client || die
- newconfd "${CONFDIR}"/openafs-client openafs-client || die
- newinitd "${SCRIPTDIR}"/openafs-server openafs-server || die
- newconfd "${CONFDIR}"/openafs-server openafs-server || die
-
- # used directories: client
- keepdir /etc/openafs
- keepdir /var/cache/openafs
-
- # used directories: server
- keepdir /etc/openafs/server
- diropts -m0700
- keepdir /var/lib/openafs
- keepdir /var/lib/openafs/db
- diropts -m0755
- keepdir /var/lib/openafs/logs
-
- # link logfiles to /var/log
- dosym ../lib/openafs/logs /var/log/openafs
-}
-
-pkg_preinst() {
- ## Somewhat intelligently install default configuration files
- ## (when they are not present)
- local x
- for x in cacheinfo CellServDB ThisCell ; do
- if [ -e "${ROOT}"/etc/openafs/${x} ] ; then
- cp "${ROOT}"/etc/openafs/${x} "${D}"/etc/openafs/
- fi
- done
-}
-
-pkg_postinst() {
- elog "This installation should work out of the box (at least the"
- elog "client part doing global afs-cell browsing, unless you had"
- elog "a previous and different configuration). If you want to"
- elog "set up your own cell or modify the standard config,"
- elog "please have a look at the Gentoo OpenAFS documentation"
- elog "(warning: it is not yet up to date wrt the new file locations)"
- elog
- elog "The documentation can be found at:"
- elog " http://www.gentoo.org/doc/en/openafs.xml"
-}