summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-02-24 18:52:27 +0000
committerPeter Volkov <pva@gentoo.org>2008-02-24 18:52:27 +0000
commitd11442b39acdf5cdf128d9caa45fb8d176d5b095 (patch)
treedbcd11371eff88017c5ebaea9da207fdbfe1b233 /net-firewall/shorewall-shell
parentUnmask linuxwacom. (diff)
downloadhistorical-d11442b39acdf5cdf128d9caa45fb8d176d5b095.tar.gz
historical-d11442b39acdf5cdf128d9caa45fb8d176d5b095.tar.bz2
historical-d11442b39acdf5cdf128d9caa45fb8d176d5b095.zip
Version bump, bug 211191. Thank Vieri <rentorbuy AT yahoo.com> for all work!
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'net-firewall/shorewall-shell')
-rw-r--r--net-firewall/shorewall-shell/ChangeLog7
-rw-r--r--net-firewall/shorewall-shell/shorewall-shell-4.0.9.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/net-firewall/shorewall-shell/ChangeLog b/net-firewall/shorewall-shell/ChangeLog
index d942c123f3bc..9360025f4efa 100644
--- a/net-firewall/shorewall-shell/ChangeLog
+++ b/net-firewall/shorewall-shell/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/shorewall-shell
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-shell/ChangeLog,v 1.8 2008/01/27 19:21:29 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-shell/ChangeLog,v 1.9 2008/02/24 18:45:36 pva Exp $
+
+*shorewall-shell-4.0.9 (24 Feb 2008)
+
+ 24 Feb 2008; <pva@gentoo.org> +shorewall-shell-4.0.9.ebuild:
+ Version bump, bug 211191. Thank Vieri <rentorbuy AT yahoo.com> for all work!
*shorewall-shell-4.0.8 (27 Jan 2008)
diff --git a/net-firewall/shorewall-shell/shorewall-shell-4.0.9.ebuild b/net-firewall/shorewall-shell/shorewall-shell-4.0.9.ebuild
new file mode 100644
index 000000000000..052a73eb3e44
--- /dev/null
+++ b/net-firewall/shorewall-shell/shorewall-shell-4.0.9.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-shell/shorewall-shell-4.0.9.ebuild,v 1.1 2008/02/24 18:45:36 pva Exp $
+
+# Choose between experimental, stable and beta:
+#MY_P_TREE="development/4.0" # experimental and beta
+MY_P_TREE="4.0" # stable
+#MY_P_BETA="-Beta7" # only beta
+MY_P_BETA="" # stable or experimental
+
+MY_P="shorewall-${PV}"
+
+DESCRIPTION="Shoreline Firewall shell-based compiler."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/shorewall/${MY_P_TREE}/${MY_P}${MY_P_BETA}/${P}${MY_P_BETA}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="net-firewall/iptables
+ sys-apps/iproute2
+ !<net-firewall/shorewall-4.0"
+
+PDEPEND="~net-firewall/shorewall-common-${PV}"
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ cd "${WORKDIR}/${P}${MY_P_BETA}"
+ PREFIX="${D}" ./install.sh || die "install.sh failed"
+
+ dodoc releasenotes.txt
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Documentation is available at http://www.shorewall.net"
+ einfo
+ einfo "In order to use the shell compiler you need to add"
+ einfo "SHOREWALL_COMPILER=shell"
+ einfo "to shorewall.conf"
+ einfo
+ einfo "Please read the included release notes for more information."
+ einfo
+ einfo "Known problems:"
+ einfo "http://www1.shorewall.net/pub/shorewall/${MY_P_TREE}/${MY_P}${MY_P_BETA}/known_problems.txt"
+ einfo
+}