summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPreston A. Elder <prez@gentoo.org>2003-04-10 14:51:42 +0000
committerPreston A. Elder <prez@gentoo.org>2003-04-10 14:51:42 +0000
commit721a343d036cd22cee0232d73d49dee63d06ccf2 (patch)
tree968390c86f70610d5adc10a1eb0ae53a6db434a9 /net-firewall/iptables
parentVersion bump. Tidied ebuild. (diff)
downloadhistorical-721a343d036cd22cee0232d73d49dee63d06ccf2.tar.gz
historical-721a343d036cd22cee0232d73d49dee63d06ccf2.tar.bz2
historical-721a343d036cd22cee0232d73d49dee63d06ccf2.zip
Added compilation of development tools
Diffstat (limited to 'net-firewall/iptables')
-rw-r--r--net-firewall/iptables/ChangeLog7
-rw-r--r--net-firewall/iptables/files/digest-iptables-1.2.7a-r41
-rw-r--r--net-firewall/iptables/iptables-1.2.7a-r4.ebuild73
3 files changed, 80 insertions, 1 deletions
diff --git a/net-firewall/iptables/ChangeLog b/net-firewall/iptables/ChangeLog
index 83c61086e9ce..f61040fcb042 100644
--- a/net-firewall/iptables/ChangeLog
+++ b/net-firewall/iptables/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/iptables
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.4 2003/03/15 21:53:29 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.5 2003/04/10 14:51:42 prez Exp $
+
+*iptables-1.2.7a-r4 (10 Apr 2003)
+
+ 10 apr 2003; Preston A. Elder <prez@gentoo.org> iptables-1.2.7a-r4.ebuild :
+ Added compilation of development tools
*iptables-1.2.7a-r3 (11 Mar 2003)
diff --git a/net-firewall/iptables/files/digest-iptables-1.2.7a-r4 b/net-firewall/iptables/files/digest-iptables-1.2.7a-r4
new file mode 100644
index 000000000000..557c12876948
--- /dev/null
+++ b/net-firewall/iptables/files/digest-iptables-1.2.7a-r4
@@ -0,0 +1 @@
+MD5 e9de1c98c86a93934c8ada812fc8b286 iptables-1.2.7a.tar.bz2 118127
diff --git a/net-firewall/iptables/iptables-1.2.7a-r4.ebuild b/net-firewall/iptables/iptables-1.2.7a-r4.ebuild
new file mode 100644
index 000000000000..ba2dc9b0b22a
--- /dev/null
+++ b/net-firewall/iptables/iptables-1.2.7a-r4.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.2.7a-r4.ebuild,v 1.1 2003/04/10 14:51:42 prez Exp $
+
+inherit eutils
+
+IUSE=""
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Kernel 2.4 firewall, NAT and packet mangling tools"
+SRC_URI="http://www.iptables.org/files/${P}.tar.bz2"
+HOMEPAGE="http://www.iptables.org/"
+
+SLOT="0"
+KEYWORDS="x86 ppc alpha sparc hppa arm mips"
+LICENSE="GPL-2"
+
+# iptables is dependent on kernel sources. Strange but true.
+DEPEND="virtual/os-headers"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${PV}-files
+ # The folowing hack is needed because ${ARCH} is "sparc" and not "sparc64"
+ # and epatch uses ??_${ARCH}_foo.${EPATCH_SUFFIX} when reading from directories
+ [ "${PROFILE_ARCH}" = "sparc64" ] && epatch ${FILESDIR}/sparc64_limit_fix.patch.bz2
+ [ "${ARCH}" = "hppa" ] && epatch ${FILESDIR}/iptables-1.2.7a-hppa.diff
+
+ chmod +x extensions/.IMQ-test*
+
+ cp Makefile Makefile.new
+ sed -e "s:-O2:${CFLAGS}:g" -e "s:/usr/local::g" Makefile.new > Makefile
+}
+
+src_compile() {
+ # iptables and libraries are now installed to /sbin and /lib, so that
+ # systems with remote network-mounted /usr filesystems can get their
+ # network interfaces up and running correctly without /usr.
+
+ make \
+ LIBDIR=/lib \
+ BINDIR=/sbin \
+ MANDIR=/usr/share/man \
+ INCDIR=/usr/include \
+ KERNEL_DIR=/usr/src/linux \
+ || die
+}
+
+src_install() {
+# dodir /usr/{lib,share/man/man8,sbin}
+
+ make DESTDIR=${D} MANDIR=/usr/share/man install
+ make DESTDIR=${D} \
+ LIBDIR=/usr/lib \
+ MANDIR=/usr/share/man \
+ INCDIR=/usr/include \
+ install-devel
+
+ dodoc COPYING KNOWN_BUGS
+ dodir /var/lib/iptables ; keepdir /var/lib/iptables
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/iptables.init iptables
+ insinto /etc/conf.d
+ newins ${FILESDIR}/iptables.confd iptables
+}
+
+pkg_postinst() {
+ einfo "This package now includes an initscript which loads and saves"
+ einfo "rules stored in /var/lib/iptables/rules-save"
+ einfo "This location can be changed in /etc/conf.d/iptables"
+}