summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-01-03 19:04:11 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-01-03 19:04:11 +0000
commitfe5b3ebfb20d33984f7222daf6fef9878bd928e8 (patch)
tree6ad7b04071a92ccb3eaf3db9243c8dfa1f03b4da /net-dns/pdns
parentFirst commit of gcc for hppa64. This one will compile 64 bit kernels. (diff)
downloadhistorical-fe5b3ebfb20d33984f7222daf6fef9878bd928e8.tar.gz
historical-fe5b3ebfb20d33984f7222daf6fef9878bd928e8.tar.bz2
historical-fe5b3ebfb20d33984f7222daf6fef9878bd928e8.zip
Added LDAP support, closes bug #36881.
Diffstat (limited to 'net-dns/pdns')
-rw-r--r--net-dns/pdns/ChangeLog6
-rw-r--r--net-dns/pdns/Manifest10
-rw-r--r--net-dns/pdns/pdns-2.9.12-r1.ebuild21
-rw-r--r--net-dns/pdns/pdns-2.9.12.ebuild4
-rw-r--r--net-dns/pdns/pdns-2.9.8.ebuild4
5 files changed, 26 insertions, 19 deletions
diff --git a/net-dns/pdns/ChangeLog b/net-dns/pdns/ChangeLog
index fb6143b42e16..8e5c8fbbc916 100644
--- a/net-dns/pdns/ChangeLog
+++ b/net-dns/pdns/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-dns/pdns
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/ChangeLog,v 1.4 2003/12/14 18:48:46 jhhudso Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/ChangeLog,v 1.5 2004/01/03 19:04:01 plasmaroo Exp $
+
+ 03 Jan 2004; <plasmaroo@gentoo.org> pdns-2.9.12-r1.ebuild:
+ Added LDAP support flag. Thanks to Lars Kneschke - closes bug
+ #36881.
*pdns-2.9.12-r1 (14 Dec 2003)
diff --git a/net-dns/pdns/Manifest b/net-dns/pdns/Manifest
index 5c5c2f7ee9a7..876b1a9496d0 100644
--- a/net-dns/pdns/Manifest
+++ b/net-dns/pdns/Manifest
@@ -1,9 +1,9 @@
-MD5 3a56cd13f5a5e84eae66590b77e472c6 pdns-2.9.12.ebuild 970
-MD5 820d957f19bc40f0cef9722ff9dfb986 pdns-2.9.8.ebuild 970
+MD5 57bbaae762db4d98fddf33e8f0189e40 ChangeLog 910
+MD5 8aad8f90ae03fd765adc9a72c493e944 pdns-2.9.12.ebuild 972
MD5 f71c33d3646cab7f4e79b40dafba3737 metadata.xml 251
-MD5 5a5405eac4ec5535b2a811d3baabed86 ChangeLog 771
-MD5 ed8b77d36f9eab478640b9744af07f77 pdns-2.9.12-r1.ebuild 1136
+MD5 30f94a808982995cefdfac0c46a1d30a pdns-2.9.8.ebuild 971
+MD5 fb17e5351081fa227df552fbbf289e09 pdns-2.9.12-r1.ebuild 1238
MD5 0969ab0b2776f09c9aeb74b0996c4426 files/pdns 533
MD5 0dfd77947e929c57e09b695e6c9aa4a5 files/digest-pdns-2.9.12-r1 63
-MD5 0dfd77947e929c57e09b695e6c9aa4a5 files/digest-pdns-2.9.12 63
MD5 edc11ac6841533c59818f2c1fb9f2a01 files/digest-pdns-2.9.8 62
+MD5 0dfd77947e929c57e09b695e6c9aa4a5 files/digest-pdns-2.9.12 63
diff --git a/net-dns/pdns/pdns-2.9.12-r1.ebuild b/net-dns/pdns/pdns-2.9.12-r1.ebuild
index 10790f3ac2b8..355660e77dda 100644
--- a/net-dns/pdns/pdns-2.9.12-r1.ebuild
+++ b/net-dns/pdns/pdns-2.9.12-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/pdns-2.9.12-r1.ebuild,v 1.1 2003/12/14 18:48:46 jhhudso Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/pdns-2.9.12-r1.ebuild,v 1.2 2004/01/03 19:04:01 plasmaroo Exp $
DESCRIPTION="The PowerDNS Daemon."
SRC_URI="http://downloads.powerdns.com/releases/${P}.tar.gz"
@@ -8,11 +8,12 @@ HOMEPAGE="http://www.powerdns.com/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-IUSE="mysql postgres static"
+IUSE="mysql postgres static ldap"
DEPEND="virtual/glibc
mysql? ( >=dev-db/mysql-3.23.54a )
- postgres? ( >=dev-libs/libpq++-4.0-r1 )"
+ postgres? ( >=dev-libs/libpq++-4.0-r1 )
+ ldap? ( >=net-nds/openldap-2.0.27-r4 )"
RDEPEND="${DEPEND}"
@@ -23,18 +24,20 @@ src_compile() {
local modules=""
use static && myconf="$myconf --enable-static-binaries"
+ use postgres && myconf="$myconf --with-pgsql-includes=/usr/include"
+
use mysql && modules="gmysql $modules"
use postgres && modules="gpgsql $modules"
- use postgres && myconf="$myconf --with-pgsql-includes=/usr/include"
- myconf="$myconf --with-modules=$modules"
+ use ldap && modules="ldap $modules"
- econf $myconf
- emake || die "emake failed"
+ econf --with-modules="$modules" \
+ $myconf || die "Configuration failed"
+
+ emake || die "Make failed"
}
src_install () {
make DESTDIR=${D} install || die
-
dodoc ChangeLog HACKING INSTALL README TODO WARNING pdns/COPYING
exeinto /etc/init.d
diff --git a/net-dns/pdns/pdns-2.9.12.ebuild b/net-dns/pdns/pdns-2.9.12.ebuild
index a80245f63fe7..2455a667c132 100644
--- a/net-dns/pdns/pdns-2.9.12.ebuild
+++ b/net-dns/pdns/pdns-2.9.12.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/pdns-2.9.12.ebuild,v 1.3 2003/12/14 18:48:46 jhhudso Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/pdns-2.9.12.ebuild,v 1.4 2004/01/03 19:04:01 plasmaroo Exp $
DESCRIPTION="The PowerDNS Daemon."
SRC_URI="http://downloads.powerdns.com/releases/${P}.tar.gz"
diff --git a/net-dns/pdns/pdns-2.9.8.ebuild b/net-dns/pdns/pdns-2.9.8.ebuild
index 661b16e485e5..81bde56af258 100644
--- a/net-dns/pdns/pdns-2.9.8.ebuild
+++ b/net-dns/pdns/pdns-2.9.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/pdns-2.9.8.ebuild,v 1.3 2003/09/08 07:10:41 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/pdns-2.9.8.ebuild,v 1.4 2004/01/03 19:04:01 plasmaroo Exp $
DESCRIPTION="The PowerDNS Daemon."
SRC_URI="http://downloads.powerdns.com/releases/${P}.tar.gz"