summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2003-12-23 00:10:11 +0000
committerTim Yamin <plasmaroo@gentoo.org>2003-12-23 00:10:11 +0000
commite93f1be88b4eada283d639f04da22e8347cc3299 (patch)
treee04586205125f434720c06c17a2e1476da9615f2 /net-dns/mydns
parentVersion bump; should close bug #36244. (diff)
downloadhistorical-e93f1be88b4eada283d639f04da22e8347cc3299.tar.gz
historical-e93f1be88b4eada283d639f04da22e8347cc3299.tar.bz2
historical-e93f1be88b4eada283d639f04da22e8347cc3299.zip
Version bump; should close bug #36244.
Diffstat (limited to 'net-dns/mydns')
-rw-r--r--net-dns/mydns/Manifest4
-rw-r--r--net-dns/mydns/files/digest-mydns-0.10.11
-rw-r--r--net-dns/mydns/mydns-0.10.1.ebuild72
3 files changed, 75 insertions, 2 deletions
diff --git a/net-dns/mydns/Manifest b/net-dns/mydns/Manifest
index 537837656224..e33edd66f582 100644
--- a/net-dns/mydns/Manifest
+++ b/net-dns/mydns/Manifest
@@ -1,5 +1,5 @@
-MD5 9aa5842b03544b312a8cb9fddc87cbae ChangeLog 474
-MD5 c6a28b4cd8cabdf76457f1551cfbb434 mydns-0.10.1.ebuild 2064
+MD5 ce8dc1e838fa7bebc19bc85aee2a556f ChangeLog 477
+MD5 d494343f97181cd55232b1db8f3db153 mydns-0.10.1.ebuild 2067
MD5 c50346bf0fb8b39c521dca42b145f6ee metadata.xml 230
MD5 9e5dafe6b14c4b044a66920be69c1d5d mydns-0.10.0.ebuild 2007
MD5 31e3706bb108132766e2611695fd803a files/digest-mydns-0.10.1 65
diff --git a/net-dns/mydns/files/digest-mydns-0.10.1 b/net-dns/mydns/files/digest-mydns-0.10.1
new file mode 100644
index 000000000000..0d51a5e792d8
--- /dev/null
+++ b/net-dns/mydns/files/digest-mydns-0.10.1
@@ -0,0 +1 @@
+MD5 a931f7fdd3398dbd441ef8cce12793c6 mydns-0.10.1.tar.bz2 576352
diff --git a/net-dns/mydns/mydns-0.10.1.ebuild b/net-dns/mydns/mydns-0.10.1.ebuild
new file mode 100644
index 000000000000..b6063a21f464
--- /dev/null
+++ b/net-dns/mydns/mydns-0.10.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/mydns/mydns-0.10.1.ebuild,v 1.1 2003/12/23 00:09:36 plasmaroo Exp $
+
+DESCRIPTION="A DNS-Server which gets its data from mysql-databases"
+HOMEPAGE="http://mydns.bboy.net/"
+SRC_URI="http://mydns.bboy.net/download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ia64"
+IUSE="nls static debug mysql postgres ssl zlib"
+
+RDEPEND="virtual/glibc
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-db/postgresql )
+ openssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ sys-devel/bison"
+
+src_compile() {
+ if [ ! "`use mysql`" -a ! "`use postgres`" ] ; then
+ eerror "MyDNS needs either MySQL or PostgreSQL."
+ eerror "Please set USE=\"mysql\" or USE=\"postgres\", and try again."
+ die
+ fi
+
+ econf --enable-alias \
+ `use_enable nls` \
+ `use_enable debug` \
+ `use_enable static static-build` \
+ `use_with postgres pgsql` \
+ `use_with mysql` \
+ `use_with ssl openssl` \
+ `use_with zlib` || die
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc ABOUT-NLS AUTHORS BUGS ChangeLog INSTALL NEWS README TODO
+ use mysql && dodoc QUICKSTART.mysql
+ use postgres && dodoc QUICKSTART.postgres
+
+ exeinto /etc/init.d; newexe ${FILESDIR}/mydns.rc6 mydns || die
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You should now run these commands:"
+ einfo
+ einfo "# /usr/sbin/mydns --dump-config > /etc/mydns.conf"
+ einfo "# chmod 0600 /etc/mydns.conf"
+ if [ "`use mysql`" ] ; then
+ einfo "# mysqladmin -u <username> -p create mydns"
+ einfo "# /usr/sbin/mydns --create-tables | mysql -u <user> -p mydns"
+ einfo
+ einfo "to create the tables in the MySQL-Database."
+ einfo "For more info see QUICKSTART.mysql."
+ elif [ "`use postgres`" ] ; then
+ einfo "# createdb mydns"
+ einfo "# /usr/sbin/mydns --create-tables | psql mydns"
+ einfo
+ einfo "to create the tables in the PostgreSQL-Database."
+ einfo "For more info see QUICKSTART.postgres."
+ fi
+ einfo
+ echo
+}