summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-16 09:11:37 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-16 09:11:37 +0000
commit7da2b2b7b67e97d4ad319f1bd05910ac491e7f15 (patch)
tree0ace159f14ab2c8cd59978d65027b54c918988fe /net-dns/bind-tools/bind-tools-9.2.2_rc1.ebuild
parentversion bump (diff)
downloadhistorical-7da2b2b7b67e97d4ad319f1bd05910ac491e7f15.tar.gz
historical-7da2b2b7b67e97d4ad319f1bd05910ac491e7f15.tar.bz2
historical-7da2b2b7b67e97d4ad319f1bd05910ac491e7f15.zip
version bump
Diffstat (limited to 'net-dns/bind-tools/bind-tools-9.2.2_rc1.ebuild')
-rw-r--r--net-dns/bind-tools/bind-tools-9.2.2_rc1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-dns/bind-tools/bind-tools-9.2.2_rc1.ebuild b/net-dns/bind-tools/bind-tools-9.2.2_rc1.ebuild
new file mode 100644
index 000000000000..7ce4844a162a
--- /dev/null
+++ b/net-dns/bind-tools/bind-tools-9.2.2_rc1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# /space/gentoo/cvsroot/gentoo-x86/net-misc/bind-tools/bind-tools-9.2.2-r1.ebuild,v 1.1 2001/12/09 23:47:08 jerrya Exp
+
+MY_P=${P//-tools}
+MY_P=${MY_P/_}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="bind tools: dig, nslookup, and host"
+SRC_URI="ftp://ftp.isc.org/isc/bind9/${PV/_}/${MY_P}.tar.gz"
+HOMEPAGE="http://www.isc.org/products/BIND/bind9-beta.html"
+
+KEYWORDS="x86 ppc"
+LICENSE="as-is"
+SLOT="0"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+
+}
+
+src_compile() {
+ econf || die "configure failed"
+
+ cd ${S}/lib/isc
+ make || die "make failed in /lib/isc"
+
+ cd ${S}/lib/dns
+ make || die "make failed in /lib/dns"
+
+ cd ${S}/bin/dig
+ make || die "make failed in /bin/dig"
+}
+
+src_install() {
+ cd ${S}/bin/dig
+ dobin dig host nslookup
+ doman dig.1 host.1
+
+ doman ${FILESDIR}/nslookup.8
+
+ cd ${S}
+ dodoc README CHANGES FAQ COPYRIGHT
+}