summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2004-02-04 14:14:02 +0000
committerHeinrich Wendel <lanius@gentoo.org>2004-02-04 14:14:02 +0000
commite78bae31891c293b9e4875e87e022671f7ebaaf7 (patch)
treeac148b14b6d25f2d4ee7d7d8a22aa39a86392395 /net-dialup
parentOverdue update (diff)
downloadhistorical-e78bae31891c293b9e4875e87e022671f7ebaaf7.tar.gz
historical-e78bae31891c293b9e4875e87e022671f7ebaaf7.tar.bz2
historical-e78bae31891c293b9e4875e87e022671f7ebaaf7.zip
added support for kernel 2.6; fixed docs; fixed DEPEND
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/ltmodem/ChangeLog8
-rw-r--r--net-dialup/ltmodem/Manifest4
-rw-r--r--net-dialup/ltmodem/files/digest-ltmodem-8.26_alpha9-r32
-rw-r--r--net-dialup/ltmodem/ltmodem-8.26_alpha9-r3.ebuild87
4 files changed, 98 insertions, 3 deletions
diff --git a/net-dialup/ltmodem/ChangeLog b/net-dialup/ltmodem/ChangeLog
index b9c741132e5f..f3726b23312d 100644
--- a/net-dialup/ltmodem/ChangeLog
+++ b/net-dialup/ltmodem/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-dialup/ltmodem
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/ltmodem/ChangeLog,v 1.10 2003/12/09 14:41:39 lanius Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/ltmodem/ChangeLog,v 1.11 2004/02/04 14:14:02 lanius Exp $
+
+ 04 Feb 2004; Heinrich Wendel <lanius@gentoo.org>
+ ltmodem-8.26_alpha9-r3.ebuild:
+ added support for kernel 2.6; fixed docs; fixed DEPEND
*ltmodem-8.26_alpha9-r2 (09 Dec 2003)
diff --git a/net-dialup/ltmodem/Manifest b/net-dialup/ltmodem/Manifest
index bb1e259ab94f..8792e800f901 100644
--- a/net-dialup/ltmodem/Manifest
+++ b/net-dialup/ltmodem/Manifest
@@ -1,6 +1,8 @@
MD5 b99ab1cca0776ce2017c43e2cdcea22f ltmodem-8.26_alpha9-r1.ebuild 1553
+MD5 08ab18b35ba0868432ec74c140c0b62f ltmodem-8.26_alpha9-r3.ebuild 2260
MD5 1f37317383191bc5a63fc394717baf04 ltmodem-8.26_alpha9-r2.ebuild 1573
-MD5 6c28446b9104b9681351191a4c8137e2 ChangeLog 1436
+MD5 e82141b7427433d4b23164ef36716d9d ChangeLog 1578
MD5 ec2f84816306825d125d0c01bd86758d metadata.xml 163
MD5 f5ab4274b107a9ac1e7d521c5dbb594a files/digest-ltmodem-8.26_alpha9-r1 66
MD5 f5ab4274b107a9ac1e7d521c5dbb594a files/digest-ltmodem-8.26_alpha9-r2 66
+MD5 c7770cf081fb61801ccdcf7eb67175dc files/digest-ltmodem-8.26_alpha9-r3 137
diff --git a/net-dialup/ltmodem/files/digest-ltmodem-8.26_alpha9-r3 b/net-dialup/ltmodem/files/digest-ltmodem-8.26_alpha9-r3
new file mode 100644
index 000000000000..a2529bd90dc0
--- /dev/null
+++ b/net-dialup/ltmodem/files/digest-ltmodem-8.26_alpha9-r3
@@ -0,0 +1,2 @@
+MD5 a75ae27d40ade3aa698c0b0b290724f4 ltmodem-8.26a9.tar.gz 679998
+MD5 c219d9d62034da24c1543f3c4bce1c91 ltmodem-2.6-alk-v00.tar.gz 217382
diff --git a/net-dialup/ltmodem/ltmodem-8.26_alpha9-r3.ebuild b/net-dialup/ltmodem/ltmodem-8.26_alpha9-r3.ebuild
new file mode 100644
index 000000000000..fbc18216ac13
--- /dev/null
+++ b/net-dialup/ltmodem/ltmodem-8.26_alpha9-r3.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/ltmodem/ltmodem-8.26_alpha9-r3.ebuild,v 1.1 2004/02/04 14:14:02 lanius Exp $
+
+inherit kernel-mod
+
+MY_P="${P/_alpha/a}"
+DESCRIPTION="Winmodems with Lucent Apollo (ISA) and Mars (PCI) chipsets"
+HOMEPAGE="http://www.heby.de/ltmodem/"
+SRC_URI="http://www.physcip.uni-stuttgart.de/heby/ltmodem/${MY_P}.tar.gz
+ http://www.sfu.ca/~cth/ltmodem/${MY_P}.tar.gz
+ http://linmodems.technion.ac.il/packages/ltmodem/kernel-2.6/ltmodem-2.6-alk-v00.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/linux-sources
+ app-shells/bash"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ if kernel-mod_is_2_4_kernel; then
+ sed -i -e 's:make -e:make:' -e 's:read -p:echo:' build_module
+ FAST="1" ./build_module || die
+ else
+ cd ../ltmodem-2.6-alk/
+ unset ARCH
+ addwrite /usr/src/linux-${KV}
+ sed -i -e "s:linux-2.6:linux:" Makefile
+ make || die
+ fi
+}
+
+src_install() {
+ # install docs
+ cd DOCs
+ dohtml *.html
+
+ rm -rf *.html Installers build* Build* gcc3.txt Examples Suse*
+ rm -rf fixscript* slackware srcprep.man scanmodem.man conf*
+
+ for i in *.man; do mv ${i} ${i}.1; done
+ doman *.man.1
+ rm -rf *.man.1
+
+ dodoc ../1ST-READ *
+ cd ..
+
+ # install utilities
+ mv utils/unloading utils/lt_unloading
+ dosbin utils/lt_*
+
+ # install configuration
+ if kernel-mod_is_2_6_kernel; then
+ tar -xzf source.tar.gz
+ sed -e "s:@LT_SERIAL_MODULE@:ltmodem:" source/debian/modules.in > source/debian/modules
+ fi
+ cd source
+
+ insinto /etc/devfs.d
+ newins debian/etc_devfs_conf.d_ltmodem ltmodem
+ insinto /etc/modules.d
+ newins debian/modules ltmodem
+
+ # install kernel module
+ if kernel-mod_is_2_4_kernel; then
+ make install ROOTDIR=${D} || die
+ else
+ cd ${WORKDIR}/ltmodem-2.6-alk/
+ insinto /lib/modules/${KV}/ltmodem
+ doins ltmodem.ko
+ doins ltserial.ko
+ fi
+}
+
+pkg_postinst() {
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+ einfo "Use /dev/modem to access modem"
+ einfo "If you have problems, read this doc:"
+ einfo "/usr/share/doc/${PF}/html/post-install.html"
+ echo
+ einfo "Also, if you wish to access the modem through"
+ einfo "/dev/modem without rebooting, run this:"
+ einfo "killall -HUP devfsd"
+}