summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2008-01-30 01:22:32 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2008-01-30 01:22:32 +0000
commit98b60a090bebcd04d92e0959815cb3f0782cbc26 (patch)
tree6e7401fd08eefe4b5bf5d72323e9e770eb7cd15e /net-dialup
parentStable on x86 wrt bug #208032 (diff)
downloadhistorical-98b60a090bebcd04d92e0959815cb3f0782cbc26.tar.gz
historical-98b60a090bebcd04d92e0959815cb3f0782cbc26.tar.bz2
historical-98b60a090bebcd04d92e0959815cb3f0782cbc26.zip
fixing string.h problem (see bug #202385) + patches for kernel 2.6.24 (thanks to Arnd Feldmueller <arnd.feldmueller@web.de>).
Package-Manager: portage-2.1.4
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/e2220pc/ChangeLog9
-rw-r--r--net-dialup/e2220pc/e2220pc-0.1-r1.ebuild53
-rw-r--r--net-dialup/e2220pc/files/digest-e2220pc-0.1-r13
-rw-r--r--net-dialup/e2220pc/files/e2220pc_kernel-2.6.24.diff46
-rw-r--r--net-dialup/e5520pc/ChangeLog9
-rw-r--r--net-dialup/e5520pc/e5520pc-0.1-r1.ebuild53
-rw-r--r--net-dialup/e5520pc/files/digest-e5520pc-0.1-r13
-rw-r--r--net-dialup/e5520pc/files/e5520pc_kernel-2.6.24.diff46
-rw-r--r--net-dialup/fcclassic/Manifest15
9 files changed, 231 insertions, 6 deletions
diff --git a/net-dialup/e2220pc/ChangeLog b/net-dialup/e2220pc/ChangeLog
index 0dcd5f2f98de..6c958f926e54 100644
--- a/net-dialup/e2220pc/ChangeLog
+++ b/net-dialup/e2220pc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dialup/e2220pc
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/e2220pc/ChangeLog,v 1.1 2008/01/06 01:25:30 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/e2220pc/ChangeLog,v 1.2 2008/01/30 01:19:27 sbriesen Exp $
+
+*e2220pc-0.1-r1 (30 Jan 2008)
+
+ 30 Jan 2008; Stefan Briesenick <sbriesen@gentoo.org>
+ +files/e2220pc_kernel-2.6.24.diff, +e2220pc-0.1-r1.ebuild:
+ fixing string.h problem (see bug #202385) + patches for kernel 2.6.24
+ (thanks to Arnd Feldmueller <arnd.feldmueller@web.de>).
*e2220pc-0.1 (06 Jan 2008)
diff --git a/net-dialup/e2220pc/e2220pc-0.1-r1.ebuild b/net-dialup/e2220pc/e2220pc-0.1-r1.ebuild
new file mode 100644
index 000000000000..a5d060aefb8d
--- /dev/null
+++ b/net-dialup/e2220pc/e2220pc-0.1-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/e2220pc/e2220pc-0.1-r1.ebuild,v 1.1 2008/01/30 01:19:27 sbriesen Exp $
+
+inherit eutils rpm linux-mod
+
+DESCRIPTION="AVM kernel 2.6 modules for Eumex 2220 PC"
+HOMEPAGE="http://opensuse.foehr-it.de/"
+SRC_URI="http://opensuse.foehr-it.de/rpms/10_3/src/${P}-0.src.rpm"
+
+LICENSE="AVM-FC"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="!net-dialup/fritzcapi"
+RDEPEND="${DEPEND} net-dialup/capi4k-utils"
+
+S="${WORKDIR}/${PN}"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if ! kernel_is 2 6; then
+ die "This package works only with 2.6 kernel!"
+ fi
+
+ BUILD_TARGETS="all"
+ BUILD_PARAMS="KDIR=${KV_DIR} LIBDIR=${S}/src"
+ MODULE_NAMES="${PN}(net:${S}/src)"
+}
+
+src_unpack() {
+ rpm_unpack "${DISTDIR}/${A}" || die "failed to unpack ${A} file"
+ DISTDIR="${WORKDIR}" unpack eumex*.tar.bz2
+
+ cd "${S}"
+ epatch $(sed -n "s|^Patch[01234]:\s*\(.*\)|../\1|p" ../${PN}.spec)
+ epatch "${FILESDIR}/${PN}_kernel-2.6.24.diff"
+ convert_to_m src/Makefile
+
+ for i in lib/*-lib.o; do
+ einfo "Localize symbols in ${i##*/} ..."
+ objcopy -L memcmp -L memcpy -L memmove -L memset -L strcat \
+ -L strcmp -L strcpy -L strlen -L strncmp -L strncpy "${i}"
+ done
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc CAPI*.txt
+ dohtml *.html
+}
diff --git a/net-dialup/e2220pc/files/digest-e2220pc-0.1-r1 b/net-dialup/e2220pc/files/digest-e2220pc-0.1-r1
new file mode 100644
index 000000000000..175474777fe5
--- /dev/null
+++ b/net-dialup/e2220pc/files/digest-e2220pc-0.1-r1
@@ -0,0 +1,3 @@
+MD5 885ab096b4b7b6a3bad3826a2c53945e e2220pc-0.1-0.src.rpm 316445
+RMD160 9a469e7942256856a928e31802276f34d47fda96 e2220pc-0.1-0.src.rpm 316445
+SHA256 0ad115ae513f13cad002468924e983271e418f98e16b4762dd62b77030e00ae5 e2220pc-0.1-0.src.rpm 316445
diff --git a/net-dialup/e2220pc/files/e2220pc_kernel-2.6.24.diff b/net-dialup/e2220pc/files/e2220pc_kernel-2.6.24.diff
new file mode 100644
index 000000000000..6e42ce76f162
--- /dev/null
+++ b/net-dialup/e2220pc/files/e2220pc_kernel-2.6.24.diff
@@ -0,0 +1,46 @@
+--- src/driver.c.orig 2008-01-30 02:03:44.000000000 +0100
++++ src/driver.c 2008-01-30 02:03:44.000000000 +0100
+@@ -91,8 +91,12 @@
+ static DECLARE_WAIT_QUEUE_HEAD(sched_wait);
+ static DECLARE_WAIT_QUEUE_HEAD(tx_wait);
+ static DECLARE_WAIT_QUEUE_HEAD(rx_wait);
++static DECLARE_COMPLETION(hotplug); /* New DECLARE, <arnd.feldmueller@web.de> */
++static DECLARE_COMPLETION(notify); /* New DECLARE, <arnd.feldmueller@web.de> */
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24))
+ static DECLARE_MUTEX_LOCKED(hotplug);
+ static DECLARE_MUTEX_LOCKED(notify);
++#endif
+
+ /*---------------------------------------------------------------------------*\
+ \*---------------------------------------------------------------------------*/
+@@ -754,7 +758,7 @@
+ close_func = func;
+ close_data = data;
+
+- INIT_WORK (&closing_work, closing_worker);
++ INIT_WORK (&closing_work, (work_func_t)closing_worker);
+ schedule_work (&closing_work);
+ LOG("Worker scheduled.\n");
+ } /* start_closing_worker */
+@@ -1171,7 +1175,10 @@
+ }
+ }
+ LOG("Scheduler thread stopped.\n");
++ complete(&hotplug); /* Complete Thread Sync here <arnd.feldmueller@web.de> */
++ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24))
+ up (&hotplug);
++ #endif
+ return 0;
+ } /* scheduler */
+
+@@ -1206,7 +1213,10 @@
+ wake_up_interruptible (&wait);
+ }
+ LOG("Scheduler thread signalled, waiting...\n");
++ wait_for_completion(&hotplug); /* Wait for complete Thread Sync <arnd.feldmueller@web.de> */
++ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24))
+ down (&hotplug);
++ #endif
+ LOG("Scheduler thread[%d] terminated.\n", thread_pid);
+ }
+ thread_pid = -1;
diff --git a/net-dialup/e5520pc/ChangeLog b/net-dialup/e5520pc/ChangeLog
index 016d07c89c82..abf20fb80411 100644
--- a/net-dialup/e5520pc/ChangeLog
+++ b/net-dialup/e5520pc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dialup/e5520pc
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/e5520pc/ChangeLog,v 1.1 2008/01/06 01:27:58 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/e5520pc/ChangeLog,v 1.2 2008/01/30 01:22:31 sbriesen Exp $
+
+*e5520pc-0.1-r1 (30 Jan 2008)
+
+ 30 Jan 2008; Stefan Briesenick <sbriesen@gentoo.org>
+ +files/e5520pc_kernel-2.6.24.diff, +e5520pc-0.1-r1.ebuild:
+ fixing string.h problem (see bug #202385) + patches for kernel 2.6.24
+ (thanks to Arnd Feldmueller <arnd.feldmueller@web.de>).
*e5520pc-0.1 (06 Jan 2008)
diff --git a/net-dialup/e5520pc/e5520pc-0.1-r1.ebuild b/net-dialup/e5520pc/e5520pc-0.1-r1.ebuild
new file mode 100644
index 000000000000..0c287bf2ea97
--- /dev/null
+++ b/net-dialup/e5520pc/e5520pc-0.1-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/e5520pc/e5520pc-0.1-r1.ebuild,v 1.1 2008/01/30 01:22:31 sbriesen Exp $
+
+inherit eutils rpm linux-mod
+
+DESCRIPTION="AVM kernel 2.6 modules for Eumex 5520 PC"
+HOMEPAGE="http://opensuse.foehr-it.de/"
+SRC_URI="http://opensuse.foehr-it.de/rpms/10_3/src/${P}-0.src.rpm"
+
+LICENSE="AVM-FC"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="!net-dialup/fritzcapi"
+RDEPEND="${DEPEND} net-dialup/capi4k-utils"
+
+S="${WORKDIR}/${PN}"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if ! kernel_is 2 6; then
+ die "This package works only with 2.6 kernel!"
+ fi
+
+ BUILD_TARGETS="all"
+ BUILD_PARAMS="KDIR=${KV_DIR} LIBDIR=${S}/src"
+ MODULE_NAMES="${PN}(net:${S}/src)"
+}
+
+src_unpack() {
+ rpm_unpack "${DISTDIR}/${A}" || die "failed to unpack ${A} file"
+ DISTDIR="${WORKDIR}" unpack eumex*.tar.bz2
+
+ cd "${S}"
+ epatch $(sed -n "s|^Patch[01234]:\s*\(.*\)|../\1|p" ../${PN}.spec)
+ epatch "${FILESDIR}/${PN}_kernel-2.6.24.diff"
+ convert_to_m src/Makefile
+
+ for i in lib/*-lib.o; do
+ einfo "Localize symbols in ${i##*/} ..."
+ objcopy -L memcmp -L memcpy -L memmove -L memset -L strcat \
+ -L strcmp -L strcpy -L strlen -L strncmp -L strncpy "${i}"
+ done
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc CAPI*.txt
+ dohtml *.html
+}
diff --git a/net-dialup/e5520pc/files/digest-e5520pc-0.1-r1 b/net-dialup/e5520pc/files/digest-e5520pc-0.1-r1
new file mode 100644
index 000000000000..8995f0648ab5
--- /dev/null
+++ b/net-dialup/e5520pc/files/digest-e5520pc-0.1-r1
@@ -0,0 +1,3 @@
+MD5 11efcd3345ba368d9104ce87bf127328 e5520pc-0.1-0.src.rpm 316463
+RMD160 3a58aa54c6903929b0f268784a3e0816a9654295 e5520pc-0.1-0.src.rpm 316463
+SHA256 898f5a0a9a14586012ec03a46cbb5d02d4012ed1c1edbcd828f2b975eb1b3438 e5520pc-0.1-0.src.rpm 316463
diff --git a/net-dialup/e5520pc/files/e5520pc_kernel-2.6.24.diff b/net-dialup/e5520pc/files/e5520pc_kernel-2.6.24.diff
new file mode 100644
index 000000000000..a5f2043682be
--- /dev/null
+++ b/net-dialup/e5520pc/files/e5520pc_kernel-2.6.24.diff
@@ -0,0 +1,46 @@
+--- src/driver.c.orig 2008-01-30 02:07:00.000000000 +0100
++++ src/driver.c 2008-01-30 02:07:00.000000000 +0100
+@@ -91,8 +91,12 @@
+ static DECLARE_WAIT_QUEUE_HEAD(sched_wait);
+ static DECLARE_WAIT_QUEUE_HEAD(tx_wait);
+ static DECLARE_WAIT_QUEUE_HEAD(rx_wait);
++static DECLARE_COMPLETION(hotplug); /* New DECLARE, <arnd.feldmueller@web.de> */
++static DECLARE_COMPLETION(notify); /* New DECLARE, <arnd.feldmueller@web.de> */
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24))
+ static DECLARE_MUTEX_LOCKED(hotplug);
+ static DECLARE_MUTEX_LOCKED(notify);
++#endif
+
+ /*---------------------------------------------------------------------------*\
+ \*---------------------------------------------------------------------------*/
+@@ -754,7 +758,7 @@
+ close_func = func;
+ close_data = data;
+
+- INIT_WORK (&closing_work, closing_worker);
++ INIT_WORK (&closing_work, (work_func_t)closing_worker);
+ schedule_work (&closing_work);
+ LOG("Worker scheduled.\n");
+ } /* start_closing_worker */
+@@ -1171,7 +1175,10 @@
+ }
+ }
+ LOG("Scheduler thread stopped.\n");
++ complete(&hotplug); /* Complete Thread Sync here <arnd.feldmueller@web.de> */
++ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24))
+ up (&hotplug);
++ #endif
+ return 0;
+ } /* scheduler */
+
+@@ -1206,7 +1213,10 @@
+ wake_up_interruptible (&wait);
+ }
+ LOG("Scheduler thread signalled, waiting...\n");
++ wait_for_completion(&hotplug); /* Wait for complete Thread Sync <arnd.feldmueller@web.de> */
++ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24))
+ down (&hotplug);
++ #endif
+ LOG("Scheduler thread[%d] terminated.\n", thread_pid);
+ }
+ thread_pid = -1;
diff --git a/net-dialup/fcclassic/Manifest b/net-dialup/fcclassic/Manifest
index ab50ad4882ba..7562df7649db 100644
--- a/net-dialup/fcclassic/Manifest
+++ b/net-dialup/fcclassic/Manifest
@@ -1,12 +1,16 @@
DIST fcclassic-0.1-0.src.rpm 279140 RMD160 de91024d8ceafa58732c69c27e403b697eddc17f SHA1 3dcd2a0e33b79bcb5e6c8604535fef272f20a9d7 SHA256 5125202114517b49fd32bf108cbc811438b7791c4da4c6ee13af7b61cd2b6be7
+EBUILD fcclassic-0.1-r1.ebuild 1235 RMD160 b6744820353fd3f2699626629d1b585d52acb6b4 SHA1 7e118bd926d878716b1620a7eaa173868170c6ed SHA256 971bb3b1a4c4499c995794d8277f87ba162d502a21faec3bb302ec927ca352d6
+MD5 ac48174c0802dd7d3afbd55b186d485a fcclassic-0.1-r1.ebuild 1235
+RMD160 b6744820353fd3f2699626629d1b585d52acb6b4 fcclassic-0.1-r1.ebuild 1235
+SHA256 971bb3b1a4c4499c995794d8277f87ba162d502a21faec3bb302ec927ca352d6 fcclassic-0.1-r1.ebuild 1235
EBUILD fcclassic-0.1.ebuild 1033 RMD160 c7cbef9e5620910f971c1e2bd70e033a496d2e38 SHA1 6c12f624bc92cbe16b62bacd206953df77055652 SHA256 092068b7b9bec7cd4082afdec9acf49079c520d329ec4886d46763e60a0e468c
MD5 ee56ed49275f855050e8073bca2db2fd fcclassic-0.1.ebuild 1033
RMD160 c7cbef9e5620910f971c1e2bd70e033a496d2e38 fcclassic-0.1.ebuild 1033
SHA256 092068b7b9bec7cd4082afdec9acf49079c520d329ec4886d46763e60a0e468c fcclassic-0.1.ebuild 1033
-MISC ChangeLog 406 RMD160 e06562294599436d363d90360d9d8c14a1b7990e SHA1 94868e56d38e2cc7db2201dd500534900e2fcc92 SHA256 c4412650bdc798d8a1b76bfd77b0f3799fadb768a82924834756edb6d58fb928
-MD5 e0dcd83660372b15012628787aa5efa5 ChangeLog 406
-RMD160 e06562294599436d363d90360d9d8c14a1b7990e ChangeLog 406
-SHA256 c4412650bdc798d8a1b76bfd77b0f3799fadb768a82924834756edb6d58fb928 ChangeLog 406
+MISC ChangeLog 568 RMD160 71b9611696856a308dc09eef92a90b395acf0525 SHA1 a3af2aad0f9cc89a7ce7469c0c77a27b346db000 SHA256 8c7b51a1c8c247e70d2e8c257089c24ec92d796d6f675de8548b4476f82f4dda
+MD5 4f7ade7a03425a503568589bb3e9c60e ChangeLog 568
+RMD160 71b9611696856a308dc09eef92a90b395acf0525 ChangeLog 568
+SHA256 8c7b51a1c8c247e70d2e8c257089c24ec92d796d6f675de8548b4476f82f4dda ChangeLog 568
MISC metadata.xml 263 RMD160 ea2e7ecb186a7fd9b309bd3aff02c9e139981ce8 SHA1 62ca0c83d00d102d78427e59920cf79b62d37dc1 SHA256 ad6c0344e90e2a2c1f631b6d6e0242799bec90eee1eaccdc04674f52be49ea75
MD5 f94665086a9aad6ef83a893ce39954fb metadata.xml 263
RMD160 ea2e7ecb186a7fd9b309bd3aff02c9e139981ce8 metadata.xml 263
@@ -14,3 +18,6 @@ SHA256 ad6c0344e90e2a2c1f631b6d6e0242799bec90eee1eaccdc04674f52be49ea75 metadata
MD5 928b775d38dbe32cf35830810e03c97d files/digest-fcclassic-0.1 250
RMD160 6d827516633011685eb47c19f2777f7b74c2ec2a files/digest-fcclassic-0.1 250
SHA256 40e07a831741de82c6f454d8c10cb36668955c80fa0b75c592e041432e03c8f3 files/digest-fcclassic-0.1 250
+MD5 928b775d38dbe32cf35830810e03c97d files/digest-fcclassic-0.1-r1 250
+RMD160 6d827516633011685eb47c19f2777f7b74c2ec2a files/digest-fcclassic-0.1-r1 250
+SHA256 40e07a831741de82c6f454d8c10cb36668955c80fa0b75c592e041432e03c8f3 files/digest-fcclassic-0.1-r1 250