summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2004-01-16 10:50:38 +0000
committerJoshua Kinard <kumba@gentoo.org>2004-01-16 10:50:38 +0000
commit1879ee13c90b7d9ae225e916323d5546b2070d52 (patch)
tree135f7ec9ac9726ae4f499e68d79517c787cab8de /net-dialup
parentcleanup (diff)
downloadhistorical-1879ee13c90b7d9ae225e916323d5546b2070d52.tar.gz
historical-1879ee13c90b7d9ae225e916323d5546b2070d52.tar.bz2
historical-1879ee13c90b7d9ae225e916323d5546b2070d52.zip
Added a small patch which allows xc to use 115200 baud speed for serial port connections. Also tweaked the Makefile to import CFLAGS from the portage environment.
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/xc/ChangeLog13
-rw-r--r--net-dialup/xc/Manifest9
-rw-r--r--net-dialup/xc/files/digest-xc-4.3.2-r11
-rw-r--r--net-dialup/xc/files/xc-4.3.2-add-115200.patch10
-rw-r--r--net-dialup/xc/xc-4.3.2-r1.ebuild42
-rw-r--r--net-dialup/xc/xc-4.3.2.ebuild4
6 files changed, 72 insertions, 7 deletions
diff --git a/net-dialup/xc/ChangeLog b/net-dialup/xc/ChangeLog
index f2a6b4843635..5c912c629be7 100644
--- a/net-dialup/xc/ChangeLog
+++ b/net-dialup/xc/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-dialup/xc
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/xc/ChangeLog,v 1.6 2003/11/19 14:51:43 lanius Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xc/ChangeLog,v 1.7 2004/01/16 10:50:38 kumba Exp $
+
+*xc-4.3.2-r1 (16 Jan 2004)
+
+ 16 Jan 2004; Joshua Kinard <kumba@gentoo.org> xc-4.3.2-r1.ebuild,
+ files/xc-4.3.2-add-115200.patch:
+ Added a small patch which allows xc to use 115200 baud speed for serial port
+ connections (I wanted to use this program to link into my cobalt raq2, which
+ operates at such a speed, and minicom has issues). Also tweaked the Makefile
+ to import CFLAGS from the portage environment.
19 Nov 2003; Heinrich Wendel <lanius@gentoo.org> metadata.xml:
metadata.xml
diff --git a/net-dialup/xc/Manifest b/net-dialup/xc/Manifest
index e87f20328e85..82450f11ee2a 100644
--- a/net-dialup/xc/Manifest
+++ b/net-dialup/xc/Manifest
@@ -1,5 +1,8 @@
-MD5 6bd64e89e96ad4bfa8c2ba3bdb70ac7a xc-4.3.2.ebuild 855
-MD5 0432b4fe381085a624e783034e7b2393 ChangeLog 876
+MD5 166386bbb96bb9435673513a66000e49 ChangeLog 1293
MD5 ec2f84816306825d125d0c01bd86758d metadata.xml 163
-MD5 80e981efed033a8eaaa0c0e632eee1ae files/xc-4.3.2-gentoo.diff 1905
+MD5 acfc233b27774e10007e47dbf9550941 xc-4.3.2.ebuild 852
+MD5 6ae497e9df82e0c5dbc4a2006a10d7b0 xc-4.3.2-r1.ebuild 1157
MD5 a19ff63623f36ba8624bf50f382e210c files/digest-xc-4.3.2 60
+MD5 80e981efed033a8eaaa0c0e632eee1ae files/xc-4.3.2-gentoo.diff 1905
+MD5 d6b646fa4989aba362ce50ae2b1907e5 files/xc-4.3.2-add-115200.patch 246
+MD5 a19ff63623f36ba8624bf50f382e210c files/digest-xc-4.3.2-r1 60
diff --git a/net-dialup/xc/files/digest-xc-4.3.2-r1 b/net-dialup/xc/files/digest-xc-4.3.2-r1
new file mode 100644
index 000000000000..7c1adf670497
--- /dev/null
+++ b/net-dialup/xc/files/digest-xc-4.3.2-r1
@@ -0,0 +1 @@
+MD5 e7bb2de7177a4ef9a4eccf3fd3d67c05 xc-4.3.2.tar.gz 162098
diff --git a/net-dialup/xc/files/xc-4.3.2-add-115200.patch b/net-dialup/xc/files/xc-4.3.2-add-115200.patch
new file mode 100644
index 000000000000..3d879ce1bc7b
--- /dev/null
+++ b/net-dialup/xc/files/xc-4.3.2-add-115200.patch
@@ -0,0 +1,10 @@
+--- xcport.c.orig 2004-01-16 05:11:34.131877776 -0500
++++ xcport.c 2004-01-16 05:13:52.459848728 -0500
+@@ -107,6 +107,7 @@ static struct {
+ {"38400",38400,B38400},
+ {"57600",57600,B50},
+ #endif
++ {"115200",115200,B115200},
+ {"0", 0, B0}
+ };
+
diff --git a/net-dialup/xc/xc-4.3.2-r1.ebuild b/net-dialup/xc/xc-4.3.2-r1.ebuild
new file mode 100644
index 000000000000..80d46abe0404
--- /dev/null
+++ b/net-dialup/xc/xc-4.3.2-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xc/xc-4.3.2-r1.ebuild,v 1.1 2004/01/16 10:50:38 kumba Exp $
+
+DESCRIPTION="unix dialout program"
+HOMEPAGE="http://www.ibiblio.org/pub/Linux/apps/serialcomm/dialout/"
+SRC_URI="http://www.ibiblio.org/pub/Linux/apps/serialcomm/dialout/${P}.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86 ~sparc ~mips"
+DEPEND="sys-libs/libtermcap-compat"
+RDEPEND=""
+S="${WORKDIR}/${P}"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.diff
+
+ # Adds 115200 bps support
+ epatch ${FILESDIR}/${P}-add-115200.patch
+
+ # Fixes the Makefile to use gentoo CFLAGS
+ mv ${S}/Makefile ${S}/Makefile.orig
+ sed -e "s:GCCOPT\t= -pipe -O2 -fno-strength-reduce -fomit-frame-pointer:GCCOPT\t= ${CFLAGS} -fno-strength-reduce:g" \
+ ${S}/Makefile.orig > ${S}/Makefile
+}
+
+src_compile() {
+ make WARN="" all prefix=/usr mandir=/usr/share/man || die
+
+}
+
+src_install () {
+ dodir /usr/bin /usr/share/man/man1 /usr/lib/xc
+
+ make DESTDIR=${D} install || die
+
+ insinto /usr/lib/xc
+ doins phonelist xc.init dotfiles/.[a-z]*
+}
diff --git a/net-dialup/xc/xc-4.3.2.ebuild b/net-dialup/xc/xc-4.3.2.ebuild
index 7a9083b32b92..a0e1fd923103 100644
--- a/net-dialup/xc/xc-4.3.2.ebuild
+++ b/net-dialup/xc/xc-4.3.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/xc/xc-4.3.2.ebuild,v 1.6 2003/09/07 00:09:22 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xc/xc-4.3.2.ebuild,v 1.7 2004/01/16 10:50:38 kumba Exp $
DESCRIPTION="unix dialout program"
HOMEPAGE="http://www.ibiblio.org/pub/Linux/apps/serialcomm/dialout/"