summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2008-01-30 01:39:30 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2008-01-30 01:39:30 +0000
commita3d0cd6c7cfaf57c8877cc0a42d8750ae8e144d0 (patch)
tree47271b33fc38eb594e60de9a69efe552ed264377 /net-dialup/fcpnp/fcpnp-0.1-r1.ebuild
parentMarking gnustep ppc for bug 207381 (diff)
downloadhistorical-a3d0cd6c7cfaf57c8877cc0a42d8750ae8e144d0.tar.gz
historical-a3d0cd6c7cfaf57c8877cc0a42d8750ae8e144d0.tar.bz2
historical-a3d0cd6c7cfaf57c8877cc0a42d8750ae8e144d0.zip
fixing string.h problem (see bug #202385).
Package-Manager: portage-2.1.4
Diffstat (limited to 'net-dialup/fcpnp/fcpnp-0.1-r1.ebuild')
-rw-r--r--net-dialup/fcpnp/fcpnp-0.1-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-dialup/fcpnp/fcpnp-0.1-r1.ebuild b/net-dialup/fcpnp/fcpnp-0.1-r1.ebuild
new file mode 100644
index 000000000000..4586a31126cc
--- /dev/null
+++ b/net-dialup/fcpnp/fcpnp-0.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcpnp/fcpnp-0.1-r1.ebuild,v 1.1 2008/01/30 01:39:29 sbriesen Exp $
+
+inherit eutils rpm linux-mod
+
+DESCRIPTION="AVM kernel 2.6 modules for Fritz!Card PnP"
+HOMEPAGE="http://opensuse.foehr-it.de/"
+SRC_URI="http://opensuse.foehr-it.de/rpms/10_3/src/${P}-0.src.rpm"
+
+LICENSE="AVM-FC"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="!net-dialup/fritzcapi"
+RDEPEND="${DEPEND} net-dialup/capi4k-utils"
+
+S="${WORKDIR}/fritz"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if ! kernel_is 2 6; then
+ die "This package works only with 2.6 kernel!"
+ fi
+
+ BUILD_TARGETS="all"
+ BUILD_PARAMS="KDIR=${KV_DIR} LIBDIR=${S}/src"
+ MODULE_NAMES="${PN}(net:${S}/src)"
+}
+
+src_unpack() {
+ rpm_unpack "${DISTDIR}/${A}" || die "failed to unpack ${A} file"
+ DISTDIR="${WORKDIR}" unpack ${PN}-*.tar.bz2
+
+ cd "${S}"
+ epatch $(sed -n "s|^Patch[01234]:\s*\(.*\)|../\1|p" ../${PN}.spec)
+ convert_to_m src/Makefile
+
+ for i in lib/*-lib.o; do
+ einfo "Localize symbols in ${i##*/} ..."
+ objcopy -L memcmp -L memcpy -L memmove -L memset -L strcat \
+ -L strcmp -L strcpy -L strlen -L strncmp -L strncpy "${i}"
+ done
+}