summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2005-05-16 08:49:33 +0000
committerStefan Schweizer <genstef@gentoo.org>2005-05-16 08:49:33 +0000
commita9bb5a3150c752040c94276f3274f45ea9ba32c3 (patch)
treec681035e9b13c6058e33eebfcd02f050b090a322 /net-dialup/capi4k-utils
parentOops, add initscript (diff)
downloadhistorical-a9bb5a3150c752040c94276f3274f45ea9ba32c3.tar.gz
historical-a9bb5a3150c752040c94276f3274f45ea9ba32c3.tar.bz2
historical-a9bb5a3150c752040c94276f3274f45ea9ba32c3.zip
Version bump, misdn hotplug added
Package-Manager: portage-1.589-cvs
Diffstat (limited to 'net-dialup/capi4k-utils')
-rw-r--r--net-dialup/capi4k-utils/ChangeLog9
-rw-r--r--net-dialup/capi4k-utils/capi4k-utils-20050509.ebuild130
-rw-r--r--net-dialup/capi4k-utils/files/capi.conf9
-rw-r--r--net-dialup/capi4k-utils/files/capi.confd5
-rw-r--r--net-dialup/capi4k-utils/files/capi.hotplug80
-rw-r--r--net-dialup/capi4k-utils/files/capi.usermap33
-rw-r--r--net-dialup/capi4k-utils/files/digest-capi4k-utils-200505091
7 files changed, 218 insertions, 49 deletions
diff --git a/net-dialup/capi4k-utils/ChangeLog b/net-dialup/capi4k-utils/ChangeLog
index c347ad49f9d2..97cba086edc9 100644
--- a/net-dialup/capi4k-utils/ChangeLog
+++ b/net-dialup/capi4k-utils/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dialup/capi4k-utils
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/capi4k-utils/ChangeLog,v 1.32 2005/04/24 13:31:48 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/capi4k-utils/ChangeLog,v 1.33 2005/05/16 08:49:33 genstef Exp $
+
+*capi4k-utils-20050509 (16 May 2005)
+
+ 16 May 2005; Stefan Schweizer <genstef@gentoo.org> files/capi.conf,
+ files/capi.confd, files/capi.hotplug, files/capi.usermap,
+ +capi4k-utils-20050509.ebuild:
+ Version bump, misdn hotplug added
*capi4k-utils-20050322-r1 (24 Apr 2005)
diff --git a/net-dialup/capi4k-utils/capi4k-utils-20050509.ebuild b/net-dialup/capi4k-utils/capi4k-utils-20050509.ebuild
new file mode 100644
index 000000000000..3dc1afb95faf
--- /dev/null
+++ b/net-dialup/capi4k-utils/capi4k-utils-20050509.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/capi4k-utils/capi4k-utils-20050509.ebuild,v 1.1 2005/05/16 08:49:33 genstef Exp $
+
+inherit multilib
+
+YEAR_PV=${PV:0:4}
+MON_PV=${PV:4:2}
+DAY_PV=${PV:6:2}
+MY_P=${PN}-${YEAR_PV}-${MON_PV}-${DAY_PV}
+PPPVERSIONS="2.4.2 2.4.3" # versions in portage
+
+DESCRIPTION="CAPI4Linux Utils"
+HOMEPAGE="ftp://ftp.in-berlin.de/pub/capi4linux/"
+SRC_URI="ftp://ftp.in-berlin.de/pub/capi4linux/${MY_P}.tar.gz
+ ftp://ftp.in-berlin.de/pub/capi4linux/OLD/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE=""
+
+DEPEND="virtual/linux-sources
+ dev-lang/perl
+ >=sys-apps/sed-4
+ virtual/os-headers
+ sys-devel/automake
+ >=sys-devel/autoconf-2.50
+ sys-devel/libtool"
+RDEPEND=""
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A} || die "failed to unpack sources"
+ cd ${S}
+ # set our config
+ cp -f ${FILESDIR}/config .config
+ # patch includes of all *.c files
+ sed -i -e "s:linux/capi.h>$:linux/compiler.h>\n#include <linux/capi.h>:g" */*.c || die "sed failed"
+ # patch all Makefile.am and Rules.make to use our CFLAGS
+ sed -i -e "s:^CFLAGS\(.*\)-O2:CFLAGS\1${CFLAGS}:g" */Makefile.* */Rules.make || die "sed failed"
+ # patch capi20/Makefile.am to use -fPIC for shared library
+ sed -i -e "s:^\(libcapi20_la_CFLAGS = \):\1-fPIC :g" capi20/Makefile.* || die "sed failed"
+ # patch pppdcapiplugin/Makefile to use only the ppp versions we want
+ sed -i -e "s:^\(PPPVERSIONS = \).*$:\1${PPPVERSIONS}:g" pppdcapiplugin/Makefile || die "sed failed"
+ # patch capiinit/capiinit.c to look also in /lib/firmware
+ sed -i -e "s:\(\"/lib/firmware/isdn\",\):\1 \"/lib/firmware\",:g" capiinit/capiinit.c || die "sed failed"
+ # no, we don't need any devices nodes
+ sed -i -e "s:\(sh scripts/makedev.sh\):echo \1:g" Makefile || die "sed failed"
+ # add --libdir to configure call in Makefile
+ sed -i -e "s:\(\./configure \):\1--libdir=/usr/$(get_libdir) :g" Makefile || die "sed failed"
+ # patch /usr/lib/pppd in pppdcapiplugin tree
+ sed -i -e "s:/usr/lib/pppd:/usr/$(get_libdir)/pppd:g" \
+ pppdcapiplugin/ppp-*/Makefile pppdcapiplugin/{README,*.8} || die "sed failed"
+}
+
+src_compile() {
+ # required by fPIC patch
+ cd ${S}/capi20 || die "capi20 directory not found"
+ ebegin "Updating autotools-generated files"
+ aclocal -I . || die "aclocal failed"
+ automake -a || die "automake failed"
+ WANT_AUTOCONF=2.5 autoconf || die "autoconf failed"
+ libtoolize -f -c || die "libtoolize failed"
+ eend $?
+ cd ${S}
+
+ emake subconfig || die "make subconfig failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+
+ # install docs
+ newdoc rcapid/README README.rcapid
+ dodoc scripts/makedev.sh ${FILESDIR}/README.gentoo
+ docinto pppdcapiplugin; dodoc pppdcapiplugin/README pppdcapiplugin/examples/*
+
+ # install init-script + init-config
+ dodir /etc/conf.d # BUG: w/o newconfd fails
+ newinitd ${FILESDIR}/capi.initd capi
+ newconfd ${FILESDIR}/capi.confd capi
+
+ # install USB hotplug stuff
+ insinto /etc/hotplug/blacklist.d
+ newins ${FILESDIR}/capi.blacklist capi
+ insinto /etc/hotplug/usb
+ newins ${FILESDIR}/capi.usermap capi.usermap
+ exeinto /etc/hotplug/usb
+ newexe ${FILESDIR}/capi.hotplug capi
+
+ # example config
+ insinto /etc
+ insopts -m 0600
+ doins ${FILESDIR}/capi.conf
+
+ # rcapid config for xinetd
+ insinto /etc/xinetd.d
+ insopts -m 0644
+ newins ${FILESDIR}/rcapid.xinetd rcapid
+
+ # install DSL/ISDN sample config
+ insinto /etc/ppp/peers
+ doins pppdcapiplugin/peers/t-dsl ${FILESDIR}/capi-isdn
+
+ # very useful tool ;-)
+ dobin scripts/isdncause
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Please read the instructions in:"
+ einfo "/usr/share/doc/${PF}/README.gentoo.gz"
+ einfo
+ einfo "Annotation for active AVM ISDN boards (B1 ISA/PCI, ...):"
+ einfo "If you run"
+ einfo " emerge isdn-firmware"
+ einfo "you will probably find your board's firmware in /lib/firmware."
+ einfo
+ einfo "If you have another active ISDN board, you should create"
+ einfo "/lib/firmware and copy there your board's firmware."
+ einfo
+ ewarn "If you're upgrading from an older capi4k-utils, you must recompile"
+ ewarn "the other packages on your system that link with libcapi after the"
+ ewarn "upgrade completes. To perform this action, please run revdep-rebuild"
+ ewarn "in package app-portage/gentoolkit."
+ ewarn
+}
diff --git a/net-dialup/capi4k-utils/files/capi.conf b/net-dialup/capi4k-utils/files/capi.conf
index 1d5acef096dd..bb1b3e916d84 100644
--- a/net-dialup/capi4k-utils/files/capi.conf
+++ b/net-dialup/capi4k-utils/files/capi.conf
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/capi4k-utils/files/capi.conf,v 1.3 2005/04/24 13:31:48 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/capi4k-utils/files/capi.conf,v 1.4 2005/05/16 08:49:33 genstef Exp $
# card file proto io irq mem cardnr options
#
@@ -9,6 +9,10 @@
# ISA/PCI devices #
##############################
+# These are examples! You have do setup your card correctly. 'P2P' means
+# 'point-to-point' (leased line) and has nothing to do with PPP. If you
+# don't have a leased line, then you must not set it.
+
### AVM B1 (you also have to install the firmware)
#b1isa b1.t4 DSS1 0x150 7 - - P2P
#b1pci b1.t4 DSS1 - - - -
@@ -80,6 +84,5 @@
#hfcpci - - - - - -
#hfcsusb - - - - - -
#hfcmulti - - - - - -
-#sedlfax ISAR.BIN - - - - -
+#sedlfax - - - - - -
#w6692pci - - - - - -
-
diff --git a/net-dialup/capi4k-utils/files/capi.confd b/net-dialup/capi4k-utils/files/capi.confd
index 4d0074247b2f..edc9d953b9ea 100644
--- a/net-dialup/capi4k-utils/files/capi.confd
+++ b/net-dialup/capi4k-utils/files/capi.confd
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/capi4k-utils/files/capi.confd,v 1.3 2005/04/09 14:35:00 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/capi4k-utils/files/capi.confd,v 1.4 2005/05/16 08:49:33 genstef Exp $
# do you want to use USB hotplug?
# if disabled, you have to configure your device in /etc/capi.conf
@@ -9,6 +9,9 @@ CAPI_HOTPLUG_USB="yes"
# should via hotplug added cards generate a beep?
CAPI_HOTPLUG_BEEP="yes"
+# should capi-usb handle hotplug-events for mISDN cards?
+CAPI_HOTPLUG_MISDN="yes"
+
# should CAPIDRV be loaded?
CAPI_LOAD_CAPIDRV="yes"
diff --git a/net-dialup/capi4k-utils/files/capi.hotplug b/net-dialup/capi4k-utils/files/capi.hotplug
index 91ad874d1d46..c866e229a8fc 100644
--- a/net-dialup/capi4k-utils/files/capi.hotplug
+++ b/net-dialup/capi4k-utils/files/capi.hotplug
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/capi4k-utils/files/capi.hotplug,v 1.5 2005/04/24 13:31:48 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/capi4k-utils/files/capi.hotplug,v 1.6 2005/05/16 08:49:33 genstef Exp $
. /etc/conf.d/capi
@@ -47,66 +47,74 @@ DEVTMP="${DEVICE##/proc/bus/usb/}"
USBBUS="${DEVTMP%%/*}"
USBDEV="${DEVTMP##*/}"
+# create/check lockfile
LOCK="/tmp/.capi-usb-${USBBUS}-${USBDEV}"
+/bin/ln 2>/dev/null -sn $$ ${LOCK} || exit 0
+trap "/bin/rm -f ${LOCK}" 0 1 2 3 15
+
+# select driver and firmware
LOADER=""
DRIVER=""
FIRMWARE=""
-
-# select driver and firmware
case "${VENDID}" in
"057c/0c00") # FRITZCARD!USB
- DRIVER="fcusb"
- ;;
+ DRIVER="fcusb";;
"057c/1000") # FRITZCARD!USB v2.0
- LOADER="avmusb"
- DRIVER="fcusb2"
- FIRMWARE="fus2base.frm"
- ;;
+ DRIVER="fcusb2"; LOADER="avmusb"; FIRMWARE="fus2base.frm";;
"057c/1900") # FRITZCARD!USB v2.1
- LOADER="avmusb"
- DRIVER="fcusb2"
- FIRMWARE="fus3base.frm"
- ;;
+ DRIVER="fcusb2"; LOADER="avmusb"; FIRMWARE="fus3base.frm";;
"057c/2000") # FRITZX!USB
- DRIVER="fxusb"
- ;;
+ DRIVER="fxusb";;
"057c/2200") # BlueFRITZ!USB
- LOADER="avmusb"
- DRIVER="bfusb"
- FIRMWARE="bfubase.frm"
- ;;
+ DRIVER="bfusb"; LOADER="avmusb"; FIRMWARE="bfubase.frm";;
"057c/2300") # FRITZDSL!USB
- LOADER="avmusb"
- DRIVER="fcdslusb"
- FIRMWARE="fdsubase.frm"
- ;;
+ DRIVER="fcdslusb"; LOADER="avmusb"; FIRMWARE="fdsubase.frm";;
"057c/2800") # FRITZX!USB OEM
- DRIVER="fxusb_CZ"
- ;;
+ DRIVER="fxusb_CZ";;
"057c/3500") # FRITZDSL!USB SL
- LOADER="avmusb"
- DRIVER="fcdslslusb"
- FIRMWARE="fdlubase.frm"
- ;;
+ DRIVER="fcdslslusb"; LOADER="avmusb"; FIRMWARE="fdlubase.frm";;
+ "0959/2bd0") # ISDN USB TA (Cologne Chip HFC-S USB based)
+ DRIVER="hfcsusb";;
+ "0675/1688") # DrayTek miniVigor 128 USB ISDN TA
+ DRIVER="hfcsusb";;
+ "07b0/0007") # Billion tiny USB ISDN TA 128
+ DRIVER="hfcsusb";;
+ "0742/2008") # Stollmann USB TA
+ DRIVER="hfcsusb";;
+ "0742/2009") # Aceex USB ISDN TA
+ DRIVER="hfcsusb";;
+ "0742/200a") # OEM USB ISDN TA
+ DRIVER="hfcsusb";;
+ "08e3/0301") # Olitec USB RNIS
+ DRIVER="hfcsusb";;
+ "07fa/0846") # Bewan Modem RNIS USB
+ DRIVER="hfcsusb";;
+ "07fa/0847") # Djinn Numeris USB
+ DRIVER="hfcsusb";;
+ "07b0/0006") # Twister ISDN TA
+ DRIVER="hfcsusb";;
*) # unknown card
syslog "unknown USB product: ${VENDID}"
- exit 1
+ exit 1;;
esac
+if [ "$DRIVER" = "hfcsusb" -a "$CAPI_HOTPLUG_MISDN" != "yes" ]; then
+ syslog "ignore mISDN card: ${DRIVER} (${VENDID})"
+ exit 0
+fi
+
case "$ACTION" in
add)
- /bin/ln 2>/dev/null -s "$$" "${LOCK}" || exit 0
-
# loading capi
if ! ( [ -f /proc/capi/capi20 ] || /sbin/modprobe -sq capi ); then
syslog "could not load CAPI!"
- beep_error; /bin/rm -f "${LOCK}"; exit 1
+ beep_error; exit 1
fi
# loading driver
if ! /sbin/modprobe -sq ${DRIVER}; then
syslog "could not load driver ${DRIVER}!"
- beep_error; /bin/rm -f "${LOCK}"; exit 1
+ beep_error; exit 1
fi
# loading firmware
@@ -119,7 +127,7 @@ case "$ACTION" in
$LOADER $DRIVER $USBDEV $FIRMWARE
else
syslog "firmware ${FIRMWARE} not found!"
- beep_error; /bin/rm -f "${LOCK}"; exit 1
+ beep_error; exit 1
fi
fi
@@ -128,7 +136,7 @@ case "$ACTION" in
syslog "could not load CAPIDRV!"
fi
- beep_ok; /bin/rm -f "${LOCK}"
+ beep_ok
;;
remove)
diff --git a/net-dialup/capi4k-utils/files/capi.usermap b/net-dialup/capi4k-utils/files/capi.usermap
index 0285836dd726..7f362041d600 100644
--- a/net-dialup/capi4k-utils/files/capi.usermap
+++ b/net-dialup/capi4k-utils/files/capi.usermap
@@ -1,8 +1,25 @@
-capi 0x0003 0x057c 0x0c00 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000
-capi 0x0003 0x057c 0x1000 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000
-capi 0x0003 0x057c 0x1900 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000
-capi 0x0003 0x057c 0x2000 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000
-capi 0x0003 0x057c 0x2200 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000
-capi 0x0003 0x057c 0x2300 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000
-capi 0x0003 0x057c 0x2800 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000
-capi 0x0003 0x057c 0x3500 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/capi4k-utils/files/capi.usermap,v 1.2 2005/05/16 08:49:33 genstef Exp $
+
+# AVM USB cards (ISDN/DSL)
+capi 0x0003 0x057c 0x0c00 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000
+capi 0x0003 0x057c 0x1000 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000
+capi 0x0003 0x057c 0x1900 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000
+capi 0x0003 0x057c 0x2000 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000
+capi 0x0003 0x057c 0x2200 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000
+capi 0x0003 0x057c 0x2300 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000
+capi 0x0003 0x057c 0x2800 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000
+capi 0x0003 0x057c 0x3500 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000
+
+# mISDN HFC-S USB
+capi 0x0003 0x0959 0x2bd0 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000
+capi 0x0003 0x0675 0x1688 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000
+capi 0x0003 0x07b0 0x0007 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000
+capi 0x0003 0x0742 0x2008 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000
+capi 0x0003 0x0742 0x2009 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000
+capi 0x0003 0x0742 0x200a 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000
+capi 0x0003 0x08e3 0x0301 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000
+capi 0x0003 0x07fa 0x0846 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000
+capi 0x0003 0x07fa 0x0847 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000
+capi 0x0003 0x07b0 0x0006 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000
diff --git a/net-dialup/capi4k-utils/files/digest-capi4k-utils-20050509 b/net-dialup/capi4k-utils/files/digest-capi4k-utils-20050509
new file mode 100644
index 000000000000..18cc113ee059
--- /dev/null
+++ b/net-dialup/capi4k-utils/files/digest-capi4k-utils-20050509
@@ -0,0 +1 @@
+MD5 16fd3dd947812a110227a6e7aa0ab021 capi4k-utils-2005-05-09.tar.gz 679827