summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrea Barisani <lcars@gentoo.org>2006-02-21 11:57:44 +0000
committerAndrea Barisani <lcars@gentoo.org>2006-02-21 11:57:44 +0000
commitd46d9bb2d3c83f3e02fe914479b4844eb3185bd4 (patch)
treecbea6ed5d2dd594531c40dc9d04e52bfc2fa75a1 /net-analyzer
parentVersion bump (diff)
downloadhistorical-d46d9bb2d3c83f3e02fe914479b4844eb3185bd4.tar.gz
historical-d46d9bb2d3c83f3e02fe914479b4844eb3185bd4.tar.bz2
historical-d46d9bb2d3c83f3e02fe914479b4844eb3185bd4.zip
new revision
Package-Manager: portage-2.0.54
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/scapy/ChangeLog9
-rw-r--r--net-analyzer/scapy/Manifest12
-rw-r--r--net-analyzer/scapy/files/digest-scapy-1.0.31
-rw-r--r--net-analyzer/scapy/scapy-1.0.3.ebuild54
4 files changed, 69 insertions, 7 deletions
diff --git a/net-analyzer/scapy/ChangeLog b/net-analyzer/scapy/ChangeLog
index 37fb57e5c3c9..793807ee369a 100644
--- a/net-analyzer/scapy/ChangeLog
+++ b/net-analyzer/scapy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/scapy
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/scapy/ChangeLog,v 1.4 2005/12/18 11:25:50 lcars Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/scapy/ChangeLog,v 1.5 2006/02/21 11:57:44 lcars Exp $
+
+*scapy-1.0.3 (21 Feb 2006)
+
+ 21 Feb 2006; Andrea Barisani <lcars@gentoo.org> +scapy-1.0.3.ebuild:
+ Version bump.
*scapy-1.0.2-r1 (18 Dec 2005)
diff --git a/net-analyzer/scapy/Manifest b/net-analyzer/scapy/Manifest
index eb30bddb3643..da1bda724158 100644
--- a/net-analyzer/scapy/Manifest
+++ b/net-analyzer/scapy/Manifest
@@ -1,7 +1,9 @@
-MD5 f7b6d1d2a9053cba45e52341a0a4d424 scapy-1.0.2.ebuild 1359
-MD5 c0cf59a965bb4c8fb3fba2080d854821 metadata.xml 355
-MD5 1724b00615eeefff03cbc1379b1ddf45 ChangeLog 753
-MD5 25ccc0be5ff2d7c0539def982c72e1d5 scapy-1.0.2-r1.ebuild 1580
-MD5 94bffde8f75a1b8f891fb780bfe15ca2 files/ethertypes 1317
+MD5 b0cab5ef20ab9a25e9a48a54a41153dd ChangeLog 869
MD5 6f8758347738221ce306b4af0fccdc64 files/digest-scapy-1.0.2 63
MD5 6f8758347738221ce306b4af0fccdc64 files/digest-scapy-1.0.2-r1 63
+MD5 7f07641aa19f9280523210a12ec3f053 files/digest-scapy-1.0.3 63
+MD5 94bffde8f75a1b8f891fb780bfe15ca2 files/ethertypes 1317
+MD5 c0cf59a965bb4c8fb3fba2080d854821 metadata.xml 355
+MD5 25ccc0be5ff2d7c0539def982c72e1d5 scapy-1.0.2-r1.ebuild 1580
+MD5 f7b6d1d2a9053cba45e52341a0a4d424 scapy-1.0.2.ebuild 1359
+MD5 0ef377e5474343953678154bc697308c scapy-1.0.3.ebuild 1577
diff --git a/net-analyzer/scapy/files/digest-scapy-1.0.3 b/net-analyzer/scapy/files/digest-scapy-1.0.3
new file mode 100644
index 000000000000..1c961ab500f2
--- /dev/null
+++ b/net-analyzer/scapy/files/digest-scapy-1.0.3
@@ -0,0 +1 @@
+MD5 bdc5247105312c61597d5c3e00dc1127 scapy-1.0.3.tar.gz 125145
diff --git a/net-analyzer/scapy/scapy-1.0.3.ebuild b/net-analyzer/scapy/scapy-1.0.3.ebuild
new file mode 100644
index 000000000000..8f9e87899ef3
--- /dev/null
+++ b/net-analyzer/scapy/scapy-1.0.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/scapy/scapy-1.0.3.ebuild,v 1.1 2006/02/21 11:57:44 lcars Exp $
+
+inherit python
+
+DESCRIPTION="A Python interactive packet manipulation program for mastering the network"
+HOMEPAGE="http://www.secdev.org/projects/scapy/"
+SRC_URI="http://www.secdev.org/projects/scapy/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="gnuplot pyx crypt graphviz imagemagick"
+
+DEPEND="virtual/python
+ net-analyzer/tcpdump
+ gnuplot? ( dev-python/gnuplot-py )
+ pyx? ( dev-python/pyx )
+ crypt? ( dev-python/pycrypto )
+ graphviz? ( media-gfx/graphviz )
+ imagemagick? ( media-gfx/imagemagick )"
+
+src_install() {
+ exeinto /usr/bin
+ newexe scapy.py scapy
+
+ # also install scapy as a importable python module
+ python_version
+ insinto /usr/$(get_libdir)/python${PYVER}/site-packages
+ doins scapy.py
+
+ insinto /etc
+ doins ${FILESDIR}/ethertypes
+ dodoc AUTHORS COPYING README changelog.txt
+ doman scapy.1.*
+ }
+
+pkg_postinst() {
+ python_mod_optimize
+
+ einfo ""
+ einfo "- Check http://www.secdev.org/projects/scapy/ for additional info"
+ einfo ""
+ einfo "- To subscribe to the mailing-list, send a mail to scapy.ml-subscribe(at)secdev.org"
+ einfo "- To send a mail to the mailing-list: scapy.ml(at)secdev.org"
+ einfo "- Web archive : http://news.gmane.org/gmane.comp.security.scapy.general"
+ einfo "- NNTP, RSS, etc : http://gmane.org/info.php?group=gmane.comp.security.scapy.general"
+ einfo ""
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}