summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-12-21 07:54:34 +0000
committerMike Frysinger <vapier@gentoo.org>2002-12-21 07:54:34 +0000
commit84a5f7e0531d5b5f0b170ae05eed0f9cd218bb09 (patch)
tree8d774330979e029d3e2a2c9ba495ca58caba9834 /net-analyzer
parentadded 'cjk' flag and the patch for 2-byte nicks (diff)
downloadhistorical-84a5f7e0531d5b5f0b170ae05eed0f9cd218bb09.tar.gz
historical-84a5f7e0531d5b5f0b170ae05eed0f9cd218bb09.tar.bz2
historical-84a5f7e0531d5b5f0b170ae05eed0f9cd218bb09.zip
intial ebuild
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/wepattack/ChangeLog8
-rw-r--r--net-analyzer/wepattack/files/digest-wepattack-0.1.31
-rw-r--r--net-analyzer/wepattack/wepattack-0.1.3.ebuild34
3 files changed, 43 insertions, 0 deletions
diff --git a/net-analyzer/wepattack/ChangeLog b/net-analyzer/wepattack/ChangeLog
new file mode 100644
index 000000000000..d722930c2121
--- /dev/null
+++ b/net-analyzer/wepattack/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-analyzer/wepattack
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wepattack/ChangeLog,v 1.1 2002/12/21 07:54:34 vapier Exp $
+
+*wepattack-0.1.3 (21 Dec 2002)
+
+ 21 Dec 2002; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me.
diff --git a/net-analyzer/wepattack/files/digest-wepattack-0.1.3 b/net-analyzer/wepattack/files/digest-wepattack-0.1.3
new file mode 100644
index 000000000000..4b33aff94895
--- /dev/null
+++ b/net-analyzer/wepattack/files/digest-wepattack-0.1.3
@@ -0,0 +1 @@
+MD5 be5a77902c992096dd95069bdade343b WepAttack-0.1.3.tar.gz 25063
diff --git a/net-analyzer/wepattack/wepattack-0.1.3.ebuild b/net-analyzer/wepattack/wepattack-0.1.3.ebuild
new file mode 100644
index 000000000000..1ac119a7e352
--- /dev/null
+++ b/net-analyzer/wepattack/wepattack-0.1.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wepattack/wepattack-0.1.3.ebuild,v 1.1 2002/12/21 07:54:34 vapier Exp $
+
+MY_P="WepAttack-${PV}"
+DESCRIPTION="WLAN tool for breaking 802.11 WEP keys"
+HOMEPAGE="http://wepattack.sourceforge.net/"
+SRC_URI="mirror://sourceforge/wepattack/${MY_P}.tar.gz"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="sys-libs/zlib
+ net-libs/libpcap
+ dev-libs/openssl
+ net-wireless/kismet"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ cd src
+ cp Makefile{,.old}
+ sed -e "/^CFLAGS=/s:=:=${CFLAGS} :" Makefile.old > Makefile
+ emake || die
+}
+
+src_install() {
+ dobin src/wepattack run/wepattack_{inc,word}
+ insinto /etc
+ doins conf/wepattack.conf
+ dodoc README
+}