summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-30 02:03:49 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-30 02:03:49 +0000
commit5b197d50c8e7073465eb76e576f1651ff9d01f9f (patch)
tree875e3bc59906169405fa9fe6df2975dbac0a265f /net-analyzer
parentChanged mkdir ${D} to dodir ${D} (diff)
downloadhistorical-5b197d50c8e7073465eb76e576f1651ff9d01f9f.tar.gz
historical-5b197d50c8e7073465eb76e576f1651ff9d01f9f.tar.bz2
historical-5b197d50c8e7073465eb76e576f1651ff9d01f9f.zip
Changed mkdir ${D} to dodir ${D}
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/p0f/p0f-1.8.2.ebuild16
-rw-r--r--net-analyzer/sarg/sarg-1.2.2.ebuild32
-rw-r--r--net-analyzer/scanlogd/scanlogd-2.2.ebuild17
3 files changed, 27 insertions, 38 deletions
diff --git a/net-analyzer/p0f/p0f-1.8.2.ebuild b/net-analyzer/p0f/p0f-1.8.2.ebuild
index 8bc6c421eda5..b38c568ddc2e 100644
--- a/net-analyzer/p0f/p0f-1.8.2.ebuild
+++ b/net-analyzer/p0f/p0f-1.8.2.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/p0f-1.8.2.ebuild,v 1.8 2002/10/04 21:09:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/p0f-1.8.2.ebuild,v 1.9 2002/11/30 02:00:45 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="p0f performs passive OS detection based on SYN packets."
SRC_URI="http://www.stearns.org/p0f/p0f-1.8.2.tgz"
HOMEPAGE="http://www.stearns.org/p0f/"
-DEPEND="net-libs/libpcap"
SLOT="0"
LICENSE="LGPL-2.1"
KEYWORDS="x86 sparc sparc64"
+DEPEND="net-libs/libpcap"
+
src_compile() {
patch < ${FILESDIR}/${P}-makefile.patch
cp ${FILESDIR}/${P}.rc p0f.rc
@@ -19,15 +19,11 @@ src_compile() {
}
src_install () {
- mkdir -p ${D}/usr/bin
- mkdir -p ${D}/usr/sbin
- mkdir -p ${D}/usr/share/doc
- mkdir -p ${D}/usr/share/man/man1
- mkdir -p ${D}/etc/init.d
- make DESTDIR=${D} install
+ dodir /usr/bin /usr/sbin /usr/share/doc /usr/share/man/man1 /etc/init.d
+ make DESTDIR=${D} install || die
}
-pkg_postinst () {
+pkg_postinst() {
einfo "You can start the p0f monitoring program on boot time by running"
einfo "rc-update add p0f default"
}
diff --git a/net-analyzer/sarg/sarg-1.2.2.ebuild b/net-analyzer/sarg/sarg-1.2.2.ebuild
index 5e653016dbe0..f90d5505f061 100644
--- a/net-analyzer/sarg/sarg-1.2.2.ebuild
+++ b/net-analyzer/sarg/sarg-1.2.2.ebuild
@@ -1,34 +1,30 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sarg/sarg-1.2.2.ebuild,v 1.2 2002/11/14 10:15:25 jhhudso Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sarg/sarg-1.2.2.ebuild,v 1.3 2002/11/30 02:03:49 vapier Exp $
DESCRIPTION="Sarg (Squid Analysis Report Generator) is a tool that allows you to view where your users are going to on the Internet."
HOMEPAGE="http://web.onda.com.br/orso/sarg.html"
SRC_URI="http://web.onda.com.br/orso/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-IUSE=""
+
DEPEND=""
RDEPEND=">=net-www/squid-2.4.7"
-S="${WORKDIR}/${P}"
src_compile() {
- rm -rf config.cache
- ./configure \
- --enable-bindir=/usr/bin \
- --enable-sysconfdir=/etc/sarg || die "./configure failed"
- emake || die
+ rm -rf config.cache
+ ./configure \
+ --enable-bindir=/usr/bin \
+ --enable-sysconfdir=/etc/sarg || die "./configure failed"
+ emake || die
}
-src_install () {
- mkdir ${D}/etc
- mkdir ${D}/etc/sarg
- mkdir ${D}/usr
- mkdir ${D}/usr/bin
- make \
- BINDIR=${D}/usr/bin \
- SYSCONFDIR=${D}/etc/sarg \
- install || die
+src_install() {
+ dodir /etc/sarg /usr/bin
+ make \
+ BINDIR=${D}/usr/bin \
+ SYSCONFDIR=${D}/etc/sarg \
+ install || die
}
-
diff --git a/net-analyzer/scanlogd/scanlogd-2.2.ebuild b/net-analyzer/scanlogd/scanlogd-2.2.ebuild
index 4ddc870baad0..85c01e18c543 100644
--- a/net-analyzer/scanlogd/scanlogd-2.2.ebuild
+++ b/net-analyzer/scanlogd/scanlogd-2.2.ebuild
@@ -1,32 +1,29 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/scanlogd/scanlogd-2.2.ebuild,v 1.6 2002/10/04 05:59:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/scanlogd/scanlogd-2.2.ebuild,v 1.7 2002/11/30 02:01:44 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Scanlogd- detects and logs TCP port scans"
SRC_URI="http://www.openwall.com/scanlogd/${P}.tar.gz"
-HOMEPAGE="http://www.openwall.com/scanlogd"
-
-DEPEND="virtual/glibc"
+HOMEPAGE="http://www.openwall.com/scanlogd/"
SLOT="0"
LICENSE="as-is"
KEYWORDS="x86 sparc sparc64"
+DEPEND="virtual/glibc"
+
src_compile() {
make linux || die
}
-src_install() {
- mkdir -p ${D}usr/sbin
- cp scanlogd ${D}usr/sbin || die
-
+src_install() {
+ dosbin scanlogd
doman scanlogd.8
exeinto /etc/init.d ; newexe ${FILESDIR}/scanlogd.rc scanlogd
}
-pkg_postinst () {
+pkg_postinst() {
einfo "Before you can run scanlogd you need to create the user "
einfo "scanlog by running the following command"
einfo "adduser -s /bin/false scanlogd"