summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-10 00:00:13 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-10 00:00:13 +0000
commit4617d963e553a09ce6db0983c5354f1b8bd9f98f (patch)
treec54f263d3b4f89738b2a91e2d87f000a8cdc3fb6 /net-analyzer
parentunmasked supersed (diff)
downloadhistorical-4617d963e553a09ce6db0983c5354f1b8bd9f98f.tar.gz
historical-4617d963e553a09ce6db0983c5354f1b8bd9f98f.tar.bz2
historical-4617d963e553a09ce6db0983c5354f1b8bd9f98f.zip
changed to using supersed instead of regular sed
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/portsentry/ChangeLog10
-rw-r--r--net-analyzer/portsentry/portsentry-1.1-r6.ebuild20
2 files changed, 17 insertions, 13 deletions
diff --git a/net-analyzer/portsentry/ChangeLog b/net-analyzer/portsentry/ChangeLog
index d6b6245ff778..050c1f62f9d9 100644
--- a/net-analyzer/portsentry/ChangeLog
+++ b/net-analyzer/portsentry/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for net-analyzer/portsentry
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/portsentry/ChangeLog,v 1.3 2002/07/21 20:53:24 owen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/portsentry/ChangeLog,v 1.4 2002/08/10 00:00:13 seemant Exp $
+*portsentry-1.1-r6 (1 Feb 2002)
+
+ 09 Aug 2002; Seemant Kulleen <seemant@gentoo.org> portsentry-1.1-r6.ebuild :
+
+ Switched the sed statements to sed -i (from supersed) and added supersed
+ as a build-time dependency.
21 Jul 2002; Owen Stampflee <owen@gentoo.org> :
@@ -10,8 +16,6 @@
28 Jun 2002; Thilo Bangert <bangert@gentoo.org> :
moved to net-analyzer - added SLOT - added LICENSE
-*portsentry-1.1-r6 (1 Feb 2002)
-
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
Added initial ChangeLog which should be updated whenever the package is
diff --git a/net-analyzer/portsentry/portsentry-1.1-r6.ebuild b/net-analyzer/portsentry/portsentry-1.1-r6.ebuild
index dce29f0774d6..71a78067cb27 100644
--- a/net-analyzer/portsentry/portsentry-1.1-r6.ebuild
+++ b/net-analyzer/portsentry/portsentry-1.1-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/portsentry/portsentry-1.1-r6.ebuild,v 1.5 2002/08/01 11:40:16 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/portsentry/portsentry-1.1-r6.ebuild,v 1.6 2002/08/10 00:00:13 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Automated port scan detector and response tool"
@@ -11,24 +11,24 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ppc"
-DEPEND="virtual/glibc"
+DEPEND="sys-apps/supersed"
src_unpack() {
unpack ${A} ; cd ${S}
# Setting the portsentry.conf file location
- sed -e 's:/usr/local/psionic/portsentry/portsentry.conf:/etc/portsentry/portsentry.conf:' \
- portsentry_config.h | cat > portsentry_config.h
+ sed -i 's:/usr/local/psionic/portsentry/portsentry.conf:/etc/portsentry/portsentry.conf:' \
+ portsentry_config.h
# presetting the other file locations in portsentry.conf
- sed -e 's:^IGNORE_FILE.*:IGNORE_FILE="/etc/portsentry/portsentry.ignore":g' \
- -e 's:^HISTORY_FILE.*:HISTORY_FILE="/etc/portsentry/portsentry.history":g' \
- -e 's:^BLOCKED_FILE.*:BLOCKED_FILE="/etc/portsentry/portsentry.blocked":g' \
- portsentry.conf | cat > portsentry.conf
+ sed -i -e 's:\(^IGNORE_FILE\).*:\1="/etc/portsentry/portsentry.ignore":g' \
+ -e 's:^\(HISTORY_FILE\).*:\1="/etc/portsentry/portsentry.history":g' \
+ -e 's:^\(BLOCKED_FILE\).*:\1="/etc/portsentry/portsentry.blocked":g' \
+ portsentry.conf
- sed -e "s:^set SENTRYDIR.*:set SENTRYDIR=/etc/portsentry:g" \
- ignore.csh | cat > ignore.csh
+ sed -i "s:^set SENTRYDIR.*:set SENTRYDIR=/etc/portsentry:g" \
+ ignore.csh
}
src_compile() {